1. Download our Official Android App: Forums for Android!

How to disable NTP_SERVER ?

Discussion in 'Android Lounge' started by kejlyCZ, May 30, 2011.

  1. kejlyCZ

    kejlyCZ Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    561
    Joined:
    Jun 6, 2010

    Jun 6, 2010
    561
    121
    93
    Male
    occupied
    Planet Earth
    I leave GPS turned on all the time (doesn't matter no programs using GPS are running in background) to be accessible when I start navigation. The problem is, that GPS is still trying to get time from NTP server in all cases. I work mostly underground with phone switched to airplane mode, but GPS is still trying to get time from NTP server every 13 minutes, which drains the battery a lot. I have just plain GPS enabled, A-GPS is turned off. Is there a possibility how to disable NTP synchronization initiated by GPS service without turning GPS off?
     

    Advertisement

  2. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #2
    Points:
    4,238
    Posts:
    39,126
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    39,126
    39,736
    4,238
    Male
    IT
    Pennsylvania
    There is a good deal of information about GPS settings here including about timeservers. Not that I understand all of it, but I thought it might help.
     
  3. Martimus

    Martimus One bite at a time...
    Rank:
    None
    Points:
    843
    Posts:
    19,533
    Joined:
    Jul 9, 2010

    Jul 9, 2010
    19,533
    4,047
    843
    Male
    Engineer
    'neath a cactus
    One thing you can try is to turn off automatic updates for time. Depending on your phone go to App Drawer -> Settings -> Date & Time and uncheck Automatic. At that point it "should" stop trying to get automatic time updates from the network.
     
    kejlyCZ likes this.
  4. kejlyCZ

    kejlyCZ Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    561
    Joined:
    Jun 6, 2010

    Jun 6, 2010
    561
    121
    93
    Male
    occupied
    Planet Earth
    Thanks for the advice, I've turned automatic synchronization off, hopefully it helps to save the battery.
     

Share This Page

Loading...