1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to fix Render Problem Failed to load AppCompat ActionBar with unknown error.

Discussion in 'Android Development' started by Edy Setyo Bayu Aji, Apr 18, 2019.

  1. Edy Setyo Bayu Aji

    Thread Starter

    upload_2019-4-18_11-29-52.png
    upload_2019-4-18_11-31-6.png
    upload_2019-4-18_11-31-26.png
    upload_2019-4-18_11-31-51.png
     


  2. Appventurez

    Appventurez Lurker

    Always use stable version of libraries. If you are developing an app, you don't want to face these type of errors.

    At the time of answering the current most stable version is 27.1.1 and second 28.0.0-rc02.

    I suggest use 27.1.1 until 28 stable version release.

    implementation 'com.android.support:appcompat-v7:27.1.1'
    • Sync again
    • No need of Invalidate/ Restart, Just restart would be okay. Or closing project and reopening from recent would be faster then restart.
    Track the support library release.


    Please change com.android.support:appcompat-v7:28.0.0-alpha3 to com.android.support:appcompat-v7:28.0.0-alpha1 in build.gradle(Module: App).

    And click File -> Invalidate Caches / Restart

    Of course you need internet access.

    It seems there is a bug in com.android.support:appcompat-v7:28.0.0-alpha3
     
  3. GameTheory

    GameTheory Android Expert

    Actually the current stable production version of the android.support library is as follows:
    Code (Text):
    1. implementation 'com.android.support:appcompat-v7:28.0.0'
    You can see for yourself in the following link:
    https://developer.android.com/topic/libraries/support-library/revisions.html

    Furthermore, you should not be using the android.support library anymore as it's been discontinued. You should now be using the stable version of the AndroidX library as follows:
    Code (Text):
    1. implementation 'androidx.appcompat:appcompat:1.0.2'
     
    Deleted User likes this.
Loading...

Share This Page

Loading...