1. Are you ready for the Galaxy S20? Here is everything we know so far!

how to flash a custom ROM if you are rooted with Unrevoked 3

Discussion in 'Android Devices' started by FLEMTP, Aug 4, 2010.


    FLEMTP Member
    Thread Starter

    Ok, I havent seen a thread on this yet, and im sure this will help those of you wanting to flash a custom ROM (even a rooted version of Froyo!)after rooting your phone with unrevoked 3.1

    Step ONE

    The first thing to do is to download and install Titanium Backup from the market, and backup all of your apps and user data.

    Once this is done, shut your phone off.


    Press and hold your volume up button. then press and release your power key while continuing to hold your volume up button.

    Your phone will boot into a white background menu that has green text at the top, followed by FASTBOOT highlighted in red, followed by text in orange, then 4 options. You can release your volume up key once this menu is up.

    Your 4 options are:

    reboot bootloader
    power down

    you want to scroll thru the options and make sure bootloader is highlighted.

    Press your power button once.

    then menu options will change to:

    Your phone will appear to be nonresponsive for a moment, and you will see some green text flash across below where this menu is. This is normal as the software reads your SD card.

    Once you can scroll thru the menu's with your volume up & down keys you want to highlight RECOVERY and press the power button once

    you will see the HTC EVO 4G menu for a moment.

    Then a menu will pop up that says "clockworkMod Recovery v2.5.0.1" (or whatever version is on your phone)

    your menu options will be:
    - reboot system now
    - apply SD card:update.zip
    - wipe data/factory reset
    - wipe cache partition
    - install zip from sdcard
    - nandroid
    - partitions menu
    - advanced
    - ++++go back++++

    scroll down and highlight "nandroid" and select it with the power button.

    The next menu will have 4 options:

    Advanced Restore
    ++++Go Back++++

    select "backup"

    Your screen will change to a picture of a box with an arrow and an android you will see text over top of that showing that it is backing up your phone and current ROM.

    While your phone is doing this, (this will take several minutes) select a download the custom ROM you want to flash onto your phone.

    If you're upgrading to a ROM that also has new radio and wimax updates (most of the 2.2 froyo ROMs will have these) download those to your desktop along with the custom ROM you want to flash.


    Once the backup is done on your phone, it will return to the ClockwordMod menu.

    select "reboot system now" and hit the power key. Your phone should reboot back into the normal home screen.

    once this is done, connect your phone to your computer via the USB cable, and make sure you select "disk drive" so you can move files to your SD card.

    move the custom ROM (plus any radio or wimax updates if applicable) to your SD card. There is no need to rename them.

    Reboot your phone into the ClockworkMod recovery as detailed above in step two.


    Once you're back into the clockwordMod menu you need to then select the option "wipe data/factory reset" and let it run, then select "wipe cache partition" and let it run.
    This allows you to clear your old rom off the main memory of your phone

    (dont panic, you did the titanium backup AND the nandroid backup, so you still have copies saved to your SD card should you need to revert back at a later time)

    Once those are both done you need to select "install zip from SD card"

    it will show you all the files and directories on your SD card. scroll down and select the file name of the custom ROM you want to flash and select it.

    The phone will now begin to install and flash the custom ROM you want. It will take a bit. The best thing to do is PUT YOUR PHONE DOWN and take a deep breath. You may need to reboot your phone after all is said and done. You will know when it is done flashing the custom ROM. I cannot recall if it rebooted automatically or not, so please forgive me.


    ***This will only apply to you if you need to flash a radio and/or wimax update as part of your ROM. This typically will only apply to froyo upgrades.***

    Once you've booted into your new ROM that you've flashed, you need to shut your phone down, and reboot into the ClockwordMod Recovery Menu as detailed above. You go through the same process as you did in step four to flash your ROM, except this time, instead of selecting the file name of the zipped ROM, you select first the Radio update zip, let it flash, then reboot into your home screen.

    Then, shut your phone down, reboot into the clockworkMod recovery, repeat the process for your wimax update. Reboot the phone when it is done.

    When you update the radio it will act a little funky. When rebooting after installing the radio update, you will get the green android guy next to a box with a yellow arrow showing him coming out of the box. So far, that appears to be normal.


    Once you've flashed your ROM, the radio, and the Wimax update (if applicable) then you find and open the android market, download titanium backup, and restore all your user data and applications.

    You may need to reboot your phone a few times before everything works properly. If your user settings arent there, dont panic!!!

    It took a few reboots before all of my settings and such returned to normal.

    If you have an application that is still not working right, then uninstall and reinstall it.

    To get the wireless tether working again, see wireless_tether_2_0_5-pre7.apk - android-wifi-tether - Wireless Tether for Root Users 2.0.5-pre7 *** EXPERIMENTAL *** - Project Hosting on Google Code to download a current working version of the wifi tether.

    I hope this does help those of you who are newer to android and used Unrevoked 3.1 to root your phone.

    CRAZYISH, jericko, M5Rahul and 8 others like this.

    1. Download the Forums for Android™ app!


  2. candy14510

    candy14510 Member

    This is great info...However....I can NOT get past recovery....it wont let me...It restarts my evo....I am sooo frustrated!!! My web pages with Flash....which is wy I wanted the 2.2....it looks like it is loading and right before it's done....it goes back to my home screen!!!! Other web pages without Flash/Video will load!!! So Weird!!!! I have skyfire too......I want to reset my phone to factory and start all over, but I can't.....and I have done that in the past (when i didn't like a froyo rom) and it worked, but they did something to not let me go to recovery!!!! I know there are LOTS of smart guys and girls out there, that can help me....I just hope it is soon!!!!
    thanks..and those are great directions!!! Oh and it wont let me use the "reflash.exe"....It tries to run and then says cant connect with the device...or lost connection!!! HELP!!!!

    FLEMTP Member
    Thread Starter

    I also wanted to point out if you want to find some custom ROMs, in addition to what is posted here on this forum, there are quite a few more listed on the
    XDA developers forum

    HTC Supersonic: EVO 4G - xda-developers

    I am currently running a rooted version of the stock sprint HTC Sense 2.2 froyo upgrade that I picked up here:
    HTC OTA Froyo 2.2, *FINAL*, build 3.36.651.6 (Rooted) Odexed - xda-developers

    it includes the radio and wimax updates which you HAVE to install after the ROM is flashed in order for the froyo upgrade to work properly.

    FLEMTP Member
    Thread Starter

    My first question is Are you rooted with unrevoked 3.1?

    If you are having a problem getting into the clockworkMod recovery, then i suggest you download Rom Manager from the market. It has an option where it will reboot you into the ClockworkMod recovery. try that.
  5. candy14510

    candy14510 Member

    OK....update...."when i go to recovery"...it appears that it is going and then I get the "evo phone/RED caution LOGO".....My phone appears to be forever "Locked" with this 2.2....and it is actually on my phone, the 2.2....I can see it in settings. I can't reflash...backup...restore.....WTF....someone please direct me to a site or link that can help me!!!!!
  6. candy14510

    candy14510 Member

    sorry, didn't see your post above....yes i rooted thru unrevoked3.....I do have the rom manager...I will see if that helps!!! Fingers crossed!!!! ;)
  7. candy14510

    candy14510 Member

    Heres what happend when trying that...Flash ClockworkMod Recovery -"an error accurred while attempting to run privileged commands!"
    when i just try "Reboot into Recovery"....Nothing happens.....crapp!!!!

    FLEMTP Member
    Thread Starter

    Ahh so you upgraded to the sprint OTA froyo... I see whats going on.

    You can TRY running the Sprint RUU for 1.47 which may work to bring you back to a 2.1, then you can run unrevoked 3.1 or whichever root method you want to, and then flash a rooted version of froyo.

    I dont know if that will work or if you are stuck waiting for someone to solve the root issue for the sprint OTA froyo update.

    Click this link, and download it to your **PC DESKTOP**


    plug your EVO in via the USB cable to your PC, enable USB debugging if you haven't done so already and it *may* restore you back to the previous version. I am not sure if this works after performing an OTA update to 2.2

    If it does indeed work, then you can root your phone using either simpleroot, or unrevoked, or the toast method, or whichever method you wish.
  9. candy14510

    candy14510 Member

    I did try running that....I was up until 3am last nite....I got the phone from best buy...i beleive they updated before i left the store....should have told them no!!!! I will try it again.....making sure I have the right one....will let you know....if it doesn't work...then am i screwed forever??? someone will figure this out right????
    by the way...the only root that would work is the unrevoked3....the others wouldn't...I tried several times...thanks I appreciate....I know there are others out there!!!
  10. candy14510

    candy14510 Member

    I thinks it not regonizing "Clockworkmod recovery".....and I can't seem to find it in my market place....is there another you would recommend to try to get it to recovery???
  11. FLEMTP

    FLEMTP Member
    Thread Starter

    Well hold on, go into your menu> settings > about phone > software information

    and post what it all says on there. Knowing what version of what software you are running will help a lot. unfortunately if you've already been upgraded to the sprint OTA Froyo by the folks at best buy, im pretty sure you're stuck with it until someone figures out how to root it.

    Maybe go back into best buy and exchange the handset for one that has NOT been upgraded to 2.2?

    Not being rooted is not the end of the world though, and im sure its only a matter of days until someone figures out how to root it. I wouldnt stress.. but if its THAT big of a deal, then go see if you can exchange it for a phone that has not been upgraded yet.
  12. candy14510

    candy14510 Member

    this is getting sooooo bad...I can't even get sync to work....can't hear the sound...that say's your connected on the computor....I've been thru this with my HTC TP2 and always got it to work, just being connected to the computor.....UHG!!!!
  13. uniquenameEVO

    uniquenameEVO Android Enthusiast

    You are effectively unrooted for now. Be patient, your day will come, I am sure.

    Also, remember to reboot in between each thing. Rom->reboot->radio>reboot-Wwimax->reboot

    And, Ti backup may not work properly in the beginning. If not, click problems and it will prompt to install beebox. That should help.
    FLEMTP likes this.
  14. FLEMTP

    FLEMTP Member
    Thread Starter

    yes, it prompted me to do just that and after installing it worked like a charm. I should have mentioned that in my first post. Thank you!
  15. 355spider

    355spider Well-Known Member

    Thank you so much for this guide for newbs like me.
  16. candy14510

    candy14510 Member

    My Settings:
    Android Vrs 2.2
    Baseband vrs
    Kernel htc-kernel@and18-2#58
    Build # 3.26.651.6 CL218634 release-keys
    Software # 3.26.651.6
    Browser vrs webkit3.1
    PRI vrs 1.40_003
    PRL vrs 60668

  17. candy14510

    candy14510 Member

    also...when I try RUU, which I have before...I get "Error(170)USB connection Error"
    I show I am connected...
    sorry for previouse comment about not hearing or seeing connection....It comes and goes...now I have it.....soooo weird!!!!!!
    thanks for all your help!!!!!
  18. candy14510

    candy14510 Member

    ALSO....interesting facts...when I get to bootloader...my computor is connected....I go to Hboot....it "disconnects"....and makes a triple sound,,in stead of ...da.da....it's da.da.da..in a down pitch....I appreciate you all trying to help....I understand I may just have to wait
  19. candy14510

    candy14510 Member

    So....what if I jsut deleted the android update off my SD card....will my phone implode???lol seriousley considering it!!!!
  20. candy14510

    candy14510 Member

    ok...so the new 2.2 disabled my hboot driver on my PC....wow....I might just figure this out!!! Reinstalled it...and i'm geting progress.....will let you know!
  21. braxx

    braxx Newbie

    Just a heads up to us noobies. When you update the radio it will act a little funky. When rebooting after installing the radio update, you will get the green android guy next to a box with a yellow arrow showing him comming out of the box. So far, that appears to be normal.

    EDIT: wimax update does this also
  22. FLEMTP

    FLEMTP Member
    Thread Starter

    You are already upgraded to 2.2... unfortunately you cannot root until someone finds a way to root 2.2

    there is nothing you can do.. sorry to say!
    candy14510 likes this.
  23. uniquenameEVO

    uniquenameEVO Android Enthusiast

    It is normal :)

    Scared the crap out of me the first time ;)
  24. 355spider

    355spider Well-Known Member

    I would like to add in my case that I had to wipe cache and data for this to work but other than that it was excellent. Thanks for the tutorial.
  25. candy14510

    candy14510 Member

    Thanks, I am so impatient...but I will just let it go!!!!! Hope someone comes up with it soon!!!!!

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
Similar Threads - flash custom ROM
  1. kylabeardad
  2. andriodadmirer
  3. MrOldCrypto
  4. Milo Williamson
  5. App Update
  6. Klausinator
  7. imnothere
  8. kumaranil13k
  9. emiller413
  10. mnjx46

Share This Page