1. Are you ready for the Galaxy S20? Here is everything we know so far!

[How-To] Force the official Android 2.2.1 update for the Motorola Droid (FRG83D)

Discussion in 'Android Devices' started by kratos, Dec 7, 2010.

  1. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    Credit for the template for this guide goes to Trident
    Credit for the update.zip goes to timhow

    -Do not attempt to install this to anything other than the Motorola Droid.
    -If you are running anything other than stock 2.2, you will receive an error.
    -If you attempt to apply this update with a custom ROM installed, the update will NOT apply.

    Use the appropriate guide for your current set up.

    Phone and Computer:

    Phone ONLY:


    Trident likes this.

    1. Download the Forums for Android™ app!


  2. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    What You'll Need:
    - A MicroSD Card inserted into your Droid
    - A USB Data Cable

    1. Download the update.zip File:
    -To begin, you will first need to download the update.zip file and save it to your computer.
    -You will need to have file extensions showing if you should have to rename the file, otherwise you will effectively name the file update.zip.zip. This is what causes errors with the instillation. When extensions aren't on, it assumes that anything you type in for the file name should go before the extension. Both Windows and OSX have options for this in Explorer and Finder respectively. Configuring this setting should, however, not be necessary since the file will already come downloaded to you bearing the proper name by default, so do not rename the file!

    Important: If you are a Mac user using the Safari browser, you
  3. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    What You'll Need:
    - A MicroSD Card inserted into your Droid
    - An Internet Connection

    1. Install Astro File Manager:
    Install Astro File Manager for free from the Android Market if you don
    coloradogregg likes this.
  4. DasMuse

    DasMuse Member

    what does it mean when my phone stays at this screen and won't go to the menu?

  5. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    Did you hold the volume up button and then press the camera button (completely) at the same time?

  6. coloradogregg

    coloradogregg Member

    I followed all the instructions just using my phone and everything went fine but on my "about phone" page it still says my version is 2.2 and build number is still FRG22D.

    Does this mean it didn't work?
  7. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    Reboot your phone and if it still says 2.2 and FRG22D, then try it again.

    Also, if you try it again, then maybe try from a computer instead of the phone only method.

  8. coloradogregg

    coloradogregg Member

    OK, I think I know what happened. I'll post it if anybody else has the same problem they will know.

    When I did the same thing and forced the FRG22D update a few months ago I never erased it from my Astro folder. So when I downloaded this one it named it update-1.zip. When I went into recovery and preformed the update I'm guessing it just used the old update.zip file and just redid what I had done a few months ago.

    So I deleted the old file and renamed the new one and preformed the update and now I'm good.
  9. gunit34328

    gunit34328 Newbie

    besides losing root is there any problem if im rooted and i install the new update thats being sent to my phone? would i have to unroot my phone back to stock before i update? i've had the update sent to my phone.
  10. I have a rooted phone with the notification. How do I get rid of the notification?
  11. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    If you try to install this update while rooted, it will fail. If you really want it, Pete has a rooted FRG83 (NOTE THE MISSING "D"). You can either try that one, wait for Pete to release a rooted version of FRG83D, or install a custom ROM. Almost all ROMs are currently running on 2.2.1 and most will probably be running on 2.3 shortly.

    This sticky has links to a lot of useful information: http://androidforums.com/droid-all-...de-updated-october-11th-2010-11-05pm-est.html.

    This link is what you are looking for: http://androidforums.com/droid-all-things-root/179578-how-do-i-prevent-ota-updates.html#post1609305

    Edit: I am currently working to find the proper numbers that need to be updated in the build.prop. This method will not work until I get those numbers. I'll update this post once I find them.

    Edit 2: I believe the string is 60505. So, follow the instructions in the link above, but replace the FRG22D with FRG83D and the 50454 with 60505.

  12. Fifty9Dunes

    Fifty9Dunes Newbie

    Thanks to Kratos and all for getting the update.zip online.

    Now I know that I probably should have been more to the book on updating - but I was curious what would happen since I was rooted and running stock 2.2 FRG22D before the update


    - VOILA - I'm still rooted and the update worked just fine - now showing 2.2.1 & FRG83D and I still have Superuser permissions.

    Don't know if this helps or hinders anyone - but just wanted to point that out.

    SO glad to have Exchange back and not running Touchdown anymore - those icons were so small on the OG Droid!!!
  13. Unsuccess!

    Followed the steps, rebooted, and the notification was still there. Running Bugless Beast .5.
  14. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    Ok, I didn't know for sure if that would work or not. I got those numbers from the FRG83 odexed and deodexed downloads on Pete's website.

    I'll look into it some more and see if we can figure this out.

  15. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    Ok, I cannot guarantee that this will work because this is for a sapphire phone and not a sholes phone, but it doesn't hurt to try. Just remember to make a backup/copy of the original file first.


    Give that a try and see if that works. I would assume that since the build is the same, then the release key would be too, but am not 100%

    If it doesn't, no worries. Replace the new file with the backed up one. I am still trying to figure this out.

    Booby_McNipples likes this.
  16. stratjb

    stratjb Lurker

    Did you check to verify the SuperUser still works by starting an App that requires it? I'm fairly certain this will break it just like the last OTA did. If you don't have a custom recovery it will install OK but should still break root.
  17. [​IMG]
  18. zandroid

    zandroid Android Enthusiast

    I just got the notification tonight and began the application process (note that I am not rooted, but WAS about a month ago, but am back to stock). I walked away while it was doing its' thing and came back to find that I am stock on an infinite boot loop of the Droid Eye. I've powered down, battery pulled, etc. I booted into recovery mode and while I do have the option of booting to the update.zip, I have no recollection of what the file could be. Could it be the newly downloaded Verizon update?
  19. Crush_Buds

    Crush_Buds Member

    So I'm rooted, and was stupid and tried to install the update once it was pushed to my phone last night. It obviously didn't update and now I have the FRG83D from this site, and I cannot get it for the life of me to work correctly. I keep getting a "signtature verification failed" error and have tried re-downloading the update numerous times and still no luck. I have also tried the deodexded version with no luck. Any help? Am I SOL because I attempted to install the OTA update originally?

    Fixed. I used this to do it.

    How to Fix / Bypass Android No Signature, Verification Failed Error | Jaxov
  20. Dark Jedi

    Dark Jedi Guest

    Updated with not a single problem. thanks
  21. UncleMike

    UncleMike Android Expert

    The only reason I rooted my Droid was to stop some of the bloatware from running and/or appearing in the app drawer. To do this I renamed the files from .apk to .bak. I have since installed Barnacle, but have only used to make sure it works in case I need to use it in an emergency. (For now) I have no interest in custom roms or anything beyond what I've done, and don't know anything about it.

    When I got the update notification I selected Install Later, then renamed those bloatware files from .bak back to .apk, thinking I would be okay. Now I just wanted to check here and make sure before proceeding.

    Regarding the apparently conflicting information quoted above, it appears to me that there's an assumption that those who root also go further, into custom recovery and roms, and that these additional steps are what cause a problem with the updates. Is that correct?
  22. stratjb

    stratjb Lurker

    I rooted with Soup or Root but kept the standard recovery meaning I never needed to use SPRecovery or Clockwork Recovery. It appears that these are what block the OTA from working.

    I was able to apply the update using these instructions but my root was broken after the update. I tried Z4Root and Soup or Root to re-root but both failed. Ended up using Super One Click Root to get root permissions running properly again.

    So basically, you can be rooted AND (at least) force the update.zip to install using these instructions. Root will be broken (was for me) meaning that apps that need root would no longer work. The SuperUser icon was still in my App drawer but no root required apps worked.
  23. kratos

    kratos Back on my throne!!!
    VIP Member Thread Starter

    The rooting tools available use a script to block the ota from applying, but you would have to manually block the notification. However, if you force the update, then it would force the system to apply it and, thus, break root.Kratos
  24. REMilk

    REMilk Lurker

    I received the following error when updating my Droid 1. I tried by downloadong to DRotd twice and once via the PC.

    assert failed: apply-patch-check("/system/app/GoogleGoggles.odex". "c8addb608879dc93d9de316920c9eb659414c84". "5d8386b8134e3956224a584e94748f5714a673a8c".
    E: Error in /sdcard/update.zip
    (Status 7)
    Installation aborted.

    Thank you for any assistance.

  25. UncleMike

    UncleMike Android Expert

    After reading the replies here, and having already renamed my .bak files back to .apk, I let the OTA update proceed. All went well. I lost root access as expected, but got it back quickly with SuperOneClick.

    I'm still confused by what you said above. Clearly my rooted Droid had nothing that blocked the OTA update. Are you using the term "rooting" to refer to more than just gaining root access to the device? I'm not trying to argue, I just want to clear up my confusion.

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page