1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to get 3g signal

Discussion in 'Android Help' started by Network 3G, Mar 20, 2016.

  1. Network 3G

    Network 3G Guest
    Thread Starter

    I'm using a galaxy s3 korean version (SHVE210L) here in the Philippines. My problem is that I never get a 3G signal the signal is always 2G that is why i cannot rely on my data network. What could be the possible solution? Thank you

     


    Khpv likes this.
  2. Best Answer:
    Post #4 by Jfalls63, Mar 20, 2016 (3 points)
  3. The_Chief

    The_Chief Accept no imitations!
    VIP Member

    Contact your provider and see if they have 3G service in your area. Your phone cannot receive what isn't there.
     
  4. chanchan05

    chanchan05 The Doctor

    1. Make sure you have 3G active in the phone. Go to settings>network connections>more networks>mobile networks. You should be using WCDMA/GSM or WCDMA only. WCDMA is 3G. If you have GSM only, then you have the 3G antenna turned off, so you obviously won't get a 3G signal.

    2. Make sure there is 3G coverage in your area. Do other phones have 3G in your area?

    EDIT:
    3. Make sure your network supports the phone. I think your phone will work with Globe 3G, since it has 850/2100 bands. It won't work for Smart who uses 1900/2100 bands, and your phone does not have 1900.
     
    #3 chanchan05, Mar 20, 2016
    Last edited: Mar 20, 2016
    Khpv likes this.
  5. Jfalls63

    Jfalls63 Android Expert

  6. chanchan05

    chanchan05 The Doctor

    LOL. According to that website, I mixed up the networks the phone 3G should work on. Should work on Smart, not on Globe.
     
    Jfalls63 likes this.
  7. mikedt

    mikedt 你好

    Is that a Korea only CDMA or Docomo version or something? Which probably has 2G GSM as well, but not 3G HSDPA modes, which would be required in Philippines.
     
Loading...

Share This Page

Loading...