1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to get back to HBOOT?

Discussion in 'Android Devices' started by pat_the_jhawk, Jun 24, 2013.

  1. pat_the_jhawk

    pat_the_jhawk Lurker
    Thread Starter

    I have been unable to find a clear solution to something that has been plaguing my new Evo 4g LTE.

    What I have:
    HBOOT 2.09

    I was hoping to try CyanogenMod 10, and I even flashed the CM10 boot.img file using fastboot. After trying it, and finding my touchscreen to be unresponsive, I read that other users have had similar issues when using the most up to date firmware from HTC (version 3.16.651.3). After being unable to find a fix for the touchscreen issue, I attempted to simply restore the backup I made using TWRP to just go back to the Sense ROM.

    At this point, my restore attempt failed, and I could no longer boot past the HTC splash screen. After reading some other posts, I decided to try locking my bootloader again to see if that would make a difference (it didn't).

    THEN, TWRP recovery would not open, I could access HBOOT, then when I press recovery, it would just reload HBOOT and do nothing else. I read that you need an unlocked bootloader to flash recovery again, so I simply ran the fastboot unlock command again, which worked, but now I appear to be soft-bricked (cannot get past the HTC splash screen).

    So my question is this: how can I get back to HBOOT when all I can do is see the splash screen?

    TL;DR - I messed up somewhere, and turned my brand new Evo into a paperweight, and am desperately seeking help.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Brian706

    Brian706 I like turtles!
    Moderator

    Try either with adb command: adb reboot bootloader

    or try holding the power button down for about 10 seconds to power down/simulate a battery pull, then try to boot into the bootloader.
     
    ocnbrze, Granite1 and pat_the_jhawk like this.
  3. pat_the_jhawk

    pat_the_jhawk Lurker
    Thread Starter

    It worked! I was not able to use the adb command because adb could not see the phone, but I was able to get back to HBOOT as well as TWRP recovery by long-pressing the power key until it turned off, then booting into HBOOT using Volume down + Power.

    So, I am now in Recovery, and I attempted to restore using the full TWRP backup I made before I started having all these problems, but it failed at the 'mounting sdcard' step, and then failed to boot (stuck at HTC splash). Long pressing power, then booting into HBOOT worked again.

    So what should I try next to get booted up? Eventually I would like to end up at Stock with root.
     
  4. Brian706

    Brian706 I like turtles!
    Moderator

    You're going to have to bare with me because I don't have your device. So, my resources are limited and I hesitate to tell you which files to flash because I would hate to choose the wrong one. So hopefully you'll be able to help me help you :)

    First of all can you tell me the info from the top of your bootloader screen? About 3 or 4 lines of text.

    I'm thinking it might just be best to run the RUU if possible, which will return the phone completely stock and then from there you would unlock bootloader, flash recovery, then flash superuser through recovery which would have you stock rooted.

    Alternatively if you know of a flashable stock rom, you could try flashing that. Right now I'm leaning toward that the phone is s-on and the reason you can't boot up is because the kernel isn't flashing.

    If you want to boot up your current rom, we can probably flash the boot.img

    If you are wanting to return to stock rooted anyway, it may be best just to RUU.

    Either way, the bootloader information will be helpful.
     
    ocnbrze, Granite1 and pat_the_jhawk like this.
  5. pat_the_jhawk

    pat_the_jhawk Lurker
    Thread Starter

    Tampered
    Unlocked
    S-On
    Radio-1.12.11.1210

    I know of the RUU's stored at AndroidFiles.org, but none of them appear to match my radio version, which is why I was hesitant to try it earlier. Does it matter if the RUU does not match the radio version?

    P.s. adb now shows me device when I run 'fastboot devices', so that is a plus!
     
  6. Brian706

    Brian706 I like turtles!
    Moderator

    I'm assuming that the bottom one here: Shipped ROMs would be your best bet. I'm assuming you have the firmware for the latest ota but there is no RUU for that version...

    Do you know if the latest OTA updated the hboot version as well? If so, you may be out of luck with the RUU, but if not, you may be able to still use the older RUU if we lower the main version on the phone...

    If you want to see if you can get your rom to boot, try putting the rom you are using on the pc and extract the boot.img from the zip. Place the boot.img in your adb/fastboot folder. Put the phone in fastboot usb mode and use: fastboot flash boot boot.img and see if it will boot up after that.

    This would be the rom you restored your backup from I believe... On Evo 3d, we are having to use an older gingerbread hboot to use jellybean roms. Not sure if it's similar for your device, but something like that could be the reason you got stuck after flashing that rom. Could be an hboot incompatibility.
     
    ocnbrze, Granite1 and pat_the_jhawk like this.
  7. pat_the_jhawk

    pat_the_jhawk Lurker
    Thread Starter

    I got booted up!

    Here is what I did:
    -When I first went into Recovery to mount the SD card so I could drop a ROM on it, I saw that the 'internal SD' had 0MB on it, and Windows asked me to format it. Obviously, I have no idea if this phone's internal memory is formatted as FAT32 or NTFS, so I went back to the 'Wipe' feature in TWRP, and told it to wipe internal sd only. While doing that, it formatted the internal storage, and made it accessible via Windows.

    -Then, I used TWRP's 'Install' function to flash the 3.16.651.3 Stock Rooted Deodex ROM from this page.
    -At this point, it still would not boot up, just sit at the HTC splash screen with the 'this is a developer version, etc."
    -Then, at your recommendation, I extracted all the files from the stock ROM I downloaded into the Platform-Tools folder which contains my adb.exe file, then did the 'fastboot flash boot boot.img' command, which was successful.

    -At this point, I pressed 'reboot' in TWRP, and I booted up without issue (did take 5 minutes though).

    Do you take donations by any chance? You have saved me from having to buy a new phone or send it off somewhere shady to get unbricked.

    Thank you very much for your help.
     
  8. Granite1

    Granite1 Zercron Encrusted Tweezer

    Brian, thanks for taking care of this!! :)

    I just noticed this thread, my apologies. :eek:

    @ pat,

    I noticed you were on the latest hboot, so you've got the latest firmware. When you took the latest OTA it updated the touchpanel firmware. Unfortunately this caused the unresponsiveness while on CM. With the new firmware you can only flash Sense roms.

    The method you used to flash the rom above is the way you'll need to flash any Sense based rom, unless you get S-off.

    If you'd like, I can move this thread over to the LTEvo root forum, and we can show you a bunch of root related info for our phone. :)
     
    ocnbrze and Brian706 like this.
  9. Brian706

    Brian706 I like turtles!
    Moderator

    Glad you are up and running :) First boot after a fresh rom install usually takes a lot longer. After the initial boot, it should be faster when you restart the phone.

    Lol, no I don't take donations. I help because I want to! I appreciate the gesture but the thanks is plenty! ;)



    No problem Granite!

    What Granite said about flashing roms like this from here on out is true, but to add to it, I will provide you with an alternative that in my opionion is simpler.

    While the phone is s-on, when you flash a rom, it will not flash the kernel (boot.img) along with the rom. This is why you have to flash it separately.

    Instead of flashing the rom, then extracting the boot.img, then flashing the boot.img separately; you can boot your recovery into the phones memory through fastboot to flash the rom, which will actually allow you to flash the rom and kernel together.

    Both methods require the use of fastboot but this will save some steps.
    Keep your recovery.img in your fastboot folder.

    When you want to change roms place the rom on your sd card like always.
    Use fastboot command: fastboot boot recovery.img

    That will boot up your TWRP recovery into the phones memory temporarily (one time use). Theoretically you could keep the stock recovery and use the boot method each time. While it may seem the same as accessing bootloader and selecting recovery, it's actually different. Booting the recovery like this will allow you to just select the rom once in recovery and flash normally. It will flash the rom and kernel and boot up fine eliminating the need to flash boot.img separately.

    Hope that made sense. I'm in a hurry so my thoughts are a little scattered :p
     
    ocnbrze likes this.
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    and just to add we now have a few different ways to get s-off. so far the best one to do it is the moonshine method. it is pretty simple and very straight forward. i just recently added them to the http://androidforums.com/evo-4g-lte-all-things-root/605567-ltevo-rooting-dummies-complete-guide.html. once you get s-off, you are more then welcome to flash any aosp rom you like. you will need to downgrade your touch panel though.

    here is also a guide about firmware as well that has more info:
    http://androidforums.com/evo-4g-lte-all-things-root/689274-guide-evo-4g-lte-firmware-guide.html
     
    Granite1 and Brian706 like this.

HTC EVO 4G LTE Forum

The HTC EVO 4G LTE release date was May 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 1GB RAM, Snapdragon S4 Plus processor, and 2000mAh battery.

May 2012
Release Date
0
Reviews
Loading...
Similar Threads - HBOOT
  1. DylanFlume
    Replies:
    6
    Views:
    2,812

Share This Page

Loading...