1. Download our Official Android App: Forums for Android!

Support How to get buttons to light up?

Discussion in 'Android Devices' started by angiembfl, Oct 19, 2011.

  1. angiembfl

    angiembfl Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    183
    Joined:
    May 3, 2011

    May 3, 2011
    183
    7
    36
    NE FL
    Here's a dumb question. How do I get my hardware buttons along the bottom of the screen to light up? I just got this X today and I noticed earlier that they were working but now they're not. I don't see any kind of setting for it. I have the .605 update if that makes a difference.
     

    Advertisement

  2. Wally World

    Wally World Android Expert
    Rank:
    None
    Points:
    78
    Posts:
    981
    Joined:
    Dec 28, 2010

    Dec 28, 2010
    981
    61
    78
    The hard keys have a mind of their own. It's the software most of the time. Sometimes rebooting helps.
     
  3. UrsusVIIILXXXVII

    UrsusVIIILXXXVII Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    330
    Joined:
    Dec 14, 2010

    Dec 14, 2010
    330
    65
    73
    It has to do with the light sensor on the left side of the ear speaker. Low light; buttons light up, full light; buttons stay off. It's also what turns off the screen when you hold the phone to your ear during calls.
     
  4. bigbadwulff

    bigbadwulff Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    2,442
    Joined:
    Jun 15, 2010

    Jun 15, 2010
    2,442
    200
    143
    Mine haven't worked for so long I forgot they ever worked. My light sensor works. Checked it with an app. Buttons refuse to light up.
     
  5. qetuop

    qetuop Newbie
    Rank:
    None
    Points:
    16
    Posts:
    43
    Joined:
    Jul 8, 2010

    Jul 8, 2010
    43
    7
    16
    Mine worked until the GB update. I can see the sensor value change in an app (Elixir) but there seems to be some bug. I haven't seen a pattern yet but it may happen when the room goes dark. The sensor doesn't seem to detect the change unless I lock/unlock the phone.

    It's very frustrating since it did work fine until I updated :(
     
  6. PACAnesFan

    PACAnesFan Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Nov 22, 2010

    Nov 22, 2010
    201
    12
    38
    Agree with all above. There is some sort of bug with the sensor. Upon startup, the lights work fine. After some time, they stop responding and remain off. A reboot usually fixes the issue.

    As an aside, if you put a 2nd-init custom ROM on your phone, the problem with the sensor does not occur.
     

Share This Page

Loading...