1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to: ***get hulu working on dl30 froyo***

Discussion in 'Android Devices' started by neotrixy, Feb 2, 2011.

  1. neotrixy

    neotrixy Well-Known Member
    Thread Starter

    Download mod file from :
    [MOD] Hulu on 2.2 Fascinate - xda-developers

    • put it on your SD card
    • make sure you have Adobe flash (get from market place if not already) installed
    • and make sure that its not set to update automatically (uncheck box if needed)
    • then boot into cwm
    • install that .zip file you downloaded and put on sd card
    • then install dolphin browser HD (or mini, which i prefer)
    • and go to hulu.com
    • and it enjoy!!!
    • Hit the thanks button if I helped you!

    NOsquid and tgulch22 like this.

    1. Download the Forums for Android™ app!


  2. tgulch22

    tgulch22 Android Enthusiast

    Will this work on EB01?
  3. nklenchik

    nklenchik Android Enthusiast

    Yeah it works
    tgulch22 likes this.
  4. tgulch22

    tgulch22 Android Enthusiast

    Hmm, I used to use Dolphin all the time, but decided to try and keep the stock browser (SC 2.1) wonder if it will work...Will let you know if it will work with stock browser
  5. saps

    saps Extreme Android User

    Doubt it but report back please
  6. tgulch22

    tgulch22 Android Enthusiast

    Well I cant get it to work at all, on dolphin, stock, or even Hulu App...It starts loading the video and then I get that it isnt supported on my platform....
  7. djb28

    djb28 Android Enthusiast

    I wonder if what i did for EB01 will work for DL30.

    Uninstall flash 10.1

    go into recovery mode. Clear cache/ wipe Dalvik

    run hulu zip

    restart phone. Instal hulu apk with file expert

    Run hulu .

    If i install flash again. Hulu stops working. Even if i click do not update.

    I was going to try freezing the Hulu app with Titanium and then installing flash and unchecking updates, Then unfreeze hulu, To see if it would still work.

    I didnt get around to it. I was too busy watching The Community on Hulu! lol
  8. tgulch22

    tgulch22 Android Enthusiast

    Mine wont work that way. Superclean 2.1v Without flash 10.1 I get the missing plug in symbol on the hulu app...(the little blue lego)
  9. NOsquid

    NOsquid Android Enthusiast

    I had a hell of a time getting this to work on eb01 + voodoo, had to call my buddy Odin because I was at my wits end
  10. tgulch22

    tgulch22 Android Enthusiast

    And what did ole Odin have to say about it?
  11. NOsquid

    NOsquid Android Enthusiast

    I do have it working in eb01 super clean, with voodoo, a bit of a pyrrhic victory though :(

    If you really want it, I had to disable voodoo, odin di01, eb01 modem, and clockwork. Then flash newer clockwork in cwm. Then flash super clean NON voodoo, boot/install flash from market, then flash the hulu_flash .zip. Then install hulu app from your sd. If it works, then flash the voodoo kernel separately to convert. Then check again, if it still works restore your apps.
  12. NOsquid

    NOsquid Android Enthusiast

    You did install flash from market first right?
  13. saps

    saps Extreme Android User

    Wow, so no straight from voodoo then
  14. NOsquid

    NOsquid Android Enthusiast

    Maybe my case is an anomaly or I overlooked something, but I'm pretty sure I tried every easier way.

    I reproduced this to check, several Odin trips occurred. For me at least I can't flash that hulu zip after voodoo and have it work. Did it with SC 2.0 and 2.1. Other zips (eg black gmail) flash fine post voodoo.

    Don't ask me I just work here :)
  15. tgulch22

    tgulch22 Android Enthusiast

    I tried it both with and without flash from the market. I have tried everything, and it just will not work
  16. NOsquid

    NOsquid Android Enthusiast

    Been there bud :(
  17. tgulch22

    tgulch22 Android Enthusiast

    Can we just disable voodoo, reboot into recovery, flash the zip, then eneable voodoo and reboot?
  18. saps

    saps Extreme Android User

    See thats what perplexes me. Voodoo should not interfere with this
  19. NOsquid

    NOsquid Android Enthusiast

    Youze guys can experiment and see, I'm taking a break :)
  20. saps

    saps Extreme Android User

    Yeah no I know you're right and all. Just suggests to me the problem lies in the hulu and the flash rather than the voodoo per se. Maybe a revised apk would help
  21. NOsquid

    NOsquid Android Enthusiast

  22. tgulch22

    tgulch22 Android Enthusiast

    I got the Hulu App working.

    Install Flash
    Boot recovery
    Disable lagfix
    boot recovery
    install zip file
    install Hulu App

    It loaded videos in the Hulu App but not in Stock Browser or Dolphin HD Browser. I am going to enable lagfix now and see what happens.
    NOsquid likes this.
  23. NOsquid

    NOsquid Android Enthusiast

    Stock browser won't work but Dolphin should, you need to set desktop user agent, doesn't hurt to clear cache/cookies etc..

    Good job testing, glad you shortened the process for everyone monitoring the thread :) looks like it's definitely something with Voodoo.
  24. tgulch22

    tgulch22 Android Enthusiast

    Still works in hulu app after enabling lag fix again....

    Works in Dolphin Browser with desktop user agent set.

    And no go in Stock Broswer...

    So yeah it looks like voodoo is preventing the install, but not the use
  25. NOsquid

    NOsquid Android Enthusiast

    Sweet, glad it wasn't just me!

Samsung Fascinate Forum

The Samsung Fascinate release date was Q3 2010. Features and Specs include a 4.0" inch screen, 5MP camera, GB RAM, Hummingbird processor, and 1500mAh battery.

Q3 2010
Release Date
Similar Threads - ***get hulu working
  1. Davdi
  2. kite
  3. bosem31
  4. mystical_ice
  5. postbmd
  6. archz2
  7. Oneechan69
  8. corvairbob
  9. Alan_aguinaga
  10. Chuchu2x

Share This Page