1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root How-To Guide: Root the Huawei M835

Discussion in 'Android Devices' started by Sebuo, Aug 3, 2011.

  1. I had my friend root my Huawie m835 for me because I'm technologically challenged... But I have been trying to learn and follow along with everything being said. I see that I do have the app called super user. But I can not figure out what to do to delete the metro apps that came pre-installed on my phone... What do I need to do to get rid of them for good? They are stupid things that I'm never going to use like... 100% games, loopt, im and social, metro navigator, metro 411, my extras, pocket express, places, virtual card, m studio, one or two of the 3 different email apps, and all the other annoying ones... :thinking:


  2. Krezin

    Krezin Newbie

    if you want to get rid of bloatware(metro apps) my best suggestion is Titanium Backup Pro. Yeah it's a paid app, but it lets you remove any installed app at will. I live off of it ever since i got it.
    Vasolini likes this.
  3. You do not have to go though this and downloading things on your PC you can download 4 squared mobile on the android market go to settings-applications-enable install non market apps. Open 4 squared and press menu button on phone and click search type in gingerbreak-v1.30.apk. Download it and open it and click on root device it will root it when your phone is rooted it will turn off. Turn it back on search for a app called super user your rooted. (Hint this can work on all devices and some not like on htc phones sometimes)
  4. PacMan13x

    PacMan13x Newbie

    uhm try to install wifi file transfer if you want its way better than using a usb cable https://market.android.com/details?id=com.smarterdroid.wififiletransfer&hl=en
  5. PacMan13x

    PacMan13x Newbie

    does anyone know if this works for huawei m865? I cant seem to root my phone I tried gingerbreak and z4root but no luck!
  6. kandrwelding

    kandrwelding Lurker

    When I click the supperoneclick it opens C prompt and then the main window with the root button on it says not responding.

    Any help ?
  7. Vasolini

    Vasolini Newbie

    I'll be rooting a M835 tonight following the instructions in the first post, and deleting the Metro bloatware with Titanium Backup Pro. If anyone has any updated advice, it would be appreciated.
    Also, she's only getting about 7 to 8 hours on the battery. Has anyone gotten theirs to go any longer without cutting off the radios (mobile data, etc.)? Because she uses texting heavily, we need to keep that stuff on. Will getting rid of the bloatware that runs in the background help with battery usage?
    I can see why this is a budget phone, but she's (daughter) happy with it except the battery issue. I may just buy her a spare battery.
    Any thoughts?
  8. Vasolini

    Vasolini Newbie

    I've used Titanium Pro on both mine and my wife's Admire, but for some reason, on this Huawei M835, it says it's failed to locate the apk file. I did get it rooted, and also tried browsing to it with two different file browsers, and both won't let me browse anything but the sd card. What am I doing wrong
  9. Vasolini

    Vasolini Newbie

    Anyone else having trouble deleting apps on this phone? I can navigate to the folder (Cust) and I can see the apps, but un-install fails no matter what means I try to do it....
    Anyone have any tips? Should I try to root the phone twice? Also, I noticed the Superuser app icon is grayed, where on my Admire it's green. It does however grant superuser rights to apps....
  10. jmosley89

    jmosley89 Lurker

    i cant install pdanet..can i use easytether or any other app
  11. Tokenpoke

    Tokenpoke Android Expert

    What os is your PC.

    I have used easy tether on the mate on XP
    On Mac Linux or 7 you can just edit the built.Prop and enable tether.
  12. EManU3LXX

    EManU3LXX Android Enthusiast

    You might need to reroot, because it might now have rooted correctly, unless it asks for superuser permissions... Try using Root Explorer or Root Manager (they cost money) and navigate to those folder's and delete them. Uninstalling ain't gunna help you
  13. NimChimpsky

    NimChimpsky Lurker

    Unfortunately, the Mac (unless booted into Windows, which I don't have at the moment) doesn't like .exe files.

    I was able to use adb to install Superuser.apk, but when I open Superuser on the phone, I get 'No apps in list' and 'No log information'. I do get to see some options under 'Settings', but they don't seem to be anything that should require superuser status.

    What am I missing?

    BTW, I have previously installed AppBrain App Market and PdaNet, although I can't recall exactly what order I did various things in, or exactly what I did.

    I should mention that I have not, so far, connected this phone to my metroPCS account and I haven't decided whether I will do that or just use it as a miniature android tablet via wifi. If, however, it turns out that I can in fact use it as a modem with my computer or, better, with an android tablet, I might do so.
  14. tclemens

    tclemens Newbie

    I just wanted to register nad say thank you very much for this thread. Worked perfectly i am now rooted
  15. D3c0y

    D3c0y Newbie

    SU is not used for allowing access, it is used to view apps in the granted list. Any app you run that requires root access will call a permissions prompt by the SU utility. Select "allow" within 10 seconds. From that point, the app you allow will show up on the list.
  16. D3c0y

    D3c0y Newbie

    AFAIK, apps on the device are being disabled from hacking the device due to EULA terms. Android is open source however, and by DEBUG mode you can get root access. This requires use of ADB on the computer end. Check the root app dev pages for updates of fixes if you wish, but ADB is pretty simple and easy to fix errors when modding your device.
  17. D3c0y

    D3c0y Newbie

    If you did root your phone, click the button that says "r/o". It will change to "r/w". This toggles read/write mode. You can find root explorer for free if you are familiar with search engines..
  18. Johnny Crapple

    Johnny Crapple Android Expert

    i tried to flash cwm for the m835 in rom manager and the ascend doesnt pop up only huawei u8160 would that work for this phone
    Edit: could I use the fastboot cwm for ascend on this phone
    Edit: I got it with fastboot
  19. Ogco2006

    Ogco2006 Lurker

    I install the programs i got to the end i click root and command pages pop up it did 3 diferent ones and the third one is taking for ever and the process says chmod gingerbreak..... Ok then running gingerbreak .... And its stuck there how long should the proces take on a xp computer
  20. Ogco2006

    Ogco2006 Lurker

    I cliked close on comand then it ran more commands and it said if it keeps looping try disabling debugging now and i do then itll say waiting for device and nothing happens till i turn debugging on again and itll go go back to running gingerbreak
  21. cacastevens3

    cacastevens3 Lurker

    it worked perfectly, so i can use a ps3 controller for games and whatever else! just wanted to post this and good luck to everyone else:)
  22. policyla

    policyla Lurker

    sebuo thanks for the helpful post. this is my first time rooting a device. I have huawei m835 android version 2.2 and gingerbreak did not work on my phone. the super1click method is the right one for me yes? I installed pdanet already like you said I just had a couple questions. first where should I download super1click from and second do I download it to my computer or my phone? any info is much appreciated as I am new to this and just want to make sure I am doing it correctly. thanks.
  23. Apoplectic1

    Apoplectic1 Member

    OK, I'm trying to root my Huawai M835 and I keep getting some error messages. Every time I try to rune PDAnet it says it cannot detect my phone Error 103. It says wait until my phone's driver installs completely to try again. The problem is I'm pretty sure my phones driver has been installed, it did it as soon as I plugged in the phone in Debugging mode.

    When I try to run SuperOneClick it says:

    Unhandled exception has occured in your application. If you click continue, the application will ignore this error and attempt to continue. If you click quit, the application will close immediately.

    Object reference not set to an instance of an object.

    What does this even mean? Am I doing something wrong here?
    DeadlyInHeels likes this.
  24. DeadlyInHeels

    DeadlyInHeels Lurker

    OMFG this helped me soo much. Thank you. After I Rooted my device, my friend wanted me to help her. does this help with HTC inspire 4g ?
  25. Swisaiahag

    Swisaiahag Android Enthusiast

    NOPEE she can check in the Htc Insoire 4g section
Similar Threads - Guide Root Huawei
  1. Rob
  2. Cyberdev
  3. Rob
  4. dontpanicbobby
  5. dontpanicbobby
  6. Cyberdev
  7. hsnchk
  8. bcrichster
  9. bcrichster
  10. bcrichster

Share This Page