1. Check out our companion app, Forums for Android! Download from Google Play

Support How to listen to audio when in DND mode?

Discussion in 'Android Questions' started by Crdf, Feb 3, 2017.

  1. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    Hi guys.

    I just updated my HTC one M9 to android 7 version 4.14.401.7.
    I use my phone as my pocket mobile computer rather than to talk to people. I also don't like sounds and vibration so I always have it in DND or silent mode (sounds give me severe anxiety and I have sleeping issues - even vibration wakes me up)
    I listen to music and audio books lot. Well, with the latest update it turns out that app volume is also muted in the silent mode and this cannot be manually overwritten.
    I've been trying to find a way around this but I am not managing. I sure agree this has to be an option but I find the absolute mute forced on users in my situations to be idiotic and just something that was not well thought trough.
    I am not sure I can manage with a roll back unless someone can advise how I can do that.
    Is anyone able to suggest how I can resolve the issue with my audio apps as I really would like to be able to listen to my books without having to change the sound profile. And before it gets suggested the time option on allowing sound is not good enough.

    Any help with this will be much appreciated.
    Thank you.

     

    Advertisement

    #1 Crdf, Feb 3, 2017
    Last edited: Feb 4, 2017
  2. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    So no one has any idea about this and on one else is bothered by this.

    Will rooting the device allow for some way to over-write this?
     
  3. artaxerxes

    artaxerxes Well-Known Member
    63

    Sep 2, 2011
    161
    44
    63
    In certain versions of Android, DND actually has three options.
    Total Silence: Just what is says
    Alarms Only: Yep, I think maybe application sounds will still work.
    Priority Only: A customized version of DND. You can pick which applications to override and which contacts can still ring. If you star a contact, the phone will ring, given certain conditions. There are a few other customizations in Priority mode. In the system settings, you can per app choose to override DND (Priority Only).

    You can setup automatic rules of when to apply DND.

    Which version of Android and which phone do you have?
     
  4. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    Hi Artaxerces. Thanks for the reply.

    My phone is HTC one M9. Android 7, Version 4.14.401.7.

    I am aware of the modes you are mentioning. I have checked the phone settings, the app settings and tried to set up priorities. Nothing over-writes the mute volume for the media.
    Yes you can choose priority for contacts - something I don't care about, but when you try to chose priority for apps from system setting there is a message - "no installed apps have requested DND access". And why should they since that was not required until 3 days ago? Changing priority from the volume control menu switches the DND mode for the phone to normal (full volume) or vibrate. Neither of these is desirable for me.
    I even installed third party app that allows to control each type volume of separately. Those apps may have worked before the current update to Nougat, but they no longer do.

    If you believe I am missing something please let me know where I should look. This is driving me nuts. Thanks again for taking the time to reply.
     
  5. artaxerxes

    artaxerxes Well-Known Member
    63

    Sep 2, 2011
    161
    44
    63
    Try going into Settings -> Apps -> [your app here] -> Notifications -> Override Do Not Disturb

    Also, Alarms Only will allow sound from applications, as well as Priority, without really changing settings.
     
    #5 artaxerxes, Feb 4, 2017
    Last edited: Feb 4, 2017
  6. dontpanicbobby

    dontpanicbobby Well-Known Member
    713

    Dec 31, 2011
    7,617
    4,165
    713
    Male
    Boston MA USA
    I've never had an m9 but on my M8 and 10 I can go to Settings>Sounds & notifications>Volumes and turn down Ringtones & notifications and Alarms but keep music blasting.
     
  7. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    Hi again.

    Regarding your first suggestion - I have done that already. However the apps I use for music and audio do not push notifications, which is what that is for I assume. The option to overwrite DND does not enable the sound from the app. The app is mute as are all apps (Facebook, YouTube, music players etc).

    Regarding your second comment. Yes that was the case before the latest update. No longer. I may not be the most high tech person and I am prone to silly mistakes, but I promise you the alarms only mode does not allow for media sound any more for me.

    When I go to "settings - sound and notification - sounds" and look at the tree sliders, the media one has a strike through.


    I really hope you can suggest something else.
     
    #7 Crdf, Feb 4, 2017
    Last edited: Feb 4, 2017
  8. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    Hi, thanks for the comment. That icon is muted and does not change if I move the slider. If I change the level of the same from from the drop down option the slider slides back by itself. If I press the volume buttons nothing happens.
    That was not happening with Android 6. Started few days ago with the latest update.

    Edit: If instead of choosing a sound profile I manually adjust the sliders the top one turns into "sound off and vibrate" not mute. If I click on the vibrate icon it turns into dnd and that automatically brings the media bar to mute.
    I will cry :( whoever came up with that.software change idea is an as#!
     

    Attached Files:

    #8 Crdf, Feb 4, 2017
    Last edited: Feb 4, 2017
  9. dontpanicbobby

    dontpanicbobby Well-Known Member
    713

    Dec 31, 2011
    7,617
    4,165
    713
    Male
    Boston MA USA
    So don't use DND. Just turn down those sliders when you only want to listen and also change your Sound profile to Silent after. I think that turns off vibrations.
     
  10. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    I am sorry but that is not good enough. I have anxiety and sleeping issues (yes vibrations wake me up). If I am going to bed and listening to something to calm me down, or have loaded timed wave based sounds to help me fall asleep I want to be able to remove my headphones (or even fall asleep) and go to sleep without worrying about changing the phone's sound profile (or even turning the screen on).
    Thank you for the reply anyway. Please feel free to reply if you have any other ideas. I'd love to know if there is a way to set the setting as they did before.
     
    #10 Crdf, Feb 4, 2017
    Last edited: Feb 4, 2017
  11. dontpanicbobby

    dontpanicbobby Well-Known Member
    713

    Dec 31, 2011
    7,617
    4,165
    713
    Male
    Boston MA USA
    Okay. I think I figured it out. First in Sounds & notifications turn of vibrate, then do the slider thing.
     
  12. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    Thank you. I actually tried that earlier today. I turn the profile to normal. Go to setting - tick off vibration. Go to the sliders and move the top slider to the left. As soon as I slide it to where the zero would be the phone vibrates and the icon switches to vibrate. When I click done and look at the settings window the vibrate option that I just ticked off is now grayed out. Notifications and phone is now in vibrate mode.
    Another click on the top slider turns it to mute which causes the middle slider to mute as well.
    ;(
    Thanks for the idea though. That was some quick thinking.
     
  13. dontpanicbobby

    dontpanicbobby Well-Known Member
    713

    Dec 31, 2011
    7,617
    4,165
    713
    Male
    Boston MA USA
    I don't get many notifications. My sweetie made me do fb though. Never know when those things will pop up. If I could just turn that off I'd be happy.
     
  14. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    I'm sure you know how to silence Facebook ;) . But yes. Notifications come at any time.

    Would the following work? :
    * Turn off vibrate. [Not sure if you need to]
    * Turn on priority mode - it displays sound profile as normal however ring and notification sounds are off.
     
    #14 Crdf, Feb 4, 2017
    Last edited: Feb 5, 2017
  15. dontpanicbobby

    dontpanicbobby Well-Known Member
    713

    Dec 31, 2011
    7,617
    4,165
    713
    Male
    Boston MA USA
    Try it and let us know.
    An interesting experiment would be to call your cellphone from your home number and see what happens.

    I don't even have an avatar on fb. I just can't get into aimless social yet. Guess I'm shy.
     
  16. Crdf

    Crdf Member
    Thread Starter
    26

    Feb 3, 2017
    12
    2
    26
    I think what threw me off was that when I click "priority" the profile always changes to "normal". I've never used it before because DND used to do what I wanted/needed.
    It might turn out that priority is exactly what I want. I just called myself from a landline and the phone was silent. Reading back the comments it seems that solution was suggested in comment 3 as well. :rolleyes:
    To be fair it is not clear that priority is a DND mode since it displays as Normal. I will be testing the apps notifications tomorrow as well. I need to sleep now as it is 4am already.

    Thanks for the support dontpanicbobby. (I obviously did panic). You we're very helpful.

    P.s. Facebook used to be better. I have the feeling the internet used to be better. And you just dont strike me as a shy person. Hangin here with me - trying to help. I also feel about FB like many people feel about cigarettes. It's okay in small doses
     
    #16 Crdf, Feb 4, 2017
    Last edited: Feb 4, 2017
    m0bot likes this.
  17. m0bot

    m0bot Member
    6

    Mar 19, 2017
    7
    1
    6
    Male
    This NEEDS to be fixed!

    I searched around and did some troubleshooting of my own but couldn't find anything.
     
  18. mikedt

    mikedt 你好
    2,238

    Sep 22, 2010
    21,295
    11,050
    2,238
    Teachaaa
    Jinan, China
    Possibly contact HTC tech support then if you think there's an issue with this One M9 update, see if they can suggest anything, that's if nothing else in this thread has worked for you.
     
  19. m0bot

    m0bot Member
    6

    Mar 19, 2017
    7
    1
    6
    Male
    Thanks @mikedt I actually never thought of this.

    I contacted support and first the had me "wipe the cache partition". They sent me good instructions, I tried it, but it didn't work. No harm no foul, was worth a try.

    Then they suggested factory reset. Not going to happen. It's clearly not a device specific issue (I provided them links to forums of other people having the same issue) and I believe others have even tried a factory reset. They said a factory reset "may sometimes" work. Well, getting my phone back to it's current state is not worth it for something that probably won't work. And if it didn't work, I would have to give them my IMEI so they could test and possibly discuss warranty/repair options. What's there to test? It's a known issue. They should be able to replicate the issue on one of their own devices if that had a good QA/testing department.

    And the last time I dealt with HTC support was not very good. My camera cover cracked (also a known issue) from no fault of mine; phone was still under warranty, yet I would have to pay to ship it to them, get no loaner phone, and then possibly have to pay for any other "issues" that were "discovered and needed repair" and if I didn't pay, I wouldn't get the phone back.

    Regardless, getting a new phone wouldn't solve the issue.

    Overall, not too happy with HTC.
     
  20. m0bot

    m0bot Member
    6

    Mar 19, 2017
    7
    1
    6
    Male
    So after my "complaining" to HTC, they've told me they are working on fixing the issue and to watch out for an update. Actually seemed pretty genuine. I will believe it when I see it, although I am of course rooting for HTC to get this fixed. If they deliver on what they said, I will have some faith restored in the company.
     
    Mirren Craig likes this.
  21. Mirren Craig

    Mirren Craig New Member
    5

    May 8, 2017
    3
    1
    5
    I feel your pain .. this is the most frustrating thing about my phone .. I don't want my phone to ring I don't want my phone to vibrate .. so therefore they block me listening to music.. any word on the update ?? Also how did you make your complaint maybe if more of us complain they will fix it quicker
     
  22. m0bot

    m0bot Member
    6

    Mar 19, 2017
    7
    1
    6
    Male
    Funny because I actually believed for a second HTC was getting it together. Haven't heard a peep from them, haven't seen an update. E-mailed them a few days ago to check in on the status and no reply.

    I complained by sending an message through their web form. The link I provided is for Canada support, hopefully it just redirects to your appropriate country's support site, otherwise just click through a few pages on their support to get to the form.
     
  23. m0bot

    m0bot Member
    6

    Mar 19, 2017
    7
    1
    6
    Male
    UPDATE: I sent them a second follow up message and they finally got back to me - apparently there were issues with their system and my first follow up was mixed up.

    They asked for my IMEI and a picture of my "Download menu" screen. They said with this information the Devs will be able to look into it and get back to me in 7 to 10 business days. So I sent it, will post any further updates here.
     
  24. burnyburnout

    burnyburnout New Member
    15

    May 13, 2017
    3
    0
    15
    Im having the same issue, only i have a galaxy s6. Only started happening when I upgraded to android 7.

    I only used DND mode to prevent people from spamming my phone with notifications while I sleep.

    Now since sound is completely muted, I turned DND off entirely.

    I feel the OP's pain, this situation must really suck for him :(
     
  25. m0bot

    m0bot Member
    6

    Mar 19, 2017
    7
    1
    6
    Male
    Sounds like this is not just an issue with HTC One M9.

    Here is the response I got from HTC:

    So it's a carrier issue I guess? I'm with Rogers in Ontario, Canada. Any idea if we can do anything about this?

    And, I wonder if every type of phone has this issue.
     

Share This Page

Loading...