1. Check out our app, Forums for Android! Download and leave feedback here!

Support how to permanently turn of "Usb debugging"

Discussion in 'Android Devices' started by AmitX123, Jun 13, 2011.

  1. AmitX123

    AmitX123 Active Member
    Thread Starter
    16

    May 31, 2011
    31
    8
    16
    When I insert USB, I have to always set USB debugging off. However it gets automatically enabled when I remove usb or reboot.

    Is there a way to permanently disable usb debugging on Samsung Galaxy Ace?
     

    Advertisement

  2. pujitjuneja

    pujitjuneja Well-Known Member
    53

    Apr 9, 2011
    234
    72
    53
    Developer-to-be ;)
    Delhi, India
    Go to menu>settings>applications>development and turn it off from there when NOT connected to usb
     
  3. AmitX123

    AmitX123 Active Member
    Thread Starter
    16

    May 31, 2011
    31
    8
    16
    I have tried that too.. It always comes back on :(

    what I mean is that even if it is off, when I plug in USB, it gets turned on.
     
  4. nvekariya

    nvekariya New Member
    5

    Jul 27, 2011
    1
    0
    5
    I am also facing same problem like when i turn off before connecting USB, it automatically turn on when i connect USB

    please help us bro

    thanx
     
  5. PJ147

    PJ147 Well-Known Member
    68

    Jun 10, 2011
    457
    143
    68
    Male
    Sales
    Hampshire, UK
    Is there a reason why you don't want it on?
     
  6. kiplaird

    kiplaird Member
    5

    Sep 24, 2011
    5
    0
    5
    if it's on, the phone/memory card don't show up on the pc, for copying/transfering files.

    i want it off PERMANANTLY..! :mad::mad::mad:

    turning off the debugging only turns itself back on when plugging in the USB cable.

    what is the reason for it anyway besides being a pain is the ass...!?!?!
     
  7. kiplaird

    kiplaird Member
    5

    Sep 24, 2011
    5
    0
    5
    trying to use the memory card as a USB Mass Storage for adding removing files is way too far a problematic inconvenience.

    after installing PC Studio, Kies and Samsung USB Drivers it still only works 1 out of a million times.

    why make it so difficult for such a simple task?

    Bluetooth works and connects fine but too slow for transfering music albums and videos.

    Had to download the pdf manual as only got a quick start guide and no cd or software. Still no answer to my problems. Having to mess around with tethering, debugging and also to put ON the usb mass storage everytime you want to do something in the memory is way too much of a hassle.

    Just orderd a sd memory card reader off eBay as quite simply put... "the USB cable is fekking POINTLESS since you can only use it for charging phone....!

    [​IMG]MINI USB 2 TF T-FLASH MICRO SD MEMORY CARD READER +Cord | eBay

    i shall be using this till Samsung or whoever make an update to fix the stupid thing. every other phone i had, usb plugged in and presto... memory there ready and available for editing. dont like all the software programs as they tend to be useless, slow and in the past ruined 2 memory cards.
     
  8. praky

    praky Well-Known Member
    53

    Jun 11, 2011
    224
    91
    53
    I had the same problem in FROYO. but in gingerbread its not there.
    Also phone is not detected as storage on PC if the drivers are not installed. I don't think it is due to USB debugging.
     
  9. praky

    praky Well-Known Member
    53

    Jun 11, 2011
    224
    91
    53
    Scratch that, I still have this problem in GB.
     
    kiplaird likes this.
  10. sergigs

    sergigs New Member
    5

    Mar 18, 2012
    1
    0
    5
    I have the same problem on galaxy ace gingerbread, the only way i could connect the phone in mass storage mode was, indeed, disabling that "usb debugging" option. Once the phone was connected it turned on again, and if i tried to disable it auto-turned on again and again. I had to disable it a few times and after 35, 36... times (i know, its just sick) it finally stayed off (seriously, dont know why). Then i dropped the top menu, selected the mass storage option and everything worked fine, i could transfer files from pc to the phone.

    EDIT
    ------------------

    Sometimes it seems to stay finally disabled and a few seconds later, while im going to select the mass storage option, it turns on again. I simply keep on disabling it until it finally wont auto-turn on (always with the phone plugged to the PC).
     
  11. rkelsen

    rkelsen Member
    15

    May 8, 2013
    10
    0
    15
    I know this thread is ancient, but has anyone managed to resolve this problem?

    USB debugging re-enables itself on boot and/or whenever a USB cable is connected.
     
  12. abdool

    abdool New Member
    5

    Jun 10, 2013
    1
    0
    5
    hi,
    to those with the problem of USB debugging automatically turning on, the solution is simple. USB drivers are needed. Just visit the following link and download the drivers to your PC while your phone is connected. Install the drivers and after installation, your phone will be able to connect to USB storage :)

    forum.xda-developers.com/showthread.php?t=1982287
     
  13. mark2930

    mark2930 Member
    35

    Jun 17, 2013
    10
    0
    35
    agree that it's annoying to always keep usb debugging on.
     

Share This Page

Loading...