1. Are you ready for the Galaxy S20? Here is everything we know so far!

[How To] Regain Root With S-Off or HTC unlocked bootloader

Discussion in 'Android Devices' started by iowabowtech, Sep 28, 2011.

  1. iowabowtech

    iowabowtech root@android:/ #
    Thread Starter

    Use Open Garden wireless tether app on Gingerbread. The old standby apps from the early days may not work.


  2. iowabowtech

    iowabowtech root@android:/ #
    Thread Starter

  3. the image for me does the same thing and the hash was correct. in addition the card was correctly formatted.
  4. iowabowtech

    iowabowtech root@android:/ #
    Thread Starter

    Some cards are finnicky. You'll have to keep reformatting the card and add the file back to it until it works...or try another card. I don't know why it happens that way sometimes but it does.

    Otherwise try the RUU instead.
  5. shameless

    shameless Lurker

    Thanks everyone who's pulled info together in this thread to make this process as straightforward as possible.
    I'm having an issue and hoping someone can point me in the right direction.
    Steps 1-5 worked just fine for me. However, in Step 6, I select "Recovery" from the menu, briefly see the HTC screen, see the screen with a phone icon and a green arc over it, and then the screen switches to a phone icon with a red triangle containing an exclamation point. Nothing further happens and I have to pull the battery to get the phone to start again.
    Am I doing something wrong? Or should I be looking at a totally different process to get re-rooted for some reason?
  6. Deleted User

    Deleted User Guest

    If you're getting a red triangle in step 6 that means you're still on stock recovery and clockwork didn't flash properly or at all.

    Make sure the file is named 'PB31IMG.zip' and not 'PB31IMG.zip.zip'. You should be prompted to install it on the first hboot screen, with no option to select recovery. After it finishes installing, select to reboot and continue from step 5.
    iowabowtech likes this.
  7. iowabowtech

    iowabowtech root@android:/ #
    Thread Starter

    mmolitor is spot on. So we are looking at both steps 2 and 4 here as the culprit. Make sure your card is formatted to fat32, that's required. Make sure to verify the MD5 hash which will ensure you have the exact file I posted. If it doesn't match, you may have a borked download and you need to redownload it. The next source of potential hangup is file naming although I have it pre-named such that you shouldn't have a problem. To be sure however, navigate to your sd card using a file manager and verify that the file shows up as PB31IMG.zip (exactly that, no exceptions).

    Once all that is verfied, you are ready for step 4. When you goto hboot, after a few seconds on the main hboot screen, it will scan your card for image files (the PB31IMG). It should locate the file now and should prompt you to load the file. You will press the volume UP key once to initiate the loading of the file. If you are not getting this, refer back to the tips above.

    If you DO have all this happening and yet you are still ending up at the stock recovery in step 6, then we need to talk.
  8. redsly

    redsly Lurker

    Worked perfectly!

    I'm a noob at this and have previously set my s-off with unrEVOked a while back, but forgot about it when I re-flashed my stock froyo this past summer.
    My problem was that I couldn't get my phone to reboot during the OTA GB update and started dabbing into 'why'.
    I used a terminal app to remove SU from the system/app folder (just in case it was a security flag in the update), that didn't help. I was trying to clear my cache in HBOOT and it wouldn't do ANYTHING... I couldn't understand why until I just decided to re-flash another factory ROM that was titled PB31IMG.zip. That worked and I received my GB update OTA almost immediately. I deleted PB31IMG.zip from my SD card and tried to install SU through a .zip file that I downloaded.

    unrEVOked wouldn't work, I couldn't get HBOOT to install SU and therefore I couldn't gain root.

    After a little trial, error and not wanting to reflash a factory ROM again, I turned to the forums. Everything I was finding on the web about gaining ROOT with GB(VZ), said that I had to DOWNGRADE to FroYo to do, BUT since I already had S-OFF I was not going to do that and decided to keep searching.
    I found this page and thought that the file you have listed as PB31IMG.zip was the same as as the one I just deleted and skipped over it... Yup, noob move! SU still wouldn't install and clockworkmod wouldn't reboot me into recovery for some reason. Then I thought about how the file above may just be a different file that already has the name changed simply for installation, as do other .zips (again, NOOB).

    Needless to say, Once I downloaded your first file everything went FLAWLESSLY!
    I was sure to "THANK" you and I greatly appreciate it!

    EDIT: This was with my Dinc (original)
    Provider VzW
  9. iowabowtech

    iowabowtech root@android:/ #
    Thread Starter

    Glad to hear it. Welcome back to root!
  10. D0nuts

    D0nuts Newbie

  11. jmarias

    jmarias Lurker

    1. Went back to stock INC with S-off. (Full wipe)
    2. Received Gingerbread OTA
    3. Version 4.08.605.2 Radio
    4. Verified S-off remained (Originally from Unrevoked method)
    5. Downloaded the PB31IMG (Verified Hash)and Superuser files
    6. Moved to SD Card (Verified FAT 32)
    7. Went into HBOOT - Found PB31IMG.zip
    8. Update went fine - Rebooted - Renamed PB31 file
    9. Powered down - Powered up into Hboot
    10. Selected Recovery
    11. Clockworkmod Recovery v5.0.2.0
    12. Selected Install zip from sdcard
    13. Received picture of tophat with orange circle
    Nothing else happens
    Can use power button to return to clockwork menu
    Selecting other give same "tophat" picture result only
    Have to remove battery to reboot

    Repeated from step 5 multiple times with same results.

    HELP !

    Thanks, JIm
  12. jmarias

    jmarias Lurker

    Problem resolved!

    While moving the phone around to remove the battery yet again, I felt the tactic feedback. Turns out it was from my brushing the optical mouse. I tried again using the mouse instead of volume/power buttons and.....

    It Worked!

    Rooted and happy!

    Silly thing to have caused such frustration !

    redelance likes this.
  13. well long story short i got my phone from ebay the owner told me he had it rooted but he unrooted it when he put it up on ebay. it shows that the s is of and its runing on 2.3.4 and baseband on i tryed unstaling the files right of ove the phone browser into astro but i cant move bolth files to the root file makes no sens the only thing i noe that he rooted it before with unrevoked. :thinking: plz help lol it sucks to be a noob.
  14. iowabowtech

    iowabowtech root@android:/ #
    Thread Starter

    E card
    Well, I didn't understand your post very well but its easiest to download the files using a computer, then hook up the phone, navigate the SD card contents and drag/drop the files onto the SD card. As mentioned in the OP, the card must be formatted to fat32 for this to work. If you have not performed that step, please remember that formatting wipes all card contents so plan accordingly.
  15. i tried it step by step i put the clock recovery and super user on the sd card then i unplug the phone from the laptop and i went to hboot when i got there no update showd up it just shows no image in green leters and back to hboot settings. and my sd card was already formatted in fat32. idk if it has to be somthing with my sd card idk its weard but thanx for helping me.:(
  16. iowabowtech

    iowabowtech root@android:/ #
    Thread Starter

    You may have to try formatting the card again, be sure to use the computer to do this. Also, if Windows, use the full format option instead of quick format. Some people have had to reformat several times before it works. I cannot explain why but that has been the case with this phone since day 1. That or try a different card if available. If you are persistent, you will almost certainly be successful.
  17. scotty85

    scotty85 Extreme Android User

  18. rooterbooter

    rooterbooter Lurker

    So I am on rezound and I followed instructions on HTCdev and unlocked it. Now trying the OP instructions and it is not working. When on step4, and I reboot in hboot, the file isn't eeven getting read. It scrolls quickly for the files it reads and I went in to hboot multiple times but this file in question is not getting read.

    Scotty85 has nice instructions on the last link he provided but that is also not working.

    I know my rezound is unlocked with S-on as it wiped all my setting after I followed instructions on htcdev.

    Anyone know how to root a rezound after it has been unlocked from htcdev? I am only concerned about tethering not particulary for putting custom ROMs on it. Please help!
  19. sdrawkcab25

    sdrawkcab25 Extreme Android User

    These instructions will only work for the HTC incredible.

    This is what you need to follow:
    [HOW TO] Permanently Root Rezound [Post Bootloader Unlock][Windows]

    More guides can be found here:
    scotty85 likes this.
  20. compguy

    compguy Lurker

    I have my phone rooted with unrevoked and wanted to know if this will work as is. Do I need to go back to stock, run the OTA to Gingerbread, then run this method? Does this bring me up to GB so I can stop getting the update notice?

    Current Phone Info:
    Android 2.2
    build & software 3.26.605.1

    Thanks for your help!
  21. sdrawkcab25

    sdrawkcab25 Extreme Android User

    You'd want to follow these instructions:

    You will have to get the necessary files from http://pvillecomp.com
  22. DrDooGood

    DrDooGood Lurker

    In step 4 it sees my PB31IMG.zip file and tries to load it but gives an error saying "main version is older. update fail"

    phone has never been rooted, just an unlocked boot loader via the official HTC method still with s-on. any suggestions?

    Edit: my goal here is to root the phone so i can load Nils Business GingerSense 3.5 ROM
  23. scotty85

    scotty85 Extreme Android User

    what i have learned from htcdev and unlocked s-on hboots,is that it is now important what information is on the "android info" text document that is contained within the PB31IMG file. basically,the "mainver" number in the info file,cannot be lower than what the actual main version is on your phone. youre on gingerbread,and the PB31IMG prolly contains a randomly selected android info file with a lower mainver than that,preventing the flash.

    in order to make the PB31IMG flsh with htcdev s-on,youll need to:
    -follow all rules for PB31IMG files(FAT32 sd,properly named file,root of sd card)
    -check your main version in fastboot via the following fastboot command : fastboot getvar all and look for the "version-main" number in the resulting outout.
    -unzip PB31IMG and edit your text doccument to this same number or higher
    -rezip with the new text document.

    it should work then.

    however,the easier way is to simply remove the recovery image from the PB31IMG file and place it into the folder you used to htcdev unlock. change to that directory and put your phone in fastboot,like when you unlocked.

    permanently flash your recovery with this command:
    fastboot flash recovery <recovery name>.img

    fastboot flash recovery clockwork-recovery-inc-

    continue on with iowas directions at step 6.

    using "fastboot flash" elimiates finicky sd cards,android info files,and improperly named files completely from the equation :)

    edit: after having messed with an s-on unlocked hboot,i think i will put together an htcdev specific guide for the few folks that want to do it this way. ill try and get it up later this eveing :)
    DrDooGood likes this.
  24. DrDooGood

    DrDooGood Lurker

    thanks. i almost did it the edit the text file way but then there is the hbootpreupdate parameter which also had different values (3 in the text file vs 11 in my getvar output). so i went with the fastboot route and it worked great.

    Edit: putting together a specific guide for this will be a great plus. i think a lot of these phones are coming off original contract plan owners and making it to new owners via the ebay circuit.

    p.s. Any idea how serious Nils is when he says hboot 0.92 is required. i'm rooted with HTC unlock, s-on, clockwork recovery, but hboot 1.02. Any idea if that would still work, or at least be safe to attempt?
  25. scotty85

    scotty85 Extreme Android User

    yes,it should be fine. id be willing to guess 1.02 is basically the same as .92,with addition of the additional fastboot commands and the ability to "lock" and "unlock".

    the warning for .92 hboot is basically so you dont try and use one of the older .77 or .79 hboots. a worse case there is it simply wont boot until you flash older firmware the hboot is capable of booting. at any rate, you should be perfectly fine flashing roms with your 1.02.0000. ive actually got it installed on my inc(and my other phones that dont have eng bootloaders available,tho i am s-off on top of that) and havent had any issues. :)
    DrDooGood likes this.

HTC Droid Incredible Forum

The HTC Droid Incredible release date was April 2010. Features and Specs include a 3.7" inch screen, 8MP camera, Snapdragon S1 processor, and 1300mAh battery.

April 2010
Release Date

Share This Page