1. Check out our companion app, Forums for Android! Download from Google Play

How to revert from 2.2 FRG01B (unrooted) to 2.1 stocked

Discussion in 'Android Devices' started by DroidFun09, Aug 11, 2010.

  1. DroidFun09

    DroidFun09 Member
    Thread Starter
    5

    Aug 10, 2010
    9
    0
    5
    Hey guys, This is what i'm dealing with. I Used astro to get my droid into the 2.2 FRG01B but i'm NOT rooted from stocked 2.1 just like in the Guide but i didn't Backup any files or i don't have SPRecovery, or anything like that. My recover screen reads as follow;
    1:Reboot
    2:apply update.zip (which is what i did the first time to get to 2.2)
    3:wipe date/Factory reset
    4:Wipe Cache partition
    5:wipe baseband data
    As you can see i don't have install or anything of that nature...

    Now my question is, is there a way to get me back to 2.1 Stocked like when i got it or am i pretty much screwed with what i've done?
    If i haven't totally messed up can somebody provide a step by step so i don't mess anything up further. Thanks an advance

    ~DroidFun09
     

    Advertisement

  2. VIO

    VIO Well-Known Member
    53

    May 12, 2010
    263
    62
    53
    no not screwed, never screwed (ok, hardly never).

    You have two options you can go for a full blown root of your phone, in which case you can install whatever android build you'd like with your shiney new recovery.

    or you can get RSDlite and flash a 2.1 .sbf file which will put your phone at brand new out of box state (software wise that is)

    either way I would head to the "All things Root (droid)" sub forum and read the sticky's there for more info
     
  3. DroidFun09

    DroidFun09 Member
    Thread Starter
    5

    Aug 10, 2010
    9
    0
    5
    Ok um.. How would i root my phone if its already in 2.2. all the things i see to root are when your already with 2.1 or 2.0.1?

    and for the second way i can't find a "Good" sbf 2.1 file because when i do the RSD lite flash it keeps failing D:
     
  4. xliderider

    xliderider Well-Known Member
    143

    Jan 28, 2010
    1,232
    192
    143
    Where Diamond Head Stay
    I think Easy Root will root your Droid if it is on 2.2

    Have you tried these sbf files?

    Peter Alfonso
     
  5. VIO

    VIO Well-Known Member
    53

    May 12, 2010
    263
    62
    53
    It's probably not the .sbf files, are you verifying the md5sum's? if you are and the hash codes match then the file is fine.

    if it's failing it's most likely a RSDlite thing, make sure yuo have the latest and check out the guides for weird quirks about it, and things to try. Like moving the .sbf to the root of the drive, etc.

    and yes easy root does froyo, but there are concerns with it since some people randomly lose custom recovery, with it.
     
  6. OMJ

    OMJ Bazinga
    213

    Nov 27, 2009
    3,290
    825
    213
    Finance
    Pennsylvania
  7. acidrane

    acidrane Well-Known Member
    16

    Aug 6, 2010
    54
    3
    16
    los angeles
    what is the hash code it's suppose to match? same one in the 2.2rooting guide?
     
  8. VIO

    VIO Well-Known Member
    53

    May 12, 2010
    263
    62
    53
    yes if you download the .sbf in that thread it should have a md5sum of 9b6a336cd8f067d4487935468c758d89

    if it doesn't the file is bad (or just different)
     
  9. acidrane

    acidrane Well-Known Member
    16

    Aug 6, 2010
    54
    3
    16
    los angeles
    i'm getting a different code. same code for the file off peter's site and the one in the guide to all things root related thread. both files wont allow me to hit "start" in rdslite.
     
  10. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    And you are clicking on the number one device that shows your phone,right?

    Try re-installing the USB drivers.

    When I played with this last week, every time after using RSDLite I had ot reinstall the USB drivers to make my computer see the phone again.
     
  11. acidrane

    acidrane Well-Known Member
    16

    Aug 6, 2010
    54
    3
    16
    los angeles
    rsd is showing the phone. when i try to load a rooted sbf file (sprecovery_ese81.sbf), i can click on "start". once i change the sbf file to the unrooted 2.1, i can't click on "start". i just reinstalled the usb driver and no luck. do i need to go to an earlier sbf (2.0.1)?
     
  12. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
  13. acidrane

    acidrane Well-Known Member
    16

    Aug 6, 2010
    54
    3
    16
    los angeles
    oooh ok, lemme try that.
     
  14. acidrane

    acidrane Well-Known Member
    16

    Aug 6, 2010
    54
    3
    16
    los angeles
  15. theron324

    theron324 Member
    16

    Aug 19, 2010
    17
    1
    16
    If you revert back from 2.2 to 2.1 does it delete everything? (i.e. pics? music? apps?) I did the force upgrade and now want to switch back to 2.1 and I'm worried I'm gonna loose all my stuff... Obviously I can just copy it to my puter but its A LOT of stuff... I've also been lookin for a thread that talks about exactly how to switch back and can't seem to find a real start to end revert..
     
  16. jgm7207

    jgm7207 New Member
    5

    Dec 20, 2010
    1
    0
    5
    I think I totally killed my software. Here's a few things to tell you where I stand.

    I have a Motorola Droid 1
    My Droid is rooted via Easy Root
    I got Android 2.2 from an internet source when it came out
    I'm using Cyanogen 6.0.0

    My problem is my phone do the Power off then Hit X to go to the SPRecovery screen.

    When I try it either gets stuck on the M logo screen or sits then finally loads.

    I also think I made the mistake of deleting my update.zip file

    I tried the steps of what may have said using RSD lite 4.6 etc. and I have a few screen shots of it telling me it has errored out even after running it as Adminstrator and getting the Bootloader 2C.7C screen with Battery OK etc.

    I just dont know where to go from here or if this can be fix....

    My phone powers on etc but will not load any new Roms such as upgrading from 6.0.0 to 6.1.2 Cyanogen

    SOMEONE HELP ME PLEASE....I LOVE MY DROID and I now feel like I'm SOL
     

Share This Page

Loading...