1. Are you ready for the Galaxy S20? Here is everything we know so far!

[How to] Root 2.3.5/1.3.418

Discussion in 'Android Devices' started by themib, Aug 7, 2012.

  1. themib

    themib Android Expert
    Thread Starter

    bhigham/beh & I have modified/combined a couple of root methods
    based on New root method for stock 2.3.4 (621/622) found (Droid2, R2D2)

    watch video By: Tomsgt

    5 options
    a self extracting batch file
    a regular batch file
    slitaz boot img, (like ezSBF)
    manual using adb/moto-fastboot
    Voodoo method

    but first you need to be on 2.3.5/1.3.418
    SBF and update.zip here http://androidforums.com/droid-x2-all-things-root/429289-custom-droid-x2-roms-sbfs-ota-updates.html
    and moto drivers USB and PC Charging Drivers - Motorola Mobility, Inc. USA

    basic instructions/steps for batch files and slitaz
    turn phone on
    enable usb debugging (system/apps/developer options)
    connect to pc
    change usb mode to charge only or pc mode
    start program, see instructions specified with the option you chose

    there are on screen instruction, but this is what will happen,
    for more details see manual root using adb and moto-fastboot

    a file is pushed to your phone with adb
    phone will reboot to fastboot, all you will see on phone is moto boot logo dualcore screen
    click enter
    two files will be flashed to phone
    phone will reboot
    when it has completed reboot
    click enter
    phone will reboot
    when phone has completed reboot
    click enter
    files will be pushed to phone with adb
    phone will reboot
    when phone has completed reboot
    click enter
    files will be pushed to phone with adb
    phone will reboot to recovery
    press both volume buttons when you see ! in a triangle with android andy
    wipe cache using volume buttons to scroll, select with power button
    when complete, select reboot with power button

    when running the batch file or slitaz you may see these errors
    rm failed for /data/preinstall_md5/magic.md5 no such file or directory
    no root.img.gz no such file or directory
    rm failed for /data/preinstall_md5/magic.md5 read only file system

    that is fine, it will still work

    and it installs bsr/system recovery

    Root DX2 2.3.5 batch file in self extracting exe


    double click on DroidX2_Root_2012.exe to start
    follow onscreen instructions

    note: first reboot, goes to a nonlabeled fastboot mode, all you will see is moto boot logo dualcore screen just click enter to flash files

    Root DX2 2.3.5 batch file

    download file
    extract with 7zip
    double click on rootdx2.bat to start
    follow onscreen instructions

    note: first reboot, goes to a nonlabeled fastboot mode, all you will see is moto boot logo dualcore screen
    click enter to flash files

    slitaz boot img, like ezSBF

    has options for D2, D2G, DX, and DX2
    burn to cd with imgburn, or flash drive UNetBootin for Windows
    restart pc boot to drive you mounted img to, cd drive or usb drive
    some PCs will auto boot, some you need to press F8 or esc and select drive
    follow onscreen instructions

    I have tested and works

    manual method may update this later

    you need
    moto-fastboot.exe not fastboot.exe in batch file
    adb files found in petes root tools and batch file
    Petes root tools
    modified root.img in batch file

    extract any .zip or .gz
    move all files to same folder like C:\root to make it easier

    Enable USB debugging on phone
    open command prompt
    Code (Text):
    1. cd/
    2. cd c:root
    3. adb shell rm /data/preinstall_md5/magic.md5 ( don't worry if you see an error)
    4. adb shell ln -s /data/local.prop /data/preinstall_md5/magic.md5
    boot phone to fastboot
    run commands
    Code (Text):
    1. moto-fastboot.exe flash preinstall root.img
    2. moto-fastboot.exe reboot
    let phone boot complete, then reboot again (reboot just replaces the local.prop, but the old local.prop is still in memory, till second reboot)
    Code (Text):
    1. adb shell
    should give you a root prompt # (instead of $)

    run petes root tools, zerg rush, or superoneclick
    then you rooted

    VooDoo Method

    1 start with full stock 2.3.4/1.3.380,if you have rooted with anything other than Pete's Root Tools*, have altered/deleted stock file, or if you are already on 2.3.5/1.3.418 you have to SBF
    SBF to full stock 2.3.4/1.3.380 (VRZ_MB870_4.5.1A-DTN-150-30_1FF_01.sbf)

    if you don't want to lose data, don't wipe data (although it is recommended), unless you bootloop
    if you bootloop you have no choice, but to wipe data via stock recovery

    2 install Voodoo OTA Root Keeper, backup su, then temp unroot (keeps backup)

    3 install update 2.3.5/1.3.418 , (Blur_Version.1.3.380.MB870.Verizon.en.US.zip)**
    a via over the air or
    b download, place in sd card root (not in a folder)
    md5 B127D3AF93FD6A75C3A3D897C6D0FCD1
    and install via stock recovery

    4 restore root with Voodoo

    *zergrush may remove stock files, to root, causing update to fail
    **updates are named by the version they are updating
    md5 checksum windows / android

    My Links
    Magic MD5 Root 2.3.4 for D2, R2D2, D2G, DX and 2.3.5 for DX2 - Google Docs

    sd_shadow's [Collection] of Links: FAQs, Guides, Rooting, SBFs, ROMs... - Google Docs

    choke5150, azdolt, colli003 and 3 others like this.

    1. Download the Forums for Android™ app!


  2. coolpoete

    coolpoete Android Enthusiast

    Thank you for posting. I am appreciative of you sharing the information. If I can make an observation that the way the information is presented is a little vague for those that may not understand the process. If I can ask that you add some formatting so that users can understand better. For example you begin by stating that there's a new root method but there are 5 options. That may be confusing.

    Preface by stating what files are needed and then clearly state the steps. Moonshadow's guides on XDA are clearer and use text formatting to show what needs to happen first, second, etc. a little more clearly. Thank you.
  3. themib

    themib Android Expert
    Thread Starter

    updated instructions, but its mostly just read onscreen instructions and click enter
  4. Scur

    Scur Android Expert

    Since I can't update (can't activate this phone) I SBFed to 2.3.5 and used the 7zip file to root. A lot of errors popped up, but it rooted.
  5. themib

    themib Android Expert
    Thread Starter

    I believe you can update, through android recovery, even if phone is not activated
  6. Scur

    Scur Android Expert

    I thought so too, but I tried plenty of times without success.
  7. derrickdroid

    derrickdroid Member

    any way to root 2.3.5 with a mac?
  8. themib

    themib Android Expert
    Thread Starter

  9. derrickdroid

    derrickdroid Member

    Well my computer seems to recognize the x2 when in fastboot mode. It asks for the drivers. But when i have the phone on, and select usb mass storage it doesnt seem to recognize it. i tried doing a factory reset and it didnt help.

    to get to fastboot I
    1. powered phone off
    2. held down volume down and power on
    3. pressed volume up when it said fastboot

    So now a few questions before i totally give up.

    Can i just root in fastboot mode? and if so how would i go about doing this?
  10. coolpoete

    coolpoete Android Enthusiast

    No, not that I'm aware of. Those modes allow you to perform an SBF to 2.3.4 or 2.3.5 which restores your system but will still have to root. Have you tampered with any system files on the phone? The only thing I can think of that would hamper the process is if you didn't use the correct drivers or if there was something wrong with the cable. Something is not allowing communication between your phone and the PC. When you plug it in do you have access to the memory card?
  11. derrickdroid

    derrickdroid Member

    No i dont have access to memory card. nothing pops up on my computer. but my phone somehow realizes it is being hooked up to the computer and goes into USB mode, which then offers me the different modes, such as charge mode, usb mass storage, pc mode and widnows media sync.

    but like previously described when in fastboot and i hook it up my computer finds the device. but then asks me for driver installation.
  12. coolpoete

    coolpoete Android Enthusiast

    Just for the heck of it I would tell you to try a hard reset on the phone and try again. Outside of that I am stumped. And to reiterate the phone has to be in charge only mode for the root tool to recognize it
  13. derrickdroid

    derrickdroid Member

    idk maybe it is just my computer. i will run to the library and try using one of theres
  14. themib

    themib Android Expert
    Thread Starter

    sounds like a drivers issue
    did you try installing drivers manually
    using link in op?
    or use iso file on cd or usb drive, no drivers needed
  15. themib

    themib Android Expert
    Thread Starter

    i believe pc mode also works
  16. derrickdroid

    derrickdroid Member

    I am at the library and it has seemed to work. I have superuser. But now i have ran into another problem. When i boot into recovery it comes to a Triangle with an ! in it and a little android dude. Any suggestions?
  17. themib

    themib Android Expert
    Thread Starter

    yes read directions
    press both volume buttons, to continue
    derrickdroid likes this.
  18. derrickdroid

    derrickdroid Member

    Thank you very much. didnt see that part. Phone is now rooted. :D
  19. coolpoete

    coolpoete Android Enthusiast

    Glad you got it rooted!
  20. derrickdroid

    derrickdroid Member

    Was starting to think this was the most difficult phone ive ever rooted.. :p

    Now where are the kernals?
    What ROM would you suggest?

    Im looking at Eclipse it looks nice. I want a change of MIUI and CyanogenMod. Those ROMS are very nice but virtually made for every phone. I wanna see what the X2 has to offer. :p
  21. coolpoete

    coolpoete Android Enthusiast

    lol.. where are the kernels... :D (not laughing at you but more in frustration that Moto is not unlocking our bootloader.)

    Now that you are on 2.3.5 rooted you may want to try Eclipse. That is the most stable and best rated ROM for 2.3.5. It's between Eclipse and CM7/CM9. As I mentioned, our bootloader is locked. As such there are no custom kernels for the phone. If you want to try CM7/9 then you have to flash the 2.3.4 SBF as those ROMs require that kernel. User DragonZKiller over at XDA developers is working on the KEXEC project that is a workaround to our locked bootloader. Untill then we do not have alot of choices and besides Eclipse and CM no one else is actively working on newer ROMs. You should do some more reading up on XDA to get more in-depth information.
    derrickdroid likes this.
  22. derrickdroid

    derrickdroid Member

    Okay... Before flashing a rom i wanted to Nandroid backup. But i dont see anything about backups in recovery. just flashing and clearing stuff.
  23. coolpoete

    coolpoete Android Enthusiast

  24. derrickdroid

    derrickdroid Member

    Okay it makes sense but it doesnt. I understand that you can back and restore off of a working ROM. But if ur ROM forces a boot loop, you are pretty much screwed then? Sorry if i seem newbish. Im just so used to being able to do everything from the Recovery itself. Thanks in advance.
  25. coolpoete

    coolpoete Android Enthusiast

    Yeah, things aren't as smooth on this device (again no thanks to Motorola!)
    It depends on what ROM you are trying to go to and where you are coming from. If you are switching from 2.3.5 to 2.3.4 or vice versa you will have to SBF because the kernels are different.

    Scenario 1: Let's say you are on 2.3.5 (ROM or stock rooted) and you want to go to a 2.3.4 based ROM. Download the recovery tool then perform your nandroid backup. You will then need to SBF to 2.3.4, root and install the ROM. If you wanted to go back to your nandroid that was on 2.3.5 you will not be able to use that nandroid restore directly. You will have to SBF back to 2.3.5, install the recovery tool THEN nandroid restore.

    Scenario 2: You're on stock 2.3.5 and want to flash eclipse (2.3.5). Install the BSR, nandroid, follow the directions to wipe data/cache and install the Eclipse ROM. If you wanted to go back just install the BSR from Eclipse (I think it's included, not sure) and nandroid restore. In this case you are on the same kernel, no need to SBF.

    Bootloops happen during SBF's typically when you don't wipe data, or cache and dalvik cache. (1 of the 3 not sure which one.) As a general rule I ALWAYS wipe all 3 no matter what they say. I can't emphasize that enough. Again some might say oh it's unneccessary if you're doing this or that but I've been in enough bootloops to know that if I follow my golden rule it won't happen again and I have had much success.

    If you get stuck in a bootloop during SBF just pull the battery, boot into recovery and wipe data and cache and you'll be fine. Another way to get yourself in trouble is running a nandroid restore from the incorrect kernel, eg applying a nandroid restore from a 2.3.5 onto a 2.3.4 kernel/system. In that case you will just have to apply the SBF which takes it back to stock and start over.

    If you try to install a 2.3.4 ROM over the 2.3.5 kernel or vice versa then most likely you will soft-brick your phone and it may get stuck on the "M" screen. In that case you have to perform a SBF based on the kernel that you want to be on and start over (root, install BSR, install ROM)

    I like to think of it in terms of installing a new OS on my computer. If you don't wipe the system clean you may run into some issues and the best way to install the OS or a backup of the OS is to start from a clean slate.
    derrickdroid likes this.

Motorola Droid X2 Forum

The Motorola Droid X2 release date was May 2011. Features and Specs include a 4.3" inch screen, 8MP camera, GB RAM, Nvidia Tegra 2 AP20H processor, and 1540mAh battery.

May 2011
Release Date

Share This Page