1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to root Atrix 2 running ICS 4.0.4

Discussion in 'Android Devices' started by ravinOrion, Jan 9, 2013.

  1. ravinOrion

    ravinOrion Newbie
    Thread Starter

    Here is the step by step method to root your Atrix 2 running ICS 4.0.4 :
    ( It worked for me 100% on my Atrix 2 ICS 4.0.4 Indian version )

    Credits : The XDA Developers ..

    I assume that you have all the drivers installed and have the original Atrix 2 data cable.

    step 1 - Download the file (highlighted in red) that you will need to root:
    ( The unzipped folder contains ROOT.bat and not UNROOT.bat ; so please don't ask me how to unroot it ; for the time being )


    Step 2 - unzip the file on your desktop

    Step 3 - open settings on your phone and tap on developer options
    Step 4 - Check "USB Debugging"
    Step 5 - go back to settings and tap on security
    Step 6 - check "Unknown Sources"

    Step 7 - connect phone to pc using data cable that came with the phone
    Step 8 - select computer connection as Camera (PTP)

    Step 9 - First run ADB.exe from the folder you have extracted ( important )
    Step 10 - When the program closes run ROOT.bat

    Progress :

    As soon as you run ROOT.bat .. your phone will reboot quickly ...

    Now just sit back until you are asked by the ROOT.bat window to press any key to continue.. the phone will reboot several times ..

    Don't touch your phone during this entire process.. it may take 3-5 minutes in the overall rooting..

    Once you close the ROOT.bat window.. wait till the phone reboots and back to your home screen..

    yay...!! Your Atrix 2 is ROOTED ... :p:)

    1. Download the Forums for Android™ app!


  2. davidwt

    davidwt Lurker

    I get a 410-Gone error page when clicking the above zip file link. Can this be fixed please?
    ravinOrion likes this.
  3. ravinOrion

    ravinOrion Newbie
    Thread Starter

    Link fixed.. :)
  4. ramcharger

    ramcharger Lurker

    My atrix2 was rooted until the ICS update, so I tried to root again, and when i run root.bat it says

    daemon not running, starting it now
    daemon started sucessfully

    Then it just sits there and does nothing, my phone doesnt reboot. Does anybody know what I should do?
  5. ravinOrion

    ravinOrion Newbie
    Thread Starter

    Make sure you have the latest Atrix 2 drivers installed on your PC.


    Make sure the "Debugging" is checked and the "Unknown sources" checked too ..

    Make sure the data cable is connected to your PC in "Camera PTP" mode.

  6. KaizenJunkie

    KaizenJunkie Lurker

    I followed your directions to the letter. I got the message as before where nothing would happen after running ADB...

    I searched the net, found the drivers, installed them, and got all the way to the hit any button screen and NOTHING happens. Any information would be greatly appreciated.
  7. skearton

    skearton Well-Known Member

  8. The53Dude

    The53Dude Lurker

    This is probably a stupid question, but does this process wipe my data off my phone?
  9. mgladin

    mgladin Lurker

    I am using an Atrix 2, 4.0.4, and everything seems to go ok, but after the process is finished, It reboots, but the screen is frozen. I have to get into recovery and wipe factory and start all over. I enabled USB debugging, I allowed installed from unknown sources, I put it in Camera (PTP), and it says in the command prompt it was rooted, but no such luck. Any help would be appreciated
  10. TVCCS

    TVCCS Android Enthusiast

    I wanted to say thanks for this post...I ran the directions on my stock Atrix 2 ICS 4.0.4. and it took about 5 minutes total. Another 15 minutes to make edits to enable tethering, lapdock, Hotspot and Bluetooth DUN (as largely described at http://androidforums.com/motorola-atrix-2/659006-wifi-tether-works-rooted-ics-atrix-2-a.html and I had all the functionality I needed in those areas.

    And no...the process did not wipe the existing data from the phone.

    Again, my thanks!
  11. my3footlizard

    my3footlizard Lurker

    Thank you so much for this thread. I have been looking all over the internet for a way to root my ATRIX 2. Once again thanks
  12. zzzzzz

    zzzzzz Lurker

    does android sdk need to be installed? by drivers do you mean only the adb drivers or motorola's up to date atrix drivers, or both? Or will these cause conflict with the adb drivers? i understand the microsoft .net 2.0 framework is necessary also when using xp to talk to my droid.. is this so? thank you so much for your time if you are able to respond.
  13. fadzli89

    fadzli89 Lurker

    it same happened on me....:(
  14. ushastikin

    ushastikin Lurker

    I had the same problem on my Atrix 2 ics 4.0.4 (root.bat doesn't "respond").
    Spending a lot of time in the internet, i have found only one solution to it - make a factory data reset. You can find it under Settings -> Privacy, but remember to backup all your needed data before.
  15. pgmrdlm

    pgmrdlm Lurker

    Now maybe I can get a handle on these app's that think they have to start up when the phone boots, even though they are not being used and the sms push has been disabled on them.
  16. premington

    premington Newbie

    How can I verify that the rooting occurred correctly?

    I followed these instructions and it said the phone has been rooted at the end of the batch file run, but during the process I received a few errors. It reported it didn't have permissions to write or remove some files. Still, at the end it said it was rooted.

    Is there a way to verify that it worked?

  17. shennwuu

    shennwuu Lurker

    can i unroot my atrix 2 after root using this ?
  18. rogerycecy

    rogerycecy Lurker

    this works to root atrix 2 4.0.4 at&t
  19. TBone69

    TBone69 Lurker

    Hi All,
    I've followed the instructions carefully, but I got the screen below.
    It's systematical. The same on several PCs.
    Could anyone help please?

    * daemon not running. starting it now *
    * daemon started successfully *
    rm failed for /data/local.prop, Permission denied
    /system/bin/sh: cannot create /data/local.prop: Permission denied
    remount failed: Operation not permitted
    failed to copy 'su' to '/system/bin/su': Read-only file system
    Unable to chmod /system/bin/su: No such file or directory
    failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file sy
    Unable to chmod /system/app/Superuser.apk: No such file or directory
    /system/bin/sh: cannot create /data/local.prop: Permission denied
    rm failed for /data/local.prop, Permission denied
    You are rooted!
    Press any key to continue . . .
  20. fungo45

    fungo45 Newbie

    You can download apps from the play store that verify it. I used one called Root Checker
  21. sms192005

    sms192005 Lurker

    TBone69 : Sounds like your not in USB Debugging mode or you don't have Unknown Sources App Installation on.
  22. droopies

    droopies Member

    Excellent write up. I had the same issue with it stalling out, until I went to Motorola's site and downloaded the Motorola USB driver pack.
  23. ssb155

    ssb155 Lurker

    Hi All,

    I have an Atrix 2 running on 4.0.4. I followed all the steps mentioned in this thread and as well as the xda thread link given. But all I get is a Command Prompt window showing:
    * daemon not running. starting it now *
    * daemon started successfully *

    Now, I have connected the Original USB Cable. I have checked the USB Debugging and Unkown SOurces. I made sure the USB Connection was in Camera Mode. 1st ran the adb.exe file and then the ROOT.bat file. But I get this window, no matter how many times I tried. Is there anything else I can do?
  24. Exactly the same issue here. Everything followed to the letter, and can't get past the stuck .bat script.

    MB865, Win7 x86.

    It's like a cruel joke...I've been waiting for a long time to get this thing rooted after all the time dealing with the locked bootloader issue; I find this page, all goes smoothly, and then...nothing. Ack!

    The ONLY thing I can think of that I haven't tried is running Windows updates. I don't know what that would accomplish, but I don't know what else to try.

    Thanks for any help!


    Still no joy, but maybe some clues.

    When I run adb.exe, what appears looks an awful lot like a linux man page, rather than something installing. I don't know if that's supposed to be what pops up, but I doubt it, and I'm betting that's my (and others'?) problem.

    Additionally, if I run ROOT.bat as administrator, the cmd window outputs a whole string of
    Code (Text):
    1. 'adb.exe' is not recognized as an internal or external command, operable program or batch file.
    followed by "You are rooted!"


    Anyway, this also seems to point to something going wrong with adb.exe. Incidentally, I get the same manpage-looking output whether I run adb normally or as administrator.

    I don't know what the issue is, but I'll keep trying, and if anyone has any suggestions, I'm all ears!
  25. Branga

    Branga Lurker

    when i run adb thats all fine, then i run the root batch file and my phone tries to reboot... but whenever my phone boots normally i have to hold down both the up and down volume keys and the power button otherwise it wont turn on it will just go to the AP fast boot flash mode(s) (flash faliure) screen.. and it will only sit on that screen can somebody help me please! ive tried to root this dam phone for ages now and noone is helping me!
Similar Threads - root Atrix running
  1. BruderDak
  2. AlinTecsan
  3. Andrew Webberley
  4. jerrysuntan
  5. Crazy Gamer
  6. monkeyman15
  7. hijratdarman
  8. Nishaun Lawrence
  9. dorlow
  10. MrJavi

Share This Page