1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to root device in Oracle VM Virtual Box

Discussion in 'Computers' started by dars1987, Jan 6, 2014.

  1. dars1987

    dars1987 Lurker
    Thread Starter


    Hi All,

    I have installed a Android OS Version 4.3 in Oracle VM Virtual Box, It's Working fine but when i goes to install any apps from Google apps it says that device is not compatible, i Google for same error find a way to root device can help me in this so any one have idea to root device in Oracle VM Virtual Box..

    Thaking You in adv.
     


  2. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    Hi there, dars1987. This is a tough one! :)

    It's hard to say if the problem you're having is an Android problem, a VM problem, or some other issue, perhaps related to the OS you're running the VMed Android on. :hmmmm2:

    My guess is that it's a VM issue and, because of that, I'm moving this thread to our Computers & IT board. If someone else thinks it's better served in an Android area, it may be moved again.

    Meanwhile, please give us a bit more info about your specific configuration, including the OS you're running the VM on and the version of the Oracle VM VirtualBox you're using.
     
    mikedt likes this.
  3. mikedt

    mikedt 你好

    Is this Android-x86? - if you're running it in Virtual Box on a PC. If so you should have root on that, it's completely open. The Google Play app compatibility can be another issue entirely, for one thing Android-x86 is very much beta experimental, e.g. things might not work, buggy, unimplemented or are incomplete, if that's what you're using.
     
    MoodyBlues likes this.
  4. mikedt

    mikedt 你好

    MoodyBlues and lunatic59 like this.
  5. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Okay, let me see if I understand ... you are running Android in a VM? The problem you are encountering is that the Play store can't identify your "device" and therefore reports the apps as incompatible.

    It used to be all apps were "compatible" unless there was something specific that made it incompatible. Now I believe Google reversed that and your device's specs must meet all criteria for it to be installed.

    This thread over at XDA might help ... [GUIDE] How to edit build.prop on any Android device! - xda-developers

    Remember to be sure to understand what you are doing or you could irreparably bork your setup. Let us know if you get it working. :)
     
    MoodyBlues and mikedt like this.
  6. mikedt

    mikedt 你好

    Yeh it did crash my Mac earlier when I first ran it....hold down power switch to reboot. I ran it with Linux > Other, 1GB RAM as the selected VM model, which seemed to be the most appropriate for Android. You have to set the VM mouse options to PS/2, otherwise the Android VM assumes a touch screen, and it can be difficult to control Android without a touch screen. :D
     
Loading...

Share This Page

Loading...