1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to Root Insignia Flex

Discussion in 'Android Devices' started by pcdebol, Dec 11, 2012.

  1. pcdebol

    pcdebol Newbie
    Thread Starter

    Simple root on this tablet use Bin4ry ICS root works like a champ.

    First you have to get ADB up and working. Pretty easy to do.

    To get ADB up and running add these lines to the latest google usb drivers included in the SDK. Modify the android_winusb.inf file. Add the lines below to the file you should be able to figure out where if you read the file. I know these lines work on 64 bit windows should also work on 32 bit windows.

    %SingleAdbInterface% = USB_Install, USB\VID_16D5&PID_8005
    %CompositeAdbInterface% = USB_Install, USB\VID_16D5&PID_8005&MI_01

    Then in your user directory. This folder may exist. C:\Users\YourUserName\.android there be a file called adb_usb.ini. Add line below to that file then ADB can see your device.

    If .android folder does not exist in your user directory you will have to create the .android directory using either a bat file or the command line.

    Here is the code to do it.
    @echo off

    if not EXIST %userprofile%\.android\ ( mkdir %userprofile%\.android\ )

    Then you have to create adb_usb.ini in notepad. This is all it will contain.

    # USE 'android update adb' TO GENERATE.


    You may have to turn off driver signing on your computer depending on OS to install driver after modding the inf file. Use google for instructions on how to do this with your version of windows.

    Link to download and instructions for Bin4rys root tool.


    Have fun takes about 3 minutes.

    I created a tool to get ADB working and check it on the Flex but can't post links yet.

    1. Download the Forums for Android™ app!


  2. pcdebol

    pcdebol Newbie
    Thread Starter

    First thing I did after rooting was install root app delete and disable the 2 update apps on mine. Pretty sure that will keep it from getting an ota update that kills root.
  3. haydenb91

    haydenb91 Lurker

    Would somebody mind creating an easier method (flash a .zip file) for us that are not that tech savvy? Using the SDK makes me nervous.
  4. haydenb91

    haydenb91 Lurker

    @pcdebol Personally, I would take Jelly Bean over rooted ICS.
  5. pcdebol

    pcdebol Newbie
    Thread Starter

    Actually you don't have to use the SDK. It's just the tool I used to get the current Google driver.

    What I posted is nothing more than instructions to customize the standard Google USB driver so the adb command can see the device. Then you can use the ICS root tool.

    Here is a link to download the modded driver there is also a bat file in there to that creates the .android folder and puts in the INI file.


    Personally I can't tell enough difference between ICS and JB to loose root. I have run both on my phone and ended up putting it back to ICS because of a few issues I had running JB.

    I'd bet some custom ROMs will be out for this device shortly. It is to good of a device at the price point. Should be popular.
    proprod and detcup4evr like this.
  6. detcup4evr

    detcup4evr Newbie

    I downloaded your utility. I am running windows 7 64, When I try to install the driver I am getting file not found. The adb_usb file in .android contains the following:

    # USE 'android update adb' TO GENERATE.

    I made sure to reboot with f8 to disable driver signing. Wondering if you have any thoughts.

    See Screen Shot of Error message while installing driver.

    Attached Files:

  7. detcup4evr

    detcup4evr Newbie

    I ended up downloading the SDK, and using sdk mgr to download the USB driver, Then replaced the the androd_winusb.inf with the one from your zip and everything installed. I then Ran the latest Bin4rys root tool and I am rooted (had to run it twice) :)

    lpagan likes this.
  8. pcdebol

    pcdebol Newbie
    Thread Starter

    Not sure why you couldn't get the driver installed. The current driver from the SDK is in the zip. You have to manually point to it to install it.

    The .bat file only creates the adb_usb.ini and the .android folder that has to be in place for the adb executable to see the device. It doesn't install the driver. Everything is there though.

    I'll try to do a write up to explain what I did it will make it easy to understand. It will also help people with other devices so they can customize the driver from the SDK to work with their device and try known exploits.
    lpagan likes this.
  9. lpagan

    lpagan Newbie

    thanks you guys and this forum rocks, follow your steps and all good . rooted. thanks again
  10. warkev

    warkev Lurker

    Derar sir I have followed your post explicitly my PC detects the device fine and when I do the last step it reboots my flex but still no root any update
  11. dinsfire

    dinsfire Lurker

    So frustrated, can't figure this out for the life of me. I wish this guide was more beginner-friendly, and from the date on the last post, I really doubt I'm going to get any help at all.

    - Where can I access or acquire the SDK you mentioned?
    - I created the .android directory, but how do I create a .ini using notepad? I just made a document in notepad and titled it adb_usb.ini, but the file is still clearly a .txt file
    - Whenever I try to update the driver in device manager it just says it's already up to date
    - ADB is online, but my Flex is not recognized as a device using Bin4ry's tool. (I have debugging on)
  12. detcup4evr

    detcup4evr Newbie

    You can get the sdk here: Android SDK | Android Developers

    Once you have it installed run the updater to get the USB driver, then replace it with the one you downloaded above
  13. detcup4evr

    detcup4evr Newbie

    I had to run the root tool 2 times back to back to get root.
  14. vandulism

    vandulism Lurker

    Is there any easier way to do this
  15. vandulism

    vandulism Lurker

    Is there any way you can make a video on how to do this or give be better steps, because im having trouble doing this. Like can you make is step by step and simpilar, thank you
  16. dinsfire

    dinsfire Lurker

    I just used the bin4ry tool to root my Venice and it was the easiest thing ever, but I STILL can't figure out how to do it to my Flex. Jesus, this is infuriating.
  17. dinsfire

    dinsfire Lurker

    Finally got it working! For those still having trouble, REMEMBER TO TURN OFF DRIVER SIGNING ENFORCEMENT! I thought I had done it, but it turns out I didn't, and as soon as I did, everything worked like a charm!

    Here's an easy guide to doing it if you can't figure it out!
    The Geek Professor
  18. detcup4evr

    detcup4evr Newbie

    Just got notice there is a system update, anyone take it yet? Where u able to root again? I have supersu pro wondering if ota survival mode will work.
  19. proprod

    proprod Lurker

    I had this thing rooted and was careless and accepted the update to Jellybean. Now I can't root this for the life of me. I've tried every tool online and no success.

    I'm wondering, if I do a factory reset using the button on the back, will that take me back to ICS, so I can do an OTA root-keeper and then accept the Jellybean upgrade?

    Any input is appreciated.
  20. detcup4evr

    detcup4evr Newbie

    Yeah, Did the same thing your hosed. I tried every single thing on the web. The only good thing is I believe I have managed to get the device into fastboot mode. I have also found steps to compile TWRP recovery for the device. Once I get some time I am going to see if I can get a custom recovery pushed to the tablet, If I can then we will be in business. I just need to make the time to take the next steps.

    *reset won't revert you back, Also the software OTA root Keeper didn't work, Used Both SuperSU and Voodoo, neither of them saved root*
  21. proprod

    proprod Lurker

    detcup4evr likes this.
  22. detcup4evr

    detcup4evr Newbie

  23. geenidee

    geenidee Newbie

  24. proprod

    proprod Lurker

    I suppose use it at your discretion.

    There's nothing odd on my computer nor is there anything odd on the tablet.

    I guess it depends on how bad you want your Flex rooted ;)
  25. ubermich

    ubermich Lurker

    Anyone found a better method in lieu of the Chinese option? I just picked up a Flex 8 which came with JB 4.2.2 out of the box (NS-14T002)...

Share This Page