1. Are you ready for the Galaxy S20? Here is everything we know so far!

How To Root SCH-730 2.3.4

Discussion in 'Android Devices' started by Lilg37, Nov 22, 2011.

  1. Lilg37

    Lilg37 Well-Known Member
    Thread Starter

    i did some research and found the right stuff to root this phone
    i do not take credit for this at all only for bringing it here to the forums for us here

    1. Download the file below
    2. extract to desktop
    3. run the file that says "run" let it boot
    (u may not have installed superuser during the rooting process so i recomend doing so manually by placing it on the root of the sd card and installing it from there)
    4. download "Terminal Emulator" from the market
    type "su" it will ask u to allow it
    then type "reboot"

    if ur phone reboots then u have root acess

    Attached Files:

  2. sezni

    sezni Lurker

    i successful,thank you very much
  3. toyotahilux

    toyotahilux Lurker

    I tried the steps above and when i type su it says permission denied, I dont know what iam doing wrong. Any suggestions would be appreciated
  4. Lilg37

    Lilg37 Well-Known Member
    Thread Starter

    Did u install superuser.apk from the zip folder befor u tried it?
  5. I've downloaded the file for rooting the transfix. How do I get it to the desktop?
  6. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    You should just be able to select the desktop as the download location on your PC?

    You'll then need a program like Winrar or Winzip to extract the files to your desktop.
    Lilg37 likes this.
  7. SmilingAhab

    SmilingAhab Lurker

    So, just got my Transfix, grabbed this rootkit, got my phone hooked up, installed superuser, extracted the kit to my desktop, ran, run.bat...

    and nothing.

    error: unknown host service
    [*] Triggering core dump..."
    error: device not found
    error: device not found
    error: device not found
    error: device not found
    error: device not found
    "Rebooting phone. It may buzz a lot and loop on boot. Don't panic."

    And does nothing.
    Tried it with USB storage both enabled and disabled. Also, compatibility mode for vista and xp did nothing.
    no root wat do?

    EDIT: You forgot to add the step to enable USB debugging mode through Settings::Applications::Development::USB DEbugging.
    img, #cubbies-overlay{ -moz-transition-property: margin, box-shadow, z-index; -moz-transition-duration: 0.1s; -webkit-transition-property: margin, box-shadow, z-index; -webkit-transition-duration: 0.1s; } .cubbies-selected{ z-index: 9999; box-shadow: 3px 3px 8px -1px blue !important; cursor: pointer !important; margin: -3px 3px 3px -3px; } .cubbies-selected:active{ box-shadow: 2px 2px 5px -1px darkblue !important; margin: -1px 1px 1px -1px; } #cubbies-overlay{ position: fixed; z-index: 9999; bottom: 30px; left: 30px; box-shadow: 0 2px 3px rgba(0,0,0,0.8); border: none; } #cubbies-overlay:hover{ box-shadow: 0 2px 3px rgb(0,0,0); }
    gatecrasher59 likes this.
  8. sthcom

    sthcom Lurker

    im having the same problem, i have super user installed along with terminal emulator. I have debugging on, and have tried running run.bat only to get the same message shown above. Still without root. What do i do now?

    TOP FLIGHT Lurker

    alight extract the first file that says run then open the file that was extracted then hit the one that says run then it should reboot your phone!
  10. sthcom

    sthcom Lurker

    Finally got root awhile ago, any idea when we might see a ROM for this phone?:D
  11. Mine is rebooting and its still sitting here with samsung on the screen and keeps vibrating. I'm starting to worry.
  12. nixnax

    nixnax Lurker

    How is it that you run the "run" script from the phone? I've tried running the script from a terminal emulator with no success, and even opened the file in a text editor to see if my programming knowledge might help.

    1. Download to Desktop
    2. Move to SDCard
    3. Install Superuser on root of SDCard
    4. Run script how?

    Thanks. Any help is greatly appreciated for this noob.

    P.S. When I try and open the run.bat file, I receive the following message: "File type bat not recognized"
  13. nixnax

    nixnax Lurker

    Same thing for myself...
  14. sthcom

    sthcom Lurker

    NIXNAX You aren't using a Windows system are you? .bat is windows specific.
    My problems were solved by downloading and installing the Transfix drivers (it took an extremely long time for them to install from my phone, there were about 5 more drivers when debugging is active)
    Let it sit for a while and everything install, then run "run.bat" mine worked flawlessly after i waited for everything to install.
    All of this needed to be done on windows. i tried Mac, and linux XD
  15. christa18

    christa18 Lurker

    doesn't even work for me...
  16. christa18

    christa18 Lurker

    i even tried it several ways PLEASE HELP. text me other ways if youd like please.. 724 425 6830
  17. Delirious84

    Delirious84 Lurker

    I rooted but ran into some problems. I just took my time and tried a few things and it worked. This is what I did...

    Pre-rooting steps.
    1. Plug in your Samsung Transfix to your pc. Make sure drivers load.
    2. Go to Settings>Applications>Development> and check USB Debugging

    1. Download the file above
    2. Extract to desktop or in the folder of your choice.
    3. Run the file that says "run". It will load a screen and run through the process and reboot your phone. It said on my pc to enjoy my rooted phone.
    4. Download "Superuser" from the market. Install and run.
    5. Download "Terminal Emulator" from the market
    type "su" it will ask u to allow it
    then type "reboot" if it doesn't reboot, type it again. I had to do it twice for some reason. I think because of the $ and # signs....$ is normal and #is SU.

    Should look like this
    Code (Text):
    2. $ export PATH=data/local/bin:$path
    3. $_
    After you type in SU it should show the # sign. This will let you know if you are rooted and have SU access.

    I am a total newb to rooting(my first root) and with little troubleshooting and not the best guide in the world to follow off of I think it went pretty smooth.
    Hope this helps.
  18. taylor441

    taylor441 Lurker

    Thank you!!!
  19. reenoip1

    reenoip1 Newbie

    titanium backup says its not rooted
  20. Menchaca

    Menchaca Lurker

    now how do i get free apps and customize my phone the way i want it?

    p.s. thanks to everyone, i used a little from each and got it
  21. Scotty2000

    Scotty2000 Lurker

    Can anyone post a video on yosutube on this process because i dont want to risk screwing up my phone.
  22. seediqbale

    seediqbale Lurker

    tanx a bunch :cool:
  23. VooDooChylde

    VooDooChylde Lurker

    Thanks so much just got the transfix and it was a little different to root but thanks to you I got it done, Thanks!!
  24. ninafbabyy

    ninafbabyy Lurker

    Basically this is pissing me off.. Can someone give me the play by play.. Cause all of this is crazy talk to me.. And I really just want a screen shot app.. I got the zip file on my desktop I got the emulator and I have super user.. Why is this not working?!
  25. OldDogEyes

    OldDogEyes Newbie

    This may or may not help, but when I was rooting a different phone and kept running into this problem, it turned out that I had NOT selected the option to mount the phone as a "Disk Drive" in Android Settings on the phone. The option to charge only (as in charge the battery) was selected.

    Once I went into Settings > Connect to PC > Default Connection Type _or_ selected the USB option in the notifications tray and changed from Charge to 'Disk Drive', I was able to get past this error.

    One other possible source of problems: If you have a "Charge Only" cable that doesn't have the wiring to sync, you'll get the same type of error. Believe it or not, some cheap cables lack the wiring for data sync (mount as Disk Drive) but do charge... I know, I have one. So make sure that you use a USB Cable that is known to have the complete wiring for data...

    Hope that helps someone...

Samsung Transfix Forum

The Samsung Transfix release date was October 2011. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1500mAh battery.

October 2011
Release Date

Share This Page