1. Check out our companion app, Forums for Android! Download from Google Play

How to root SPH-M840 Samsung Galaxy Ring

Discussion in 'Android Devices' started by sr10638, Jul 11, 2013.

  1. sr10638

    sr10638 New Member
    Thread Starter
    28

    Jul 11, 2013
    3
    14
    28
    Male
    Ok,

    So i'll start by saying I have successfully rooted this device. Please be aware you may brick your device in this process, I say this only as a precaution I have yet to have any problems using this method, but as always be weary. For the root I used the method I found here http://forum.xda-developers.com/showthread.php?t=2130276 by poster alephzain and tweaked it a bit for this device. All I had to do was the following:

    1) Grab the file from the above mentioned guide (Framaroot-1.5.1.apk)

    2) Email this file to yourself, so you can download it to your phone directly (but don't download yet).

    3) On your device go to settings and then security. Make sure App installation from unknown sources is checked.

    4) Now bring up the email you sent yourself with the attached file on your phone. Download the attachment and install it. Make sure to select package installer, not the Google installer when prompted.

    5) Open the app, Framaroot. Leave the "Install Superuser" setting alone and select the Gandalf exploit from the list. Then reboot your device.

    6) Once the reboot is complete again open Framaroot app. This time changing "Install Superuser" setting to "Install SuperSU" and again select the Gandalf exploit from the list. Then reboot your device again.

    7) DONE! That's it. You device should now have root access. Verify it by downloading a root check app from the Play store.

    It's quick and painless, I rooted my device in less than 5 minutes without needing to connect the phone to a computer.

    Again I want to give credit to where I got the information and the Framaroot.apk to alephzain and the developers of the Framaroot app. This is just a modification of their instructions.

    Please let me know how it goes for you!.

    -SR10638
     

    Advertisement

  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    oh nice....thanx for posting this.....i'm gonna sticky this, if you do not mind.
     
    palmtree5 likes this.
  3. aestrada225

    aestrada225 New Member
    5

    Jul 18, 2013
    4
    0
    5
    Male
    California
    Mine didn't root according to the root checking app I got from the play store. Should I try doing it again or should I try it with 1.5.2?
     
  4. Mobstergunz

    Mobstergunz Well-Known Member
    313

    Sep 5, 2011
    2,896
    1,444
    313
    Reading, PA
    This didn't work for me either. My assumption is if you accepted the OTA updates this root method will not work
     
    ocnbrze likes this.
  5. beatdroppah

    beatdroppah Well-Known Member
    38

    Mar 18, 2011
    114
    10
    38
    Indiana
    just picked my Ring up today. took the OTA immediately. follow that same link, and download the (now) 1.5.3 version of the apk and followed OP directions. works fine for me, got me rooted, and downloaded and ran wifi tether to confirm. thanks :)
     
    Orothos and ocnbrze like this.
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    Congrats!!!!!!!!!!!!
    :party:
     
  7. beatdroppah

    beatdroppah Well-Known Member
    38

    Mar 18, 2011
    114
    10
    38
    Indiana
    thanks!!!! too bad im bootlooping already...hence my thread i opened :/
     
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    oooops:eek::(

    i missed that thread:(:(:(
     
  9. beatdroppah

    beatdroppah Well-Known Member
    38

    Mar 18, 2011
    114
    10
    38
    Indiana
    oh its all good, just frustrating...havent even had the phone for 6 hours lol...and i cant get stupid adb logcat to work to help me fix it...ugh
     
  10. tinaburke

    tinaburke New Member
    25

    Mar 11, 2012
    4
    0
    25
    Thanks...first try worked perfect..good work..
     
  11. Orothos

    Orothos Member
    26

    Nov 13, 2013
    5
    1
    26
    Does it still work with current as of 11/15/13?
     
  12. tootonetony

    tootonetony Member
    15

    Dec 21, 2012
    15
    0
    15
    Male
    Baltimore, Maryland
    If I updated my samsung and official os firmware in my settings cant the root still work with this exploit or will it brick it
     
  13. russtang

    russtang New Member
    5

    Aug 16, 2012
    2
    0
    5
    Just used framaroot 1.7.0 to root mine. No problem. Android 4.1.2, kernel 3.4.0-1382747 08/29 12:12:35.
     
  14. borstarhymes

    borstarhymes New Member
    5

    Jan 15, 2014
    2
    0
    5
    i've never done a root before and am nervous i went to the site and noticed there is higher framaroot 1.8 something i think should i DL that one instead any help would be appreciated as i don't want to brick my phone
     
  15. borstarhymes

    borstarhymes New Member
    5

    Jan 15, 2014
    2
    0
    5
    also will rooting my phone allow me to have the phone read the sd card as internal storage thanks again
     
  16. captne76

    captne76 New Member
    5

    Feb 10, 2014
    1
    0
    5
    Had a Virgin Mobile Samsung SPH-M840 and it had some weird phone number with 6 zeros to start and wouldn't connect.
    Cust Support gave me the following in order to View Edit or save (Done) the MDN number (your assigned phone number) and the MSID number:

    Dial ##543576# that will bring you to the screen to do that.

    Other numbers they gave me earlier that did not work, but do other things that might work for you:

    ##72786# request for update (You get a screen message SCRTN and then it reboots)

    ##847446# might be an update or activate request.

    :D
     
  17. jenniferwrinkle

    jenniferwrinkle New Member
    5

    Feb 15, 2014
    1
    0
    5
    Female
    tennessee
    i completed this and it has worked thus far. now that it IS rooted, how to i transfer all my apps to my sd?
     
  18. mjhealy78

    mjhealy78 Member
    26

    May 23, 2012
    22
    3
    26
    Male
    Lowell, Ma.
    Yah,
    All's well that ends well! Simple, easiest phone 've ever rooted! Kinda took all the fun outta it!!! Oh well thanks guys/gals~:D
     
  19. mjhealy78

    mjhealy78 Member
    26

    May 23, 2012
    22
    3
    26
    Male
    Lowell, Ma.
    Just rooted my girls galaxy ring, worked fine! I used framaroot 1.9.1 with no problems, almost too easy! Thanx!!!
     
    nickyhickey likes this.
  20. SariBalles22

    SariBalles22 New Member
    5

    Mar 5, 2014
    1
    0
    5
    I finally got mine rooted.. My current issue is I cant manage to get rid of the Virgin mobile boot animation or the virgin mobile tagline on my lock screen. those are really the only two reasons I wanted my phone rooted in the first place :/
     
  21. bakerd62

    bakerd62 Well-Known Member
    23

    Jan 15, 2014
    95
    26
    23
    Found a way to root the Samsung galaxy ring(sph-m840), after md5 OTA update!
    1. Download framaroot 1.5.1
    2. Open the app, choose superuser
    3. Click Gandalf
    4. Reboot your phone
    5. Go back to the app, repeat steps 2 and 3
    6. Reboot your phone
    7. Download root checker from the play store
    8. Check to see if you have root access
    (9) If you don't have root access, then redo steps 2-4
    10. Phone is rooted!!!!

    Hoped this helped :)
     
    mjhealy1978 likes this.
  22. TheRealKTFO

    TheRealKTFO Well-Known Member
    58

    Aug 18, 2011
    101
    11
    58
    is everything!
    Rooted my Ring yesterday following this guide. I'm a little upset about the whole process. It was way too easy.

    I already had the mh5 update, Kernel 3.4.0-1382747...I used Framaroot 1.5.3.

    Have noticed zero issues so far...Now I need to find something that works to move my appps/files to the sd card.

    Easiest root of a phone I've ever done...
     
    mjhealy1978 likes this.
  23. kzthc23

    kzthc23 New Member
    6

    May 17, 2014
    1
    1
    6
    I rooted this phone with Framaroot-1.9.2. It was even simpler than the original post, all I had to do was open Framaroot, tap Gandalf, reboot, and the phone was rooted, simple as that.
     
    mjhealy1978 likes this.
  24. mjhealy1978

    mjhealy1978 Well-Known Member
    78

    Apr 1, 2013
    401
    101
    78
    Male
    Lowell,Ma.
    I rooted my girls Galaxy Ring back in January with Framaroot!!! Simple!!! I used it to root my Lg Optimus F3 4G last week too. It really is too easy!
     
  25. Melissa Glick

    Melissa Glick New Member
    15

    Mar 15, 2015
    1
    0
    15
    Female
    Artist
    Cambridge, MA
    tried to download forum.xda-developers.com/showthread.php?t=2130276 Framaroot-1.51apk ....contained virus!
     

Share This Page

Loading...