1. Download our Official Android App: Forums for Android!

Root How to root Verizon Galaxy S4 with Lollipop (5.0.1)

Discussion in 'Android Devices' started by barry.holroyd, May 1, 2015.

  1. Emo rocker3

    Emo rocker3 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Jan 31, 2016

    Jan 31, 2016
    4
    0
    15
    Male
    You might wanna try flashing is with Odin that will work for sure with the kernel u have
     

    Advertisement

  2. Emo rocker3

    Emo rocker3 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Jan 31, 2016

    Jan 31, 2016
    4
    0
    15
    Male
    You might wanna try flashing is with Odin that will work for sure with the kernel u have
     
  3. scubaman

    scubaman Member
    Rank:
    None
    Points:
    36
    Posts:
    68
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    68
    8
    36
    Could you elaborate on that please?
     
  4. scubaman

    scubaman Member
    Rank:
    None
    Points:
    36
    Posts:
    68
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    68
    8
    36
    I just rooted SCH-I545 5.01 (OF1) using the NewKingrootV4.90_C142_B262_xda_release_2016_04_21_105243.apk. I'd tried Kingroot a few months and was not successful, with apk and PC version. I nearly didn't try but then thought what do I have to lose? Phone is factory reset anyway. And to my surprise it worked!

    What I really wanted to do is get the AOSP Rom on there on this phone... but I have not been able to. I am unable to flash Philz recovery using various version of odin. Lots of people have that problem, and I find very few resolutions, none for the I545. And only lots of BS about using the original USB cable only - what total nonsense! Yeah don't use a real crappy cable, but there is no magic about the 'original' cable... Anyway, Odin just always gives me an error. So now I can root this thing but I don't think I am any closer to installing a custom ROM. Or simply a custom recovery which is step 1...
     
  5. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    Verizon locked the bootloader so no chance of a custom recovery. There are a few modified stock Touch wiz based Roms that you can flash with Flashfire. You might even be able to get Xposed installed but not much else you can do with i545.

    I ran this for a few weeks before I sold i545
    http://forum.xda-developers.com/galaxy-s4-verizon/development/stang5litre-ediition-5-0-t3132555
     
  6. scubaman

    scubaman Member
    Rank:
    None
    Points:
    36
    Posts:
    68
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    68
    8
    36
    All I wanted to do is pass my S4 on to my sister in Germany... but it would have to be in German throughout, from initial setup. Verizon has only 5 or 6 languages and German isn't one of them. There are some ways to change locale once it's set up, but I wanted more than that. Lots of stuff is left in English... oh well, bummer! Thanks for the link, looks pretty decent!

    Rich
     
    Jfalls63 likes this.
  7. CanHasDIY

    CanHasDIY Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    May 22, 2016

    May 22, 2016
    1
    0
    15
    Male
    Still working as of May 22 with the apk version! Now to swap SuperSU and get rid of some bloat...
     
  8. MCLiLMack

    MCLiLMack Lurker
    Rank:
    None
    Points:
    15
    Posts:
    6
    Joined:
    Mar 17, 2016

    Mar 17, 2016
    6
    0
    15
    Male
    Grand Rapids, MI
    I have my phone rooted using KingRoot and I tried to flash a cmw recovery using Rashr and it didn't allow me to install it or it installed wrong. I am a noob and I am trying to get my phone back to working status. It won't let me connect to Google Play nor will it allow me to re-install it. It also deleted google play services which seems to be important for other things to work lol Has anyone ran into problems like this and what could I do to get it back to factory status?
     
  9. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    Download the stock firmware from here
    http://www.sammobile.com/firmwares/download/53590/I545VRUGOF1_I545VZWGOF1_VZW/
    Create a free account. Download takes about 30 to 45 min. Flash with Odin. Instructions at bottom of page.
    Or use the Verizon Samsung Software Update and Repair Tool
    http://www.verizonwireless.com/support/knowledge-base-80201/
    The bootloader is locked so you cannot install a custom recovery.
     
  10. MCLiLMack

    MCLiLMack Lurker
    Rank:
    None
    Points:
    15
    Posts:
    6
    Joined:
    Mar 17, 2016

    Mar 17, 2016
    6
    0
    15
    Male
    Grand Rapids, MI

    Have you ever used heimdall? or has anyone. I have been trying to use the online version of Oden but for some reason it won't allow me too. Im using Safari. Should I be using a different browser to use the online version? Im running a Macbook so Im trying to figure out how to properly do these things.
     
  11. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    Have a look at JOdin.
    http://forum.xda-developers.com/showthread.php?t=2598203
    I have never used Heimdall since I have Windows laptops.
    The second link I posted above for the Verizon tool also has a version for Mac. The Software Update and Repair tool will backup you data, reflash the firmware, then restore data if the system is not to corrupt.
     
  12. MCLiLMack

    MCLiLMack Lurker
    Rank:
    None
    Points:
    15
    Posts:
    6
    Joined:
    Mar 17, 2016

    Mar 17, 2016
    6
    0
    15
    Male
    Grand Rapids, MI

    Thanks a bunch. I am currently using the Vzn Update/Repair Tool. it wouldn't pop up on my computer at first but it is now. I still have some time for the firmware download to complete while I try that method so hopefully it works. I have never had this problem before and it makes sense now that you told me the boatloader is locked. So my next question will be what can you still do with a rooted phone as far as changing the way it looks and runs. I know that is a loaded question haha If there are links to the answers in this forum and you can direct me that would be greatly appreciated.
     
  13. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    When I had my i545, after I rooted it, I flashed the 5.0 OF1 Deodexed ROM with FlashFire from here
    http://forum.xda-developers.com/gal...-to-update-to-i545of1-5-0-1-keeproot-t3182544

    I installed Xposed framework from here
    http://forum.xda-developers.com/gal...ow-to-install-xposed-5-0-1-including-t3160856

    I think the only Xposed module I had installed was Wanam.
    Didn't play around with the phone much before I flashed it back to stock and sold it.

    I did try Stangs 5.0 ROM for a few days before Deodexed and Xposed.

    http://forum.xda-developers.com/galaxy-s4-verizon/development/stang5litre-ediition-5-0-t3132555
     
  14. MCLiLMack

    MCLiLMack Lurker
    Rank:
    None
    Points:
    15
    Posts:
    6
    Joined:
    Mar 17, 2016

    Mar 17, 2016
    6
    0
    15
    Male
    Grand Rapids, MI
    Thank you for your help. Vzn software update tool worked. I know this is an older phone but some of us are broke still and the phone is still pretty decent used. Flash Fire doesn't recognize that the phone is rooted using King Root. I have verified the the phone is rooted with Root Checker. Does anyone who still has this phone had this problem?
     
  15. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    Not sure. Most who use Kingroot also use Super-Sume pro to remove Kinguser and replace with SuperSU. I used a different root method so didn't have Kinguser.
    The S4 is still a great phone. I have a i337 that I tinker with some and a few S3's.
     
  16. swango80

    swango80 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 29, 2016

    Oct 29, 2016
    1
    0
    5

    This worked perfect for me!
     

Share This Page

Loading...