1. Are you ready for the Galaxy S20? Here is everything we know so far!

How To: Root w/ Mac OSX

Discussion in 'Android Devices' started by jxnrxy, May 17, 2010.

  1. jxnrxy

    jxnrxy Well-Known Member
    Thread Starter

    Many people ask how to root their phone on Mac OSX. I myself was once in that position. I researched and eventually figured it out. It's very simple and really not much different from Windows installation using http://androidforums.com/all-things-root-eris/53963-guide-stock-1-5-latest-root-2-1-a.html

    now everything from this point on is assuming that you have the android SDK setup and working on your Mac. Also make sure you've rooted your phone using the PB00IMG.zip (md5: 63eacc5ede3b179f95dc22d8ef585f94) from the link above. Once your phone is on go ahead and make sure that you have enabled USB Debugging and your phone is plugged in via USB and set to "Charge Only".

    I'll explain how to install Amon's recovery image using Terminal(command prompt for mac users)

    1.Download the recovery.zip file from the link above and unzip/extract the files. Now take those files and place them in your /tools directory of your Android SDK.

    2. Next open Terminal (applications>utilities>terminal). First go ahead and change the directory to your android sdk/tools folder using the following command:

    cd /Users/(enter your folders and path) /tools

    and easy way to get the path:

    so type cd in terminal, then go to your /tools folder of your Android SDK and click and drag it into your terminal window!

    You can also open the android sdk tools folder, dbl click pretty much any of the executable files. It will open a terminal window and at the top you'll see the path you want (/Users/.../tools) copy it/remember it. Be sure to leave the folder after /tools off the end. Example if you dbl click the adb executable the path would be /Users/(your path)/tools/adb ; exit;. Be sure to not copy /adb ; exit;

    so once you have your path go ahead and use cd to set the directory and press enter.

    Next enter the following commands in Terminal and press Enter after each line:

    ./adb shell mount -o rw,remount /dev/block/mtdblock3 /system
    ./adb push recovery.img /sdcard
    ./adb push flash_image /system/bin
    ./adb shell chmod 755 /system/bin/flash_image
    ./adb shell flash_image recovery /sdcard/recovery.img

    You are done! with the hard part. Now power off your phone and then power back on by holding the Vol Up + Power button at the same time. If you did everything correctly you should see


    Now you can go ahead and just reboot your phone so you can install the new rooted ROM

    3. Go ahead and download the eris21official-root.zip from the original guide(link is still above:D).

    Place the file (still zipped) on the root of your sdcard. DO NOT extract!!! Leave zipped.

    Now go ahead and turn phone off and reboot into recovery using the method just explained above.

    Use the trackball and scroll down to select Wipe, then complete the following:
    data/factory reset
    dalvik-cache wipe

    You can now use the Vol down button to get back to the main menu pictured above. From there select Flash Zip from SDcard. You should see the eris21official-root.zip there. Select it and press trackball and let it do its thing. Once completed go ahead and reboot normally and you're done!

    I recommend if you're gonna change roms doing a nandroid backup first of this. That way if anything goes wrong later you'll have this basic ROM to fall back on. Like a new beginning.

    I do not in anyway take credit for any of this. All information was gathered using google and this forum, not to mention http://androidforums.com/all-things-root-eris/53963-guide-stock-1-5-latest-root-2-1-a.html

    1. Download the Forums for Android™ app!


  2. alexhendershott

    alexhendershott Well-Known Member

    You can also go directly to a path if you type cd and then drag whatever file/folder directly onto your terminal window. :)
  3. jxnrxy

    jxnrxy Well-Known Member
    Thread Starter

    good to know! thanks i will add that to the OP
  4. chris22

    chris22 Newbie

    Someone with the ability should really sticky this. I had to bug andrizoid for weeks because I am a mac guy, and the correct directions weren't up here. Thanks for posting them man, I should have done so after I got them all.
  5. char561

    char561 Well-Known Member

    the only thing you really change is you put a ./ in front of the computer commands. they should add that to the guide and that would eliminate the need for another stickyed post.
  6. dommecca

    dommecca Lurker

    I've been at this for a while. I am very good at following directions, and I'm really not sure what is going wrong here. I'm stuck all the way back on step two where I'm supposed to:

    "so type cd in terminal, then go to your /tools folder of your Android SDK and click and drag it into your terminal window!"

    I've tried it every way I can think of, and all I get on the terminal is "No such file of directory" every time I try. I can't figure out what I'm doing wrong. I dont have any experience with the terminal window, so maybe it is catching up with me.

    Is there a setting or something I have wrong? Somebody please help! Much appreciated.
  7. dommecca

    dommecca Lurker

    ALSO, I cannot figure out how to get the SDK working on my Mac, I've followed all the instructions on the Android site, and on this forum, and I can't figure out what I'm doing wrong there either. Thanks for your help in advance!
  8. jxnrxy

    jxnrxy Well-Known Member
    Thread Starter

    can you be more specific on where you're having trouble?
  9. erisuser1

    erisuser1 Android Expert

    I'll point out that there's a bit of Cargo Cult in this post - and in the Windows posts from which it derives. Not that it won't work, it looks like it will. But there's a vastly easier way, in which steps 1 & 2 can be nearly eliminated.

    Specifically, if you've installed the root-leak ROM (PB00IMG.ZIP, md5 63eacc5ede3b179f95dc22d8ef585f94) onto your phone, you didn't need the SDK to do that (just get it on to the SD card) - and you don't need SDK (or adb) to flash the recovery.img file to the recovery partition, either.

    Once the Root-PB00IMG.ZIP file has been installed, the S-OFF bootloader on the phone can be put into FASTBOOT-USB mode, and you just burn the recovery.img file to the recovery partition with a single command:

    ./fastboot flash recovery recovery.img

    That eliminates the need to screw around with Java, install the Android SDK, type multiple adb commands, et cetera - just go and get the Mac version of fastboot from HTC (about midway down the page - and note that there is nothing else on this page that applies to the Eris, just grab the fastboot for Mac).

    The same thing is true of the Windows install, too; folks went down the road they did with the SDK and adb because the GUI-driven way of installing the USB driver for the Eris involves using the SDK. But in the Mac OS/X case, no driver install, so... no need for an SDK install there, either.

    Explicitly, in steps:

    (0) Root the phone as suggested in your step 0 above (root PB00IMG.ZIP method).
    (1) Download the Mac version of the fastboot tool and install to the Mac
    (2) Remove the SD card, or get the PB00IMG.ZIP file off the root so it won't interfere with the Bootloader (HBOOT) starting up
    (3) Restart the phone in FASTBOOT-USB mode by:

    - Hold down Vol-down and End/Power simultaneously
    - Press Send key to Enter Fastboot Mode

    (4) You can plug and replug the USB cable at this point to see if the phone is aware of the computer (you will see only FASTBOOT without the cable, and "FASTBOOT USB" if the phone senses the computer

    (5) In Terminal (on the Mac), type the command "./fastboot devices". If you are not connected, you won't see any messages at all. If you are connected, you'll see a single line which gives your phone serial number (starts with "HT...") and the word "fastboot" in the second column. This output is what you want to see - it tells you you are connected.

    (6) Now (in the Mac Terminal window) flash the recovery image to the recovery partition using fastboot:

    ./fastboot flash recovery recovery.img

    (Obviously, the "recovery.img" file needs to be in the folder, or "current directory" that you are using in Terminal - either that or specify the complete file path if it is not in the Terminal's current directory)

    This is exactly the same thing you are accomplishing with all that SDK/adb stuff, but without the machinations.

    Now, continue the process with your step #3

    Note that I am not against people using ADB; in fact, it is very useful to have around to communicate with either the booted OS or the Amon_RA recovery console. OTOH, using a lot of individual steps to reach a given goal not only increases the amount of time for accomplishing the task, but also increases the risk that a mistake will be made.

    doogald likes this.
  10. erickswar

    erickswar Lurker

    i have tried this and this is what i get every time "-bash: cd/Users/erickkrigsvold/android-sdk/tools: No such file or directory" this is really driving me crazy can anyone here help???!!!
  11. erickswar

    erickswar Lurker

    i have tried this way and countless other ways to flash recovery image nothing has worked! this is the message I always get .

    "bash:cd/Users/erickkrigsvold/android-sdk/tools: No such file or directory"

    I have android sdk and eclipse with adt plugin in my home folder amons recovery image and flash_image in tools section in sdk and on the root of my sd card Please advise as to what it is that I may be doing wrong!
  12. BigBeefy

    BigBeefy Well-Known Member

    put a space between cd and /users

    cd /users/...../tools then press enter
  13. erickswar

    erickswar Lurker

    thanks big beefy! but it worked until i got to this message

    mtd: read error at 0x00000000 (Out of memory)

    what now?!
  14. BigBeefy

    BigBeefy Well-Known Member

    I had that too. I still went ahead and continued with step 3. it seemed to work. I am fully rooted and running Eris_Official 1.0 Alpha With Controllable Overclocking! [5/9/2010]
  15. erickswar

    erickswar Lurker

    but my stupid trackball wont scroll down...I have a new eris on the way hopefully it won't have the 2.1 update when it gets here!
  16. skiingian

    skiingian Lurker

    I think this is the closest I've come to rooting my Eris. I am trying to root from 2.1 OTA and when I try to flash I get: flash_image: permission denied

    This has to be a stupid mistake, but I can't work around it. Thanks for your help
  17. Flames92

    Flames92 Newbie

    Omg wow, Ignore this message lmao...I figured it all out. Thank you so much for this!!! I stayed up till 5 am last night =[ Couldn't figure out this part. Helped so much gah! Lol
  18. Kutanks

    Kutanks Member

    I am getting completely confused. I installed the root image pb00 etc, i can't figure out how to use terminal to instal the recovery image. i tried both the fastboot method and adb, neither is working. how do i use terminal to specify a certain directory. can someone whose rooted their eris please tell me, starting with a blank terminal window and my phone plugged in what specific commands to type. Ive been trying all day and im frustrated, at this point I would give up but my phone feels dog slow on stock 2.1. Thanks
  19. doogald

    doogald Extreme Android User

    Where did you download the fastboot-mac file to on your Mac? Assuming that you downloaded to your Downloads folder in your home directory, start Terminal, and type the following command:

    Code (Text):
    2. [b]cd ~/Downloads[/b]
    (That is letter c, letter d, space, tilde, slash, the word "Downloads", return key.)

    This will change the current directory for the Terminal to your downloads folder. To see if the fastboot-mac file is actually in that directory, you can type the following:

    Code (Text):
    2. [b]ls fastboot-mac.*[/b]
    (That is letter L, letter S, space, "fastboot-mac", period, asterisk, return.)

    It should list

    Code (Text):
    2. fastboot-mac
    3. (and maybe) fastboot-mac.zip
    If you see just the fastboot-mac.zip file, you need to open that file from the Finder to extract the actual fastboot-mac application that you will use in the steps to install the recovery image.

    If you downloaded the fastboot-mac.zip file to another location, just let me know where, and I will tell you what command to type into the terminal. Some people download to their Desktop; if that was the case, your command would be:

    Code (Text):
    2. [b]cd ~/Desktop[/b]
  20. Kutanks

    Kutanks Member

    yeah so that worked, i got it to find fastboot. now what do I do with it. I think I may have gotten slightly over my head here, but the root image ****ed up my mobile internet and now i have no contacts on my phone so i need to root/ reflash the ota
  21. Kutanks

    Kutanks Member

    its in my downlaods folder, but im only seeing fastboot-mac.zip when i do ls fastboot.mac.*
  22. Kutanks

    Kutanks Member

    Im getting a permission denied error when im trying to flash the recovery.img
  23. Kutanks

    Kutanks Member

    eh, i guess ill go over to my buddies house, hopefully i can sync my contacts on wifi. For some reason my wifi at home doesn't work with my phone, but works on my ipod touch, xbox, wii, and all my other computers
  24. doogald

    doogald Extreme Android User

    Oops, I forgot that it doesn't work that way. Instead,

    Code (Text):
    2. [b]ls fastboot-mac[/b]
    and it should say something like:

    Code (Text):
    2. [b][i]computername[/i]:Downloads [i]username[/i]$ ls fastboot-mac
    3. fastboot-mac[/b]
    You also want to make sure that you have downloaded Amon's Recovery Image and have that in your downloads folder as well. You can download the lastest recovery image from:

    HTC Droid Eris ROM Site

    (Scroll down and download the file "recovery-RA-eris-v1.6.2.img").

    Now, you can follow the instructions (I've slightly altered them.)

  25. Kutanks

    Kutanks Member

    Yay! it worked, what rom do you guys recommend? i was gonna try evil eris first but im open to suggestions

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date
Similar Threads - Root Mac OSX
  1. otropibemasenlared
  2. N4ty_Kitty
  3. Pr0ph3cy
  4. Betwixtandbetween
  5. LuckyBit33
  6. LuckyBit33
  7. kisame010588
  8. kisame010588
  9. CPF7429
  10. Cyqo_3

Share This Page