1. Are you ready for the Galaxy S20? Here is everything we know so far!

[How-To] root your Kyocera Milano

Discussion in 'Android Devices' started by chrisyroid, Nov 30, 2011.

  1. chrisyroid

    chrisyroid Newbie
    Thread Starter

    Chances are some of you readers will be computer illiterate or have very little experience using command line interfaces...no offence. If this is the case and you still want to continue I have included a one click root in the post. Just follow the instructions at "Start here if you are going the one click route"

    A few things you should be aware of before diving into this:

    1. This will void your warnity if you have any.

    2. Rooting isn't for everyone, if you don't know what rooting is or what your getting into please visit these links.

    Rooting - is it for me? Some Q&A | Android Central
    Editorial: Sometimes, root isn?t the answer | Android Central

    3. There aren't any roms/firmware/recovery modifications for this phone yet. I will remove this if any should come up.

    4. If somehow you manage to screw up your phone as a result of rooting I'm not responsible but there a quite a few people on this fourm and others like this one who will help you out.

    OK, on to the tutorial:

    First off you will need to:

    1. Download and install Sun JRE and JDK - Download here.

    2. Download and install the Android SDK - Download here. It should be installed into the root of your drive like "C" or "D" For the sake of this guide it will be: "C:\SDK"

    3. Configure Android SDK - Go ahead and run the SDK and tell it to download and install everything under the tools folder.

    4. Download install the ADB drivers - Download here.

    5. Download the attachment: "oblique.zip" Inside of it will be six files. Depending on where you put the SDK, the files should be extracted into the "platform-tools" directory in your SDK. "C:\SDK\android-sdk\platform-tools"

    Start here if you are going the one click route.

    Once you are done, with the above steps we can continue with the rooting process.

    If you are going with the one click method just download and extract "GenericZergRushRoot.zip" to a folder, open the .bat file after step 3, ignore step 4 and the commandline stuff.

    Step 1: Plug your phone into your PC with the USB cable.

    Step 2: Make sure the phone is on "USB charging only" The phone should ask you when the phone is plugged in.

    Step 3: Turn USB debugging. Go to Menu > Settings > Applications > Development > USB debugging and check it on.

    Step 4: Open up a terminal and navigate to your SDK directory.

    To do so type in the following:

    Code (Text):
    1. cd C:\SDK\android-sdk\platform-tools
    Now we push the exploit to the phone and set some permissions.

    Code (Text):
    1. adb push zergRush /data/local/
    2. adb shell chmod 777 /data/local/zergRush
    3. adb shell rm /data/local/tmp/*sh
    Then execute the exploit and wait for it to finish.

    Code (Text):
    1. adb shell /data/local/zergRush
    Now do a remount and set some more permissions.

    Code (Text):
    1. adb remount
    2. adb shell mount -o rw,remount rootfs /
    3. adb shell mount -o remount,suid /dev/block/mmcblk0p29 /system
    4. adb shell chmod 4755 /system/bin/sh
    Last but not least send some more stuff to your phone, set permissions then install some apps.

    Code (Text):
    1. adb push ./su /system/bin
    2. adb push ./busybox /system/bin
    3. adb shell chmod 4755 /system/bin
    4. adb shell chmod 4755 /system/bin/su
    5. adb push ./Superuser.apk /system/app
    6. adb install ./androidterm.apk
    7. adb install ./Root_Explorer_v2.17.2.apk
    Finaly restart your phone.

    Code (Text):
    1. adb reboot
    Don't close out the terminal yet! After it restarts, type in "adb shell" (without the quotes) and hit enter to see if you did it right. If the terminal comes up with a "#" insted of a "$" it worked.

    Awesome! You just rooted your phone! If this your first time, give yourself a pat on the back.

    Persional notes:

    This rooting tutorial is using the zergRush binary created by Revolutionary. I came across this method by accident while looking for a rooting method for my phone. The one I used was for the HTC Amaze 4G. So I guess you could say this works for that phone as well.

    If there is any way I could improve this tutorial please feel free to PM me.

    View attachment GenericZergRushRoot.zip
    View attachment oblique.zip

  2. vgamerv

    vgamerv Lurker

    what am i doing wrong? i get a device not found after i try to put the second box commands "exploit phone and set permissions" on the terminal
  3. chrisyroid

    chrisyroid Newbie
    Thread Starter

    Looks like the adb drivers didn't install properly. I have only got the adb drivers to install on my laptop and I didn't document what I did to install them. Fumble around with the drivers to see if you can get them to work. I have heard that installing the drivers from the SDK work too. You might want to try that. If you have any experience in removing drivers completely from your system I suggest you do that then install the ones from the SDK.
  4. fatalfury

    fatalfury Well-Known Member

    the drivers that are provided by kyocera dont work worth jack anyone have working drivers ???
  5. ehrichweiss

    ehrichweiss Lurker

    I tried to do this in Windows but had the same issues with the drivers; no matter which one I used, it wouldn't recognize them as being for the phone. I tried both XP and Win7 to no avail. I hooked it up to my Linux system and it worked like a charm. I *think* only the JRE and the Android SDK need to be downloaded/installed but I'm not sure of that since I already had the Java SDK installed as well.

    That said, what needs to be done to get a stock image? Wait on Clockworkmod?
  6. chrisyroid

    chrisyroid Newbie
    Thread Starter

    I was able to install the drivers without a problem....but on only machine. I was fiddling around with some other drivers before that, I think it was for the echo if I remember correctly. Might want to try playing around with those for shits and giggles. The Milano is a strange phone indeed.
    mrsbartlett likes this.
  7. ehrichweiss

    ehrichweiss Lurker

    Well, I accidentally bricked my first Milano about a week ago thanks to a firmware update that I mistakenly accepted. Today I got a replacement and figured I'd take the update and THEN root it. Well, now I get an error at the "adb remount" stage which seems to indicate that something needs to be changed in the exploit because I even tried the manual method for remounting and it still doesn't work. I think it has something to do with the default.prop file according to what I've read so far but I can't figure out how to edit it since I can't su.

    I'll patiently await any suggestions.

    (I tried to attach my logcat but it says the file size is too big)
  8. ehrichweiss

    ehrichweiss Lurker

    (dupe post)
  9. ehrichweiss

    ehrichweiss Lurker

    Anyone found a way to root the Milano after this OTA update? I'm stuck with a non-rootable phone which is driving me nuts. I don't even know where to start on rooting these things so I'm hoping someone has at least a pointer on what to look for.
  10. so anybody rooted this yet? if so how i cant figure it out
  11. I'm in the same boat. I get stuck after running Zerg Rush and getting the ""Hellions with BLUE flames !" error.
  12. hawkeyez731

    hawkeyez731 Lurker

    None of the current rooting methods work on a milano gb2.3.4... do not expect much help here.
  13. I have a Milano from Ting (Sprint), and have not found a root solution. I have tried Zergrush, Superoneclick, Unlock Root, and Gingerbreak but none of them work. On Ting's forum they explain that the Milano software was patched against Zergrush and other exploits around March 2012 https://help.ting.com/entries/21807722-rooting-the-kyocera-milano

    I have not found posts anywhere online of someone being able to root a Milano after March 2012. Without root this phone is pretty useless to me because it only has 150mb of internal memory and is so full of bloatware that it can only download about 3 apps then is full.

    I am willing to make a donation to someone who can help me get this rooted.
  14. wesman2232

    wesman2232 Lurker

    Any help on Rooting a Kyocera Milano C5120 Gingerbread 2.3.4? I got it from Krogers, and it uses the I-Wireless service, running Sprint ID and all. I want to root it so I can get rid of all the junk apps that are preinstalled on it, taking up all the space.

    I've tried ZergRush, and SuperOneClick now. Nothing is working. Some help would be appreciated.
  15. manuelrh15

    manuelrh15 Lurker

    how can i root kyocera milano, android 2.3.4
  16. dabar

    dabar Lurker

    has anyone considered downgrading to 2.3.3? I've been looking but haven't found anything or the firmware itself
  17. tcaF0xd

    tcaF0xd Newbie

    Great news! It is possible to root the Kyocera Milano with Android 2.3.4! zergRush doesn't work, but https://github.com/hiikezoe/break_setresuid does. You might need to add these:

    { "C5120", "GINGERBREAD", 0xc013358c },

    { "C5120", "GINGERBREAD", 0xc0810c30 },

    { "C5120", "GINGERBREAD", 0xc074aee4 },

    Here it is working (through SSHDroid):
    ~/data/berserker.android.apps.sshdroid/home $ ./break_setresuid
    # whoami
  18. Chas

    Chas Newbie

    Am i supposed to already know what do to with all those files? :p
  19. dabar

    dabar Lurker

    has any one successfully rooted this yet? I have, I'll go back and find how it worked, I just noticed this thread again when someone liked one of my comments
  20. Chas

    Chas Newbie

  21. crownkings317

    crownkings317 Lurker

    ok you have to install it manually doit from the adb driver menu when it says install automatically this manually then it will take yuu to the adb menu with yr phone moden click on adb it should have a plus sign click add click install wait until it says adb debugging has been installed then click on sdk android framework do the same to that easy take.........

Kyocera Milano Forum

The Kyocera Milano release date was September 2011. Features and Specs include a 3.0" inch screen, 3MP camera, 512GB RAM, MSM7627T processor, and 1490mAh battery.

September 2011
Release Date

Share This Page