1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to run Linux (Ubuntu/Debian) on Micromax A25.

Discussion in 'Android Devices' started by davidheis, Dec 22, 2012.

  1. davidheis

    davidheis Newbie
    Thread Starter

    Micromax A25 is a really small device and running a desktop/laptop OS on it will be, what can I say..horrifying? :D
    But I do it anyway, not for any productive purpose. I do it out of curiosity and it's amazing to see what this little Android can do.
    In my experience in trying to get Ubuntu to run on my A25 (I haven't tried Debian but I'm sure it will run better than Ubuntu does) I faced some hurdles and I intend to prevent the same from happening to you too.

    Things you will need:
    1. A rooted Micromax A25.
    2. The Complete Linux Installer app (get it from google play(
    3. Terminal Emulator
    4. A VNC client.

    You can download the Terminal Emulator and the VNC app from the Complete Linux Installer app itself. So get this app first.

    After you have downloaded Complete Linux Installer, open it. Go to Install guides>>Ubuntu 12 install guide>>Next>>Download ubuntu image. Download the Small Image!!!!! The core image will be useless unless you want to use only command lines. And the full image will not run properly, if at all.
    You might want to download the image via torrent (I use BitTorrent app). The image is about 396MB in size and 1.9 GB once extracted. So you will need at least a 4 GB card.
    Now make a folder named 'ubuntu' (without the quotes, of course) in the root of your sdcard. This means that you make the folder in your sdcard and not in a folder in your sdcard. Extract the contents of your downladed zip file (which contains the ubuntu image) into the 'ubuntu' folder. You will get two files - ubuntu.img and ubuntu.img.md5.

    After that is done, download the VNC app and the terminal emulator from the links given in the Linux installer. You won't really need to install busybox as the Linux Installer uses its own busybox binary, but install it anyway because you will need it to run other apps that require root access.

    Now that you have everything in place, open Linux Installer and select LAUNCH and select Ubuntu and press on the Launch button. This will start the terminal emulator , running a script. If you have placed the image and md5 files in the right place, the script will verify whether the image is damaged. After some time the whole process will stop with a message like 'cannot mount /dev/block/loop255 on /data/local/mnt'. That's because A25 does not support ext2 filesystem.
    Now type '/sbin/tune2fs -j /sdcard/ubuntu/ubuntu.img' in the terminal and press enter. This will change the image into ext3 format.
    If that does not work type 'su' and press enter before entering the above command.
    After that is done download the bootscript zip file that I have attached and extract it and place the bootscript.sh file that you get in /data/data/com.zpwebsites.linuxonandroid/.
    Overwrite/replace if prompted. Use ES File Explorer to copy the file and paste it in this directory. You will have to turn on root options in ES's menu.

    After you have placed the bootscript file in the given directory, Launch ubuntu again. If you did everything right, you should see a whole load of lines in the terminal that you did not see in the first attempt. Enter your new password for ubuntu and your preferred screen resolution. You could enter 320x240 but things wont appear nice. I use 1024x768 instead. I prefer to pan around than have everything looking like sh*t.

    After some time you will see a line 'root@localhost'. If you see that, Ubuntu is already running on your phone! But you dont't see it! For that, open the VNC app that you downloaded before and enter 'ubuntu' as password and 'localhost' as IP ADDRESS. The port is 5900. Now press CONNECT and voila! You will see the Full Ubuntu LXDE desktop on your phone! I installed GIMP photo editor on my ubuntu and it works! Have fun playing around with your new OS on A25!
    You could also try with Debian, either small or large. I'm sure it will work.
    Click on the thanks button if I helped you. I have never received a thanks. :) A first time will never hurt. ;)

    Visit LinuxonAndroid for more information on the Linux On Android project which is how we are running Ubuntu on our A25!

    Attached Files:

    kp27, adityaluv and deepesh1193 like this.

    1. Download the Forums for Android™ app!


  2. vaibhavcoolm

    vaibhavcoolm Well-Known Member

    mounting /dev/block/loop255 on /data/local/mnt failed : No Such Device
    Plz help.....
  3. davidheis

    davidheis Newbie
    Thread Starter

    did you do tune2fs? and did you place booyscript.sh file in the right place?
  4. electrokid17

    electrokid17 Newbie

    @davidheis man can u help me wid dis well m stuck i got the ubuntu 12.04v4
    and vnc, termina,complete linux installer bt no commands running it jus blank.....can uu plz help me wid dis i really wanna use ubuntu on ma fone as i ve neva used it before...plz.....thanx in advance plz explain abt which version as to works o wat is wrong.....
    thanx again
  5. we have to place bootscript.sh in /data/data/com.zpwebsites.linuxonandroid/file nd replace it have to use es file explorer nd grant root permison i m having ubuntu on my mma25 :D
  6. electrokid17

    electrokid17 Newbie

    cool bro but won't root explorer work???
    coz i used dat bt didn't work anyways thanks ill try wid es file explorer
  7. electrokid17

    electrokid17 Newbie

    sorry i mean root browser file manager
  8. electrokid17

    electrokid17 Newbie

    "chroot:can't excute '/root/init.sh:no such file or directory" have encountered dis can ny one plz give me brief tutorial on dis o can any one tell me wat on earth do i do??????
  9. electrokid17

    electrokid17 Newbie

    "$ # Loop device existsmount: mounting /dev/block/loop255 on /data/local/mnt failed: No such device
    mount: mounting devpts on /data/local/mnt/dev/pts failed: No such file or directory
    mount: mounting proc on /data/local/mnt/proc failed: No such file or directory
    mount: mounting sysfs on /data/local/mnt/sys failed: No such file or directory
    mount: mounting /sdcard on /data/local/mnt/sdcard failed: No such file or directory
    mount: mounting /sdcard/external_sd on /data/local/mnt/external_sd failed: No such file or directory
    net.ipv4.ip_forward = 1
    ubuntu.sh: cannot create /data/local/mnt/etc/resolv.conf: directory nonexistent
    ubuntu.sh: cannot create /data/local/mnt/etc/resolv.conf: directory nonexistent
    ubuntu.sh: cannot create /data/local/mnt/etc/hosts: directory nonexistent
    Ubuntu is configured with SSH and VNC servers that can be accessed from the IP:
    eth0: No such device

    chroot: can't execute '/root/init.sh': No such file or directory
    Shutting down Ubuntu ARM"
    dis how i get when i try to start it up....
  10. davidheis

    davidheis Newbie
    Thread Starter

    Hello! Sorry, I had abandoned this thread but now I'm back. I'd still be happy to help. Post a reply and we'll get your problem solved, if you are still into it, that is. I'll be checking back on this thread now and then.
  11. electrokid17

    electrokid17 Newbie

    i am still amused by the idea ..but i can't get it to work...
  12. skkishore44

    skkishore44 Lurker

    bro could u upload screen shots..?
  13. amitdx94

    amitdx94 Lurker

    downloaded linux launcher from http://www.twxdroid.com but it doesn't work........would any of you know another way to install it
  14. amitdx94

    amitdx94 Lurker

    seems like work........but wants some proof...

Micromax A25 Forum

The Micromax A25 release date was October 2012. Features and Specs include a 2.8" inch screen, 1.3MP camera, 256GB RAM, MT6515 processor, and 1280mAh battery.

October 2012
Release Date

Share This Page