1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to SAFELY move all photos and videos to SD card

Discussion in 'Android Help' started by tgm1024, Jan 30, 2016.

  1. tgm1024

    tgm1024 Well-Known Member
    Thread Starter

    Samsung Galaxy Note II
    Verizon version. *Not* rooted.
    Android 4.4.2
    16GB internal
    64GB external, class 10, Sandisk


    Ok, this might not be as simple as it sounds, or it might be in the stupid category.


    I'll list the issues, to hopefully make this less wordy:

    1. Internal storage maxed out.
    2. Photos saving automatically to ext SD card.
    3. Phone warns that videos will not save to ext SD card. (HUH?)
    4. As a former unix engineer, I'm familiar with moving things around a filesystem, but I'm a little gunshy because when I followed the instructions before to do this, I ended up with my gallery acting flakey).


    Questions:
    1. If I go in and copy the contents of the photo/video folder to the SD card, is it like a camera where there are external files containing extra meta data that should go with the file? Or is the photo & vid file itself enough?

    2. Is deleting the contents of the internal folder safe? Previously one of my attempts was to copy the contents of the internal storage to Win7 via USB, and then hand delete the internal photos/videos via that windows connection, and this seemed to crock my Gallery app.


    3. Do I need an app to manage this?

    4. Can I set up a symbolic link (at the linux level) to the SD card so that the videos are automatically stored there?
     


  2. chanchan05

    chanchan05 The Doctor

    I dunno. I have a Note as well. I just open My Files and move the picture files via that app. Have you tried that?
     
  3. tgm1024

    tgm1024 Well-Known Member
    Thread Starter

    After how flaky Gallery got the last time I touched the files, I was afraid that there was something more to it.

    Why isn't there a bulk "move to SD" option built into Gallery? I don't understand this. Nor can I understand why video can't be saved directly to SD by default. Is that a read/write speed issue?
     
  4. chanchan05

    chanchan05 The Doctor

    I can save video directly to SD so no idea for that. As for moving files to SD via gallery, there has to be a folder in SD card for the gallery app to move to initially. I think it has to do with Android changing how things were handled with SD cards with 4.4
     
  5. tgm1024

    tgm1024 Well-Known Member
    Thread Starter

    Yep. I've found out what's wrong. Good grief.

    But I do understand the problem. Google is trying to properly use unix permissions (on an EXT filesystem) so that security remains high. A huge problem if you just plop in an SD card from a vendor (or format it yourself from a PC with one of the FAT variants), because it immediately crocks whatever apps you've previously moved to the SD card.

    Basically (as cygwin encountered years ago), there simply isn't any way to set ownership (and RWXRWXRWX permissions which are now required for security) on the files in a FAT system, and this means that anything you've previously moved there is hosed.

    Apparently though, 4.4.2 will allow you to move the app to the SD card and (maybe?) maintain its own permission structure through other means.

    Holy crap. But I totally understand.

    BTW, *always* access the phones via cable for now. It uses a different mechanism entirely.

    And now (and I can't believe I'm saying this) I am now in favor of android phones non-removable external storage.

    http://www.androidcentral.com/kitkat-sdcard-changes#content

    PROBLEM NOW: do I move back the apps from my FAT sdcard (and reinstall the broken ones), and format my SD cart to EXT and hope for the best?
     
  6. chanchan05

    chanchan05 The Doctor

    Not really sure. I've never encountered a problem like yours, but then I use the phone to format the SD card and not a PC before use. You could try moving the apps back and hope for the best, while backing up the rest of the data on a PC to return to the phone once card formatting is done.
     
  7. mikedt

    mikedt 你好

  8. tgm1024

    tgm1024 Well-Known Member
    Thread Starter

    I only buy batteries from BestBuy(non-marketplace) and memory cards from NewEgg(non-marketplace) or BestBuy(non-marketplace), which I'm hoping have a better chance of not being black market.

    Well, I've reset the phone and everything vanished as an issue (with a new SD card).

    Here's how I believe everything is tied together. Jump to "Summing Up" if you're prone to tl;dr, and/or are not an engineer.

    1. Since KitKat, there was a distinct issue is disallowing applications from writing outside their own established folders on a 2ndary card. Lots of reasons for this, many of them are software engineering specific that I just don't want to get into now, and it's filled with exceptions and nuances. Note, as of Lollipop (which Samsung has announced a cancel on for Lollipop :( ), much of this has cleared up.

    2. This has everything to do with updating from prior 4.4 to 4.4 and trying to keep the data that was written on the 2ndary card by unsupported pre 4.4 APIs and without the proper linux-level permissions and ownerships in place.

    3. This means that phones exhibiting this problem will errantly tell you that they're writing to the card, but won't be. Your primary storage will therefor fill up. But that's not all:

    4. People have noticed a dramatic drop in battery life. And other flaky things happening. For instance, I had break-ups in my BT connections, when I could access the card from the phone, a format wouldn't work, and I discovered that this was coincident with that the card kept cycling between mounting and unmounting and mounting and unmounting, etc..... However, which happened first, KitKat or dead card? I'll tell you why I believe it was KitKat first:

    5. Looking online, you see that many people have reported "KitKat destroyed my SD card". To the point where it could not be recognized in any other computer SD slot (SDHC/XC/whatever). This might happen with something at the driver level used to write something to a particular place within the card that maxed out its writing count (all flash can only be written to, but they try to load-balance elsewhere). Having written unix device drivers myself, I am still not sure why this would be the case (a mount should sit *above* the driver, and the driver should leave the card to determine how to ignore locations), but I can't see any reason why there would be so many complaints claiming "KitKat" == "Killed Card".

    Summing up: I believe the causality chain went like this:

    1. Phone worked great with pre-KitKat.
    2. Upgraded to KitKat
    3. (for reasons I now agree with): KitKat requires a different permission model for the 2ndary storage.
    4. This frigged up both KitKat's ability to regain information that was written using non-standard pre-kitkat API's. This also at some level (don't know yet) mucked up the card's ability to mount cleanly.
    5. Primary storage fills up AND phone enters mount/unmount rapid repeating cycle.
    6. This causes multiple odd behaviors, because low-level driver issues cause hiccups (such as my BT flaking out).
    7. I was able to limp along briefly in between mount/unmount to attempt formats to no avail.
    7. The rapid low-level write from the mounting/unmounting tanks the the card permanently.

    Solution:

    1. If you can somhow get some information off the card elsewhere (some can *somewhat*), do so to a PC. I could not. (Again, IMO this happened because of KitKat....see #4 and #5 in the first list above).
    2. replace card---I use a 64GB.
    3. Reset the phone completely. (You can decide to what degree).

    I also reformed the card from within the phone to be "safe", but be careful here that no app of yours has automatically moved a ton of storage to the card first.

    Rules (unless you're a software engineer):

    1. Never take card out and write to it from a PC directly.
    2. NOTE: PURE SPECULATION ON MY PART---> I wonder if actually putting it in a PC and even ONLY READING from it *might* be setting an access date someplace within the card that KitKat will not like. I have no idea if this is true, but I'm asking folks to be cautious. I am.
    3. Use the usb cable write to and read from the phone to have KitKat manage the I/O to the areas within the phone. This at least will allow KitKat to maintain it's own permission structure.
     
    #8 tgm1024, Feb 9, 2016
    Last edited: Feb 9, 2016
  9. tube517

    tube517 Android Expert

    Note 2 and SanDisk cards dont play well even legit ones. I went thru this and just got a Samsung sd card. And yes this was on kitkat. I have had no issues since.
     
Loading...

Share This Page

Loading...