1. Check out our companion app, Forums for Android! Download from Google Play

Root [How TO] Simple Root and Custom Recovery Installation and Install ROM - WINDOWS

Discussion in 'Android Devices' started by Mastermind278, Apr 24, 2011.

  1. Mastermind278

    Mastermind278 Well-Known Member
    Thread Starter

    I keep getting a lot of requests on how to explain and simplify the root and custom recovery installation on the Motorola CliqXT. So for those people who are on WINDOWS and want a simple method here is the simplified way.

    I have used the files provided by ModMyMobile and made a few scripts that allow for Root to be installed.

    Follow the YouTube Video as well as the instructions below:

    YouTube - Simple and Easy Root and Custom Recovery Installation on the Motorola CliqXT

    1. Download "Connectbot" from the Android Market: https://market.android.com/details?id=org.connectbot

    2. Enable USB Debugging on the Motorla CliqXT. This can be done by going to MENU--SETTINGS--APPLICATIONS--DEVELOPMENT--USB DEBUGGING. Make sure that it gets a green arrow.

    3. Download Motorola ADB Drivers. Choose the version of the Windows you are running:
    MOTODEV > Documentation & Tools > USB Drivers

    4. Install the Motorola ADB Drivers.

    5. **At this point you might want to disable AntiVirus as some will find rageagainstthecage-arm5.bin to be an Android Virus. Being that it is an exploit for Android it is understandable to be mistaken as that, but this the method required for root**
    Download my ROOT files:
    Extract ROOT files onto your Desktop.

    6. Plugin the Motorola CliqXT onto your Computer. Wait for all the drivers to install. You should see a message saying that the ADB interface drivers were installed. If not just wait a few minutes and everything should get installed.

    7. Open the ROOT folder you extracted on your Desktop.

    8. Double click on #1-Run this to start ROOT.
    This will upload the files needed onto the phone. It might take a few minutes, on the video it was quick as I already had these files in the SDCard of my phone. Once it gets to the point that it says Adb Shell and has a $ with a blinking underscore (_) then we are ready to go to the phone.

    9. Open up ConnectBot on the phone that you previously downloaded.

    10. Click on where it says SSH and change it to Local. Type any name and press enter. Once you get the black screen with the $ you can type the following lines:
    11. It will show a message, just wait till it shows
    FORKED **** Childs.
    **** is a number. Once that happens you can close down Connectbot.

    12. Re-Open ConnectBot. If successful you should see a # meaning you have temporary root already.

    13. Now type the following commands:
    14. Nothing should happen, except getting another # sign, meaning that the script has finished.

    15. Now go back to your computer and close down the command prompt window.

    16. Click on the file called: #2-Run this to start RECOVERY

    17. Wait a few seconds and then you will get the $ _
    Type the following command:
    18. On the phone there should be a prompt that says SU user request. Click ALLOW.

    19. On the computer now it should give you a #.

    20. Type the following commands:
    ***You might get an error when doing the rm /system/recovery.img (something like "No such file or directory") that is OKAY, this is just to verify that the recovery doesn't get overwritten by stock one***

    21. Enjoy you have just rooted and installed a custom recovery on your CliqXT.


    YouTube - Installing a ROM on the Motorola CliqXT (Cyanogen Mod 7 (CM7) - Android 2.3 - Gingerbread)

    On this video I forgot to mention that you should BACKUP your stock ROM.
    Before doing the WIPE, you should choose BACKUP and Restore, then choose Backup Nand. Let it run.
    After that you can follow the video and do the WIPE!


    Jakaro and burn-n-daylight like this.
  2. cisquo1

    cisquo1 New Member

    Apr 7, 2010
    Everything runs exactly as instructed until I get here:
    20. Type the following commands:
    flash_image recovery /sdcard/recovery.img
    mount -o rw,remount /dev/block/mtdblock1 /system
    rm /system/recovery.img

    The first command "flash_image re..." returns several "...bad sector..." then "not enough space on the device" or something to that effect. I retried the whole process up to that point and every time it gave me the same error. The last time I went ahead and entered the last two commands. When the phone reboots the superuser app appears but when I go ahead and try to load your ROM I get a blue screen after pressing the volume down button that says "security on; fastbood failed" I can't get to the point where I backup the stock rom.

    Now I'm stuck. Any advice?
  3. max@dcmafia.co

    max@dcmafia.co New Member

    Jul 11, 2011
    The adb push commands to copy Superuser.apk and su are failing due to a permissions error. Any ideas on how to fix that?

    G:\Downloads\20110710-CliqXT\Root>"#1-Run this to start ROOT.bat"

    G:\Downloads\20110710-CliqXT\Root>adb push Superuser.apk /sdcard/Superuser.apk
    failed to copy 'Superuser.apk' to '/sdcard/Superuser.apk': Permission denied

    G:\Downloads\20110710-CliqXT\Root>adb push su /sdcard/su
    failed to copy 'su' to '/sdcard/su': Permission denied

    G:\Downloads\20110710-CliqXT\Root>adb push rageagainstthecagearm5.bin /data/local/tmp/rageagainstthecage-arm5.bin
    526 KB/s (5392 bytes in 0.010s)

    G:\Downloads\20110710-CliqXT\Root>adb push install-root.sh /data/local/tmp/install-root.sh
    35 KB/s (325 bytes in 0.009s)

    G:\Downloads\20110710-CliqXT\Root>adb shell chmod 0755 /data/local/tmp/rageagainstthecage-arm5.bin

    G:\Downloads\20110710-CliqXT\Root>adb shell chmod 0755 /data/local/tmp/install-root.sh

    G:\Downloads\20110710-CliqXT\Root>adb shell
  4. michhiker

    michhiker New Member

    Aug 1, 2011
    Everything has worked great except, google apps and I can not log into my google account.
    Any suggestions
  5. forkuapple

    forkuapple New Member

    Aug 21, 2011
    I am getting a fail at step 13


    /sdcard/su: no such file or directory
    /sdcard/superuser.apk: No such file or directory:mad:
  6. keatonisballin


    Oct 19, 2011
    I cant get past the step where i have to unzip the ROOT files. My Winzip wont unzip the rageagainstthecage-arm5.bin file. Thus i cant go any further.
  7. tigerike

    tigerike New Member

    Jun 4, 2014
    Thanks a bunch, this worked well from linux.

    chrome wouldnt let me download the boot.zip file so I worked around it by using wget from the terminal.
    I also renamed a few files to make typing in connectbot a bit easier:

    me@enterprise:/stuff/tv/rom/pops/Root$ cat root.sh
    adb push Superuser.apk /sdcard/Superuser.apk
    adb push su /sdcard/su
    adb push rageagainstthecage-arm5.bin /data/local/tmp/rage.bin
    adb push install-root.sh /data/local/tmp/ir.sh

    adb shell chmod 0755 /data/local/tmp/rage.bin
    adb shell chmod 0755 /data/local/tmp/ir.sh
    adb shell

    Also, since I ran this from linux I ran all of the adb commands as root because my user isnt in the proper group to open the outgoing socket.

Share This Page