1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to STOP galaxy from automatically turning on and connecting to WiFi?

Discussion in 'Android Devices' started by CellularGuy, Feb 12, 2013.

  1. Scotken

    Scotken Lurker

    Om my S2 using version 4.0.3 I don't have a 'Connection Optimizer' option when I go into 'Mobile Networks'. Why is this or am I doing something wrong?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. KitsapAndroid

    KitsapAndroid Android Enthusiast

    It's because the Connections Optimizer was introduced with JB (v. 4.1.2). If you ever choose to upgrade to JB, then you will have the Connections Optimizer option.
     
  3. btv333

    btv333 Lurker

    I'm also with S3 and battery Guru. Dont have the Connections Optimizer option in menu. In BG I've uncheck in status the WiFi . Now it's good.
     
  4. AliGisin

    AliGisin Lurker

    Thank you very much :)
     
  5. themorn2112

    themorn2112 Lurker

    I have a note 3 with the most up to date version of Kitkat on T-Mobile (4.4.2). I am experiencing the same problems with my wifi Randomly turning on. I haven't found the connection optimizer feature on my phone. Any help would be deeply appreciated.
     
  6. By_design

    By_design Newbie

    In reply to OP, As a rule I only turn my WiFi on when I am activelyusing it. When I am finished I turn it off. It only takes a second to turn it off and on. I always actively manage my Wifi, but one thing that would be helpful to have is a blocking function to prevent the same signals popping back up on the list everytime you come in close proximity.
     
  7. nab622

    nab622 Lurker

    I have your answer, if you haven't found it already. It was quite evasive but some other people's hints narrowed it down and I finally found it.

    Instead of putting the Wifi manager in the phone's settings menu, T-Mobile hid it in the My Account app, which incidentally with the last update also started hitting me with ads. Very strange, although the ads can also be disabled in the settings.

    In my case, the Wifi would turn on because of lost cell tower signal, and the phone would glitch and be unable to connect to a tower without a full system restart. So the pictures below show how to turn this abysmally implemented feature off, with the originals attached just in case.

    [​IMG]

    [​IMG]

    [​IMG]
     

    Attached Files:

  8. sruji

    sruji Lurker

    Hey guys!
    i am using android 4.2.2 mbl
    im getting frustrated all d day wid my wifi auto connection
    even though i keep my wifi off, it connects automatically along with data connection and reducing my battery power as well as amount from dat sim.... every morning...
    when ph is idle for few minutes it is connecting automatically wifi on nd also data connection of my first sim......

    please help me :banghead:
     
  9. breenicole96

    breenicole96 Lurker

    Hi I have straight talk and its a Galaxy SIII and I can not get the wifi to stop turning on automatically after I turn it off? HELP????
     
  10. roughneckgrl

    roughneckgrl Lurker

    I'm having the same problem so if can help it would be nice
     
  11. jwacg

    jwacg Lurker

    I also have a galaxy s3 with straight talk that is having the WiFi turn on every couple minutes. I even factory reset the phone and it still does it. Any ideas?
     
  12. Mad Matt

    Mad Matt Lurker

    The problem appears to be buried in the My Account app. Once uninstalled, my Wi-Fi stayed off when I shut it off.
     
  13. Snapper238

    Snapper238 Lurker

    My husband has been trying to find the Connection Optimizer on his Galaxy 2, for days, so he can disable the Wifi continuously connecting. We can't find it in the suggested location. Any assistance would be greatly appreciated. phone.jpg
     
  14. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    You're not going to find it - it's a setting unique to US phones on the Sprint carrier.

    Something else is forcing your wifi back on - for example, the phone locator in Lookout Security will do it.
     
  15. Lizardo

    Lizardo Lurker

    Change the new sim card and solved problem
     
  16. rjsdavis

    rjsdavis Lurker

    Thanks for this helpful reply.

    I've got this same problem on my daughter's GS2. It doesn't, as far as I am aware, switch the WIFI functionality on if it's off, however, what it is doing, is connecting to every single WIFI network that it comes into contact with.

    I've just been through it and "forgotten" all of these extra WIFI networks, and we'll see if it continues to re-add them tomorrow, but as you've pointed out above, we also don't have the Connection Optimiser software in the MORE SETTINGS sub-menus. This is a British phone on the EE network.

    Wondered if any Brit users knew how to stop the phone from continually connecting to every WIFI network it finds?

    Many thanks
     
  17. MSSHANELL

    MSSHANELL Lurker

    I have AT&T the Samsung Galaxy S6 Edge+ & I've had the same problem where my wifi would connect on its own. All I did was to go wifi (while it's connected) & in the right hand corner it has 2 options wifi direct & more. Click on advance & then click on more then go down until you see auto connect. Then you obviously unchecked that & bam there you have it problem solved! ☺
     

    Attached Files:

    AZgl1500 likes this.
  18. AZgl1500

    AZgl1500 Extreme Android User

    I agree with this. The ONLY WiFi link that I have AutoConnect is my home router... All of the others just show up and are on the "WiFi Available" list.... if I choose to connect, I select one..... I use WiFi360 as my primary list finder.
    * WiFi Overview 360 Pro - Android Apps on Google Play
     
  19. Gay Lietzke

    Gay Lietzke Lurker

    I have a Sprint Note 4. Even with turning off the optimizers connectivity and the advanced setting all are off such as allow auto scanning my phone, night WiFi, etcetera it continuously scans and connects to WiFi.
    From what I read its a lollipop issue.
    Also if you read each app permissions some will have change network connectivity and or connect and disconnect from WiFi.
    On my phone these apps have those permissions= Sprint smart search, messenger, messenger plus, voicemail and Facebook. Their are probably more if look at each one.
    Also sync in app permissions can be a issue with connectivity, turning on WiFi
    I read one person had google fit syncing even though he never used it.
    One person posted on another site loaded macrodriod to run a macro that stopped the WiFi every time it launched.
    I believe the connectivity toggled off renders little help due to popular app permissions.
    If anyone else found a app that controls the auto connect to WiFi and it works please list
     
  20. Baysider

    Baysider Lurker

    My Samsung phone was turning on and connecting wifi by itself. I discovered that Avast Mobile Security / Anti-Theft was responsible. The software defaults to turning on wifi for tracking if the phone believes it is lost or stolen. I had removed the SIM card while the phone was in for screen replacement. This instigated the lost/stolen response, and it was turning on wifi because this had not been reset. To reset it i simply had to log in to the AntiTheft feature in Avast with my password. Once the phone knew it was me wifi no longer turned on by itself !!
     
  21. robiulislam

    robiulislam Lurker

    there is no any option like "connection optimizer" in my samsung galaxy j5(2016).what can i do??? :-(
     
    Michael Maye likes this.
  22. Michael Maye

    Michael Maye Lurker

    Yeah, I have searched every single setting in this galaxy grand prime, and I do not have the connections optimizer, ANYWHERE.....Help....? :(
     
  23. I've been wrestling
    S6 solution: settings/ applications/ application manager /connections optimizer/force stop
     
  24. etechmaster

    etechmaster Lurker


    Hello alb, Thank you for the advice. I really haven't given it a try but it makes total sense. I'm going to give you the credit since I saw your post first. I will reply back later with my long term results.
     

Samsung Epic 4G Touch Forum

The Samsung Epic 4G Touch release date was September 2011. Features and Specs include a 4.52" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1800mAh battery.

September 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...