1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to test if your phone has Root using Terminal and other Rooting question

Discussion in 'Android Devices' started by No_Nickname90, Feb 8, 2011.

  1. No_Nickname90

    No_Nickname90 Well-Known Member
    Thread Starter

    Ok. I want to know how can you test that your phone is rooted. When I'm doing the XDA method of rooting my G2, I push all the needed files to my phone, and do the thing where Terminal Force closes and you open again after you had ran rage. Now I have the root shell in Terminal.

    When I run command:

    $ su
    not found

    ($) is my command line, and (blanks) is what came back. ^^
    Is it suppose to say "not found"? or is it suppose to say something else? I did exactly what I was suppose to do. It wasn't all that hard. Before I did the rage command, it was

    $ su
    Permission Denied

    That seems normal. But after I supposedly temporarily root my phone, if I open ROM manager, it tells me that I need to root my phone. What tha truck? Am I missing something?

    I run:

    $ /data/local/gfree -f

    {export PATH=/data/local/bin:$PATH
    # # /data/local/gfree -f
    --secu_flag off set
    --cid set. CID will be changed to: 11111111
    --sim_unlock. SIMLOCK will be removed
    Section header entry size: 40
    Number of section headers: 44
    Total section header table size: 1760
    Section header file offset: 0x00015398 (86936)
    Section index for section name string table: 41
    String table offset: 0x000151df (86495)
    Searching for .modinfo section...
    - Section[16]: .modinfo
    -- offset: 0x000011cc (4556)
    -- size: 0x000000c4 (196)
    Kernel release: 2.6.32.17-g9ab3677
    New .modinfo section size: 204
    Attempting to power cycle eMMC... OK.
    Write protect was successfully disabled.
    Searching for mmc_blk_issue_rq symbol...
    - Address: c029c72c, type: t, name: mmc_blk_issue_rq, module: N/A
    Kernel map base: 0xc029c000
    Kernel memory mapped to 0x40002000
    Searching for brq filter...
    - Address: 0xc029c72c + 0x34c
    - 0x2a000012 -> 0xea000012
    Backing up current partition 7 and patching it...
    patching secu_flag: 0
    Done.}

    I run command:

    $sync

    # {sync}

    I run command:

    $ /data/local/tmp/root

    # {/data/local/tmp/root
    mkdir failed for /system/xbin, File exists
    cp: can't stat '/system/xbin/busybox': Not a directory
    Unable to chmod /system/xbin/busybox: Not a directory
    /data/local/tmp/root: /system/xbin/busybox: not found
    cp: not found
    cp: not found
    Unable to chmod /system/bin/su: No such file or directory
    #}

    (mkdir failed for /system/xbin, File exists) This is where I think I'm messing up. The directions say it should state:

    ( mkdir: /system/xbin already exists)

    See the difference? The directions doesn't say "Failed" while mines does.

    Thanks for any help. And sorry. I completely changed the question.
     



    1. Download the Forums for Android™ app!


      Download

       

T-Mobile G2 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...