1. Are you ready for the Galaxy S20? Here is everything we know so far!

How To Turn Off This Spelling Suggestion Thing? (It's NOT Auto Correct Or Predictive)

Discussion in 'Android Devices' started by joshhumble, Oct 4, 2019.

  1. joshhumble

    joshhumble Member
    Thread Starter

    When I use google voice to text, the words underline themselves, and if I touch near them, a drop down list of other possible words shows up.

    I want to turn this OFF. I have searched multiple tutorials, none worked or were related.

    Already had predictive text turned off, spell check. None of the settings seem to have this thing.

    [​IMG]
    [​IMG] [​IMG]d[​IMG]
     

    Advertisement

  2. JAy3001

    JAy3001 Android Expert

    The function your looking for is Auto Replace. Start writing some text and you will see recommended words above your keyboard, if you make a mistake or the keyboard believes there is better word to use it will highlight that word.

    Touch the options button beside the recommended words (3 dots) and turn off Auto replace. Now delete all the text you wrote and re-type it and you will notice the keyboard will not highlighted text anymore.
     

    Attached Files:

    #2 JAy3001, Oct 5, 2019
    Last edited: Oct 5, 2019
    Dannydet and ocnbrze like this.
  3. joshhumble

    joshhumble Member
    Thread Starter

    Hi,

    I don't believe that is the same feature. I believe I turned that off in the past.

    See in the first screenshot I pasted up top, there are no words above the keyboard, it's a different thing. I also tried hitting the 3 dots that was there, it just goes to this:
    [​IMG]
     
  4. JAy3001

    JAy3001 Android Expert

    Ok, so to confirm you are using the Samsung keyboard?

    I didn't notice to said you did this via voice. However I went in and had a look and as you speak the text is underlined, but as soon as you stop talking or press the full stop the underlined text disappears.

    Regarding the option button, you must start typing before pressing the options button and have the cursor near the text for it to present you with the Auto Replace options, otherwise you will be presented with a basic options screen.

    Edit: Because you have predictive text turned off you will not see the mentioned options screen. Turn predictive back on and then you will be able to switch Auto Replace off too.
     
    ocnbrze likes this.
  5. joshhumble

    joshhumble Member
    Thread Starter

    I believe it is Samsung Keyboard, but when I do the speech to text, is that still samsung keyboard? I dont know.

    But the text underline does Not go away when I stop talking. And there is no options button as you mentioned.

    Perhaps it's just for Google related apps it does this. I made a video to show: https://www.youtube.com/watch?v=XpLAXcF2wN8
     
    #5 joshhumble, Oct 5, 2019
    Last edited: Oct 5, 2019
  6. JAy3001

    JAy3001 Android Expert

    Ok, so I've managed to replicate your issue. It certainly lies with the Google speech to text app and I can find no way of disabling the feature.

    Because my phone was setup to use Samsung voice input I don't seem to have this issue. You could give the Samsung voice to text app ago as a temporary fix?

    Touch the cog button on your keyboard, and at the top of the screen press back on the title Samsung Keyboard and it will take you to your On-screen Keyboard settings. Next select Manage Keyboards and deselect Google Voice Typing and select Samung Voice Typing. Now hit back on your phones nav buttons a few times to return to whatever your typing.

    Another way of doing to above is to go into your phone settings and searching for Language and Input, you'll find the settings you need under the heading Keyboards - On screen keyboards.

    Give it a go and see if your happy with the results @joshhumble
     

    Attached Files:

  7. joshhumble

    joshhumble Member
    Thread Starter

    Okay, so can't be turned off.

    I tried swapping to Samsung Voice Input, it's not there like in your screenshot. I restarted the phone too after disabling the Google Voice, there's still not Samsung Voice input. Lol, sorry, the problems just don't seem to end. Oh well. Probably not worth all this trouble


    [​IMG]
     

    Attached Files:

  8. JAy3001

    JAy3001 Android Expert

    Odd, must be your variant of S8 as what I have read it would appear that the S8 does have the Samsung Voice input app.

    I've had another dig around and cannot find the app on either the Samsung store or the play store, so it must be a system app that only currently gets updated with OTA updates.

    You could however try a mirror site to grab the app and see if it works with your S8. Upto you:

    https://www.apkmirror.com/apk/samsu...input/samsung-voice-input-2-1-01-212-release/
     
Loading...

Share This Page

Loading...