1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to unlock bootloader

Discussion in 'Android Devices' started by 1337xhoax, Jun 8, 2020.

  1. 1337xhoax

    1337xhoax Newbie
    Thread Starter

    I have infinix hot 4 lite X557 Android 6. (NO root) and LOCKED bootloader
    So i decided that it was time to unlock my bootloader and i tried to use the official method (using adb and fastboot)
    So i just connected my phone to my Windows PC and run adb devices command my phone was recognised i typed
    adb reboot bootloader
    It rebooted to fastboot mood
    I ran fastboot devices and my phone was recognised now i typed
    fastboot oem unlock
    And i got an error saying
    remote : 'unknown command '
    I also tried
    fastboot flashing unlock
    It returns
    remote: 'unknown command'
    So just type
    fastboot reboot
    And my phone got back to normal
    My question is why is *fastboot oem unlock* not working
    I see in videos people flashing TWRP on infinix hot 4 lite X557
    So that means this model have a unlock able bootloader
    But mine is not unlocking please help?! I would really appreciate it
    P.S : i heard something about phones that are can be normally unlock with adb and fastboot but the same device if bought from ISPs or carriers or service providers ...you can not unlock them so you have to unlock the chip first i am not sure if my phone was brought from ISP or not
     


  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    you have to enable oem unlock by going into the developers option. find your systems build number and hit it 7-8 times until you get a popup asking to allow developer's option. go back into settings and find the developer's option and select it. you should now see an option to enable oem unlock.

    now you should be able to use the code:
    Code (Text):
    1. fastboot oem unlock
    it is something like that as i do not have your phone....just going on what works on some of the other devices.
     
    imsail and MrJavi like this.
  3. 1337xhoax

    1337xhoax Newbie
    Thread Starter

    Thank you. But i have already done what you said and the same error .... :(
     
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    ok well then it looks like it is not recognizing fastboot commands. are you sure when you type "fastboot devices" you get your phone listed?

    is there any way you can make a screenshot of the commands and post them there here?
     
    imsail and MrJavi like this.
  5. 1337xhoax

    1337xhoax Newbie
    Thread Starter

    Yes i get my device when i type fastboot devices
    Also that fastboot reboot works fine and reboots the phone to normal usage state every time i will send the command screen shot soon
    It is 1:59 after mid night here so i got to get some sleep
     
    ocnbrze likes this.
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    no worries, get some sleep and post when you can the screenshot.
     
    MrJavi likes this.

Infinix HOT 4 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...