1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to Unroot Droid X on Gingerbread 2.3.3?

Discussion in 'Android Devices' started by meeraj023, May 23, 2011.

  1. meeraj023

    meeraj023 Lurker
    Thread Starter

    So I found a link for the Gingerbread download when I searched "droid x gingerbread download" on google.
    It had the 4.5.588 System Version.
    I successfully downloaded the software on my sdcard but unfortunately I forgot to unroot my phone with z4root before installing the software.
    Now I don't know what to do since the superuser remains as well as z4root but no rooted softwares work.
    Please don't let me brick this!
    How do I unroot this phone or fix it? Any help is appreciated.

    1. Download the Forums for Android™ app!


  2. Steven58


    Welcome to Android forums, I'll move this to the root section for ya! :)
  3. fonefreak

    fonefreak Well-Known Member


    Can you add a question mark to the post title? I thought the thread was a how-to, not a how-do-you-do-this.
    JB in AZ likes this.
  4. JB in AZ

    JB in AZ Android Expert

    moved to the root section
  5. JB in AZ

    JB in AZ Android Expert

    Done! Thanks for the suggestion. :)
  6. darkcyber

    darkcyber Android Expert

    So, let me see if I understand. You are on .588 GB, non-rooted and your phone is working fine...except it is just not rooted? Sounds like you may have install a non-rooted version.

    You may want to grab .595 and do an sbf and then install the 3 file .588 and then .595 and get on the latest version. Either way, sbf should fix your problem. Or someone else might chime in a better solution.
  7. lonetreeranch

    lonetreeranch Lurker

    I also am having a similar problem as meera, only I have .596 and it still won't root or unroot since the stupid update? I have tried everything that is within my paygrade to figure out my problem but to no avail? I have a droid x that works normal every other way but cannot get rid of superuser so that I can try to rerun z4, I am not real techie in the IT world but I can manage some things. Is there any other suggestions I might try?
  8. ylexot

    ylexot Android Expert

    z4 does not work on GB. If you are rooted, why do you even want to try to re-root or un-root?

    If you really want non-rooted GB, probably the easiest way would be to SBF 596, but you won't be able to re-root it without SBF'ing to 340 and then using the 2-zip 596 GB method.
  9. lonetreeranch

    lonetreeranch Lurker

    Not sure what all that meant? My phone was rooted prior to the update, after the update it still appears to be rooted ie: Superuser icon and all but when I try to run wireless tether it says phone isn't rooted and Z4 just sits and spins until it locks up and force quits itself? I have tried to uninstall Z4 and reinstall it I have tried to unroot through Z4 and reroot all with no change in operation of my phone? I still have data connection and service but no actual root access and it still will download and appear to run root programs but nothing happens???? Can you spell FRUSTRATING........
  10. ylexot

    ylexot Android Expert

    You are not rooted. Z4 root will not work. Read the stickies for more.
  11. mortymouse

    mortymouse Well-Known Member

    I would SBF back to Froyo, (good news is that we have a then upgrade directly to a rooted version of .596 via the following post:

    Official DX Gingerbread 2.3.3 (4.5.596) Release Thread - Something for everyone


    File Part 1
    md5sum: a02e41f06370419ac4f8f77c45b52c1e
    file size: 99.4 MB (104,274,395 bytes)

    Mirror 1: Download Now
    Mirror 2: Download Now
    Mirror 3: Download Now

    File Part 2
    md5sum: 652ae2341f17fd46631be26c28e28eac
    file size: 12.9 MB (13,534,847 bytes)

    Mirror 1: Download Now
    Mirror 2: Download Now
    Mirror 3: Download Now

    We also have this post that will help you:


    Remember its very simple. Just SBF back to Froyo, then update to the rooted version.
  12. Okay, here's my problem:
    I also updated my phone to gingerbread without unrooting, not knowing it would screw things up so bad. I really wanna flash back to 2.2 Froyo and manually install the rooted Gingerbread update so I can get my wifi tethering back. Problem is, I hardly know what flashing is, let alone how to do it lol. I've just used z4root and other one-click methods, etc. so most of this makes no sense to me. I've also tried looking up how to flash back to 2.2 but most of the files or methods used need root access which is what I'm trying to get back in the first place! This is by far the most frustrating thing I've ever tried to do but I'm bound and determined to get it to work :)
    Could someone pleeeeease give me noob instructions...I would be forever indebted to you :)))))
  13. ylexot

    ylexot Android Expert

    This will get you back to Froyo.
    SBF’ing the Droid X U D G
  14. Thanks so much!!!!
  15. bigbadwulff

    bigbadwulff Android Expert

    Also search thru You Tube to see how to sbf. Many little items like (getting to the boot loader) make much more sense SEEING it done. Also seeing what buttons to push in RSD Lite are right there instead of wondering where all the stuff is in RSD. Also the steps you need to do are are in front of you and not easily confused by the written word.
  16. VoidedSaint

    VoidedSaint Resident Ninja

    everyone learns different ways
    seeing, doing, hearing, watching
    most everyone learns one way
    alot of people learn 2 to 3 ways
    and not many learn from all 4

    the ones who learn from all 4 are your everyday developers who adapt to things rather quickly without any explanation.

    hopefully you will learn as quickly as well all did on making your device the best it can be
  17. bouchigo

    bouchigo Android Expert

    See monkey do (get it?) Lol
  18. VoidedSaint

    VoidedSaint Resident Ninja

    your not funny...

    not entirely anyway
  19. bouchigo

    bouchigo Android Expert

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date

Share This Page