1. Are you ready for the Galaxy S20? Here is everything we know so far!

How to Update the Moment (instructions)

Discussion in 'Android Devices' started by 9Nails, Jan 18, 2010.

  1. martonic

    martonic Newbie

    Hi guys, this is an amazing thread - thanks!

    If you "brick" your phone, what then? :eek:

    A new Moment without service plan costs $430 at Amazon. Is that the worst-case scenario? Or is there something else you can do? :thinking:

    1. Download the Forums for Android™ app!


  2. N*TE

    N*TE Newbie

    if you brick your phone, take it in to sprint...how would they know what you did to brick it? plus if you have insurance on your plan its 100 bucks for a new phone. but either way, there really isnt a way they can tell on why a phone bricked, so they'd have to replace it. if they argue, just argue back...remember, customer is ALWAYS right

    PS...dont think anyone has bricked their phone using the above method of rooting...
  3. 9Nails

    9Nails Member
    Thread Starter

    To, that sounds like your using the newest Odin version. I had the same result when it tried the latest version. More than10 minutes sounds lilk its taking too long, so its probably not transfering any files/data. You migjt be able to confirm that by pulling the battery and booting the phone.

    Just to make sure, you are using the 3.98 version of Odin and not the 4.03 right?
  4. slosvt

    slosvt Newbie

    I'm def using Odin 3.98. I was able to get the phone to flash the first upgrade, but the phone will has the same issue when trying to reconnect to flash the cdma upgrade. I am not even sure I can flash bacck to stock to take it to Sprint. Frustrating to say the least.
  5. N*TE

    N*TE Newbie

    -if using firefox, make sure its closed
    -make sure PC studio IS NOT running in the background (check toolbar)
    These are what made mine work...boy did I feel like an idiot after days of trying and realizing pc studio was the culprit.
  6. martonic

    martonic Newbie

    Hi: I'm stuck on this step:

    Step 1-7. Windows must be able to identify your phone as a "SAMSUNG USB Composite Device" and show that it's working properly. If its not, you need these drivers: Samsung Moment USB Drivers Windows.zip

    I downloaded and installed the drivers (by running install.exe) and rebooted my computer (Windows XP Pro SP/3). However, it does not recognize the device. When I point the driver installation prompt to the drivers directory, it still does not find a driver - and I don't know which exact file to point it to.
  7. danooooo

    danooooo Newbie

    I can NOT get my Moment to be seen in download mode. It works fine when normally attached to a pc, but in dl mode it shows as a USB Device. I've tried showing it the drivers, but no go. Rebooted everything. Nope. Any other ideas?
  8. martonic

    martonic Newbie

    Hi, I am going to try again after installing Samsung PC Studio 3.13 (for Win XP):


    which I found here:

    Support for Sync

    Supposedly, this will allow Windows XP to recognize the Samsung Moment in download mode. I will report back on whether or not this works.

    There is also a version for Vista available at the above link. :D

    Edit: This worked to get the PC to recognize the device correctly.

    I installed the above software, then closed it out, then connected the device.

    Next step: Odin!
  9. N*TE

    N*TE Newbie

    Just make sure you close all the way out of PC studio....it stays open in the taskbar on your PC.
  10. martonic

    martonic Newbie

    Thanks - I thought I had closed it completely - it is not in my task list, process list or task bar - but Odin has now been running (step 3-2-10) for TWENTY MINUTES and nothing is happening :thinking:
  11. martonic

    martonic Newbie

    So after 25 minutes I unplugged it and dumped out the battery. It's the same as before. ;)

    Assuming that PC Studio in the background prevented the update, I rebooted the computer and will try it again. :eek:
  12. Gizmodo

    Gizmodo Member

    You must have not read my post in another thread on flashing your phone. Like you, I did EVERYTHING I read in multiple posts in the forum. No luck. Then, I read a post by Zefie which included a couple of things.

    1. Make sure PC Studio and NOT New PC Studio is installed but NOT running in the background and...

    2. And this was the biggy...FireFox must NOT be running!

    I had always left FireFox open to this forum so I could read each step as I did it. Once I closed the web browser, it worked flawlessly! Took about 45 seconds!
  13. martonic

    martonic Newbie

    Hi Gizmodo, Thank you very much. I had in fact noted those things, and thought I had closed everything, but clearly PC Studio was still running.

    After rebooting my PC, I tried it again and SUCCESS!


  14. akenis

    akenis Member

    Getting ready....and excited.

    Do I have to have PC Studio installed? Or is that just for the drivers? I think my drivers are all set. I get just the drivers from the package in the tethering thread.....works fine.
  15. martonic

    martonic Newbie

    Hi - I installed PC Studio to get the drivers. If you're computer is recognizing the device, then you probably don't need it.
  16. martonic

    martonic Newbie

    After completing the update to CL14, I went to System Updates (where there is now an "Update Android" button!) and requested "Update PRL" and then "Update Profile". This was recommended (somewhere!) to avoid intermittent G3 connection glitches.
  17. akenis

    akenis Member

    Guess I was missing G driver. Gonna try PC studio.


    Still having problems w/ driver stuff. Is the device recognized differently while in download mode? In normal mode USB composite works fine. In download mode, I had trouble with USB composite device, and something called Gadget Serial Control.

    1. Are the drivers listed above the same as those in PC Studio? Does PC studio need to be installed? I ran the install, but not as admin or Vista SP2 compatibility. Does that matter?

    2. How do I get Gadget serial control to load?
  18. martonic

    martonic Newbie

    Hi Akenis,

    I suggest installing PC Studio 3.2.1 for Vista (NOTE: this is not v. 3.1.3) as Administrator, then rebooting your PC. Most of the success stories (mine included) seem to been obtained from Win XP, but there seems no reason it can't be done on 32-bit Vista. If you have 64-bit you may be out of luck. I have a Vista laptop but have not tried using it for this. I am not ashamed to say that I hate Vista. Good luck.
  19. akenis

    akenis Member

    Well...pulled a lot of hair out, but finally got all the drivers.

    I am running 64 bit Windows 7. I had previously set up all the drivers via the tethering package in this forum. I used the usbdev program several times and deleted all instances of drivers for the phone (run as admin). I think it just kept loading the same drivers until I renamed the folder from the tethering package. I was never able to manually set a driver for G or Serial Control device.... update driver was always grey'd out. When I finally got a chance to manually set a driver I sent it to the PC Studio directory w/ USB drivers....sub folders checked. It ends up as another Android modem or something.

    Got the sys only and cdma....AND GPS in the hotel room. Keyboard works better. Now that this is easy....ZE09 kernel next.
  20. martonic

    martonic Newbie

    What are the pros and cons of ZE09? (Thanks in advance for answers :))
  21. danooooo

    danooooo Newbie

    Thanks for this info! Now it's seen in download mode and I'm running CL14.
  22. Solo

    Solo Member

    Sigh...I need help...I followed all the steps got the to end. and even tho the usb is unplugged and everything it boots up and just stays at the pulsing samsung screen...ironically enough I thought this would fix my pulsing android screen that probably was caused by the stupid "techs" at sprint with my failed 2 hour update....I really wanna pitch the phone against the wall.
  23. danooooo

    danooooo Newbie

    I'm not sure if this is the issue, but you might want to read this:

    • Don't take your phone to Sprint to be updated. If you took your phone to a Sprint store to be updated to CL14, and are wanting to use Zefie's custom kernels, then you will need to flash your kernels with the patchoob versions. The CL14 update from Sprint stores will jack up your phone and cause headaches when wanting to flash with any of Zefie's custom kernels. Instead, flash with the CL14 update listed above. It is the SAME EXACT update that Sprint is handing out, but doesn't run into problems with any of his kernels.

    Also i want to reiterate that NO ONE should try to flash the Sprints official update using any method on this forum or SDX-DEV, as it can permanently damage your phone. If you want the official one go to your local Sprint store and get it that way. If, in the future, you want problem-free flashing of the ZE** kernels, stay away from the stock CL14 all together. Just flash the CL14 /system update and the CL14 modem listed above.

    How-To: Flash to ZE08 & back to Stock Kernel/Remove System Apps
  24. bbong73

    bbong73 Newbie

    Well I was finally able to flash the update after installing PC Studios.

    Now my question is should I also update the kernel with the Zefie's custom kernel? What will I get out of it?
  25. martonic

    martonic Newbie

    What is the difference between SPH-M900_ZE09.2_KERN.tar and SPH-M900_ZE09.2-patchoob_KERN.tar?

    Is there a changelog for Zefie's kernels? What is new in ZE09.2 compared to ZE08.3? What are the pros and cons of flashing to ZE09.2?

Samsung Moment Forum

The Samsung Moment release date was November 2009. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1440mAh battery.

November 2009
Release Date

Share This Page