1. Are you ready for the Galaxy S20? Here is everything we know so far!

HOWTO: Install Stock Sywpe From OTA Gingerbread Update on Rooted MT4G with CM7 ROM

Discussion in 'Android Devices' started by whytigr, Sep 18, 2011.

  1. whytigr

    whytigr Lurker
    Thread Starter

    I am writing this because I had trouble installing Swype from my 2.3.4 OTA version of the stock ROM and could not find anything to help rectify the situation. I first attempt to just install the .apk from the stock ROM, but that resulted in a continual crash loop of the Swype application. I next tried to install it by only mounting the /system filesystem in read-write mode, but that did not solve the issue either. After dumping the entire file list from my stock ROM and grepping swype, I noticed that I was missing the shared library on the new ROM. Copying it there solved the issue and now Swype works just as it always has. Here is a list of steps to ensure that you don't run into the same aggravation that I did if you want to have Swype as a choice for your input method.

    1. Copy the following files from the stock image into your platform-tools directory:

    /system/app/Swype.apk
    /system/lib/libSwypeCore.3.7.85.27287.so

    2. Boot into the ROM that you want to install Swype on.
    3. Plug your phone into the computer with USB cable and USB debugging on. Make sure you are not in USB Storage Mode (charge-only works fine).

    4. Enter the "adb shell" and make sure you have a "#" (root) prompt. Now type:
    mount -o remount,rw /system
    exit

    5. Push the 2 files you copied from the stock ROM onto the new ROM:
    adb push Swype.apk /system/app/
    adb push libSwypeCore.3.7.85.27287.so /system/lib/

    (This next step may not be necessary. Android will install any APK in the /system/app directory upon boot)
    6. Unplug your phone from USB and using a root enabled file-manager with apk-installing capability, navigate to /system/app and install Swype.apk

    7. Plug your phone back into the computer (without USB Storage Mode) and run "adb shell" again.

    8. From the root prompt, type the following:
    mount -o remount,ro /system
    exit

    9. Unplug your phone from USB and reboot.

    You *may* have to run "Fix Permissions" from ClockWork Mod. I did this before I copied the shared library over hoping that it would solve the crash-loop but no luck.

    Happy Swyping!

    -Tigr
     

    Advertisement

  2. HJAcevedo

    HJAcevedo Well-Known Member

    Another way (and the way I did it when I installed a custom rom) was just to apply for swype beta which then pushes an .apk to install Swype Installer which can be used to install the latest version of swype on your device.
     
  3. whytigr

    whytigr Lurker
    Thread Starter

    While the method you used may work temporarily, I would not recommend it due to the future hassle of program expiration, loss of functionality and inability to reinstall what we are already entitled to just for the sake of convenience while exposing your phone to exploits from unsupported software which is guaranteed to contain bugs as it is a beta program after all. While the method you suggested will provide dirty access to just get swype working, I see many reasons not to go that route.

    Firstly, beta applications are riddled with untested functionality and bugs do not belong on production systems with the expectation it will work as intended, as designed or even at all., Secondly, the version you suggest expires leaving the user once again without Swype and expires without the ability to replace it again, thereby causing the hacking cycle to begin all over again only later rather than utilizing the working procedure because you had an aversion to rebooting your device for unknown reasons. Instead you decide to mislead others with misinformation and promises of simplicity while actually walking them down the road less travelled which actually ends up taking you to the gingerbread house being fattened up by the cannibal witch with no way to escape without reimaging or purchasing Swype that again is not meant for your device. Finally, the few extra steps taken to forward-port the original application to the new ROM makes sense as we already licenseed it by purchasing the phone. We are still entitled to seek support from the vendor for the the full version, whereas we would likely be denied when attempting to get help for the unsupported and unreleased version we installed under an unsupported operating environment.

    Considering the above, why not use the full version we already have vs setting the stage for mega annoyance and additional frustration and hours trying to hack the solution as I originally did for the initial post? I prefer the original version we were sold to the newer versions as well, so my choice was easy. Living on the bleeding edge on a device I must have in order to succeed is unacceptable because whenever Murphy has an opportunity to hose you over, you can bet he will, right when the moment is pivotal too!

    If you enjoy testing commercial applications for free and you can get away with not being able to use your device for hours or possibly days if you don't get frustrated and reinstall your ROM because it's just easier than hacking and researching the solution, then by all means take the easy road to self inflicted misery and walk the road of forced learning instead of putting the extra few keystrokes of effort to succeed the first time.

    Hope this saves somebody additional aggravation even though it is so long after the fact.

    ~Tigr~~
     
Loading...

Share This Page

Loading...