1. Are you ready for the Galaxy S20? Here is everything we know so far!

HP Touchpad Not Charging.

Discussion in 'Android Devices' started by SCPadgeebar, Jan 13, 2013.

  1. SCPadgeebar

    SCPadgeebar Android Enthusiast
    Thread Starter

    Hello guys,
    I'm new here at the HP Touchpad Section but not new here in Android Forums.

    I am running CM7 on our HP Touchpad and my little brother has been fiddling with it(downloading many apps from the playstore using my personal account, thus forcing me to create a new google account/other shiz).

    Then one time, the screen kept turning on and off without us even touching it. Our guess was it was dust on the screen which is being registered as touch.

    After a week or so that that was happening, the touchpad ran out of battery and was not charged right away.

    The result, it won't charge anymore.

    Is there anyway to open the device and shock the battery? It may be a dead battery just like what happened to my sister's iPhone.

    I've also been reading some charging issues with CM7 and CM9 and tried some of their troubleshooting methods but non worked.

    If I just get a little juice to boot it, I would reboot back to webOS as fast as I can and uninstall CM7.

    Thanks in advance,

  2. colchiro

    colchiro Extreme Android User

    You NEVER want to run a Touchpad's battery dead. They don't always make it back easily.

    There are a number of threads on Rootzwiki for dead Touchpads. Holding down the power and home buttons for over 30 seconds and making sure you have a good usb cable and the stock charger is a must. Some times it takes most of a day to charge a dead Touchpad. <-- this is the first thing to try.

    My wife ran her's dead once and luckily it started up again after an hour of charging. Last time I checked it was at 6% so I averted the problem again. The next build of CM10 will automatically power off at 3%.

    Some people have to do this to bring them back to life: TPDebrick v0.1 - HP Touchpad - RootzWiki You might find some hints to get it to power up there too.
  3. SCPadgeebar

    SCPadgeebar Android Enthusiast
    Thread Starter

    Thanks for the reply, colchiro. Will try that on the weekends since I am very busy with school works.
  4. SCPadgeebar

    SCPadgeebar Android Enthusiast
    Thread Starter

  5. colchiro

    colchiro Extreme Android User

    Glad you got it working. What does this mean?
  6. SCPadgeebar

    SCPadgeebar Android Enthusiast
    Thread Starter

    I just read it from the article I read.

    I guess it means that the cord I am using should be used for a period of time so that I will be using a wire that electricity just traveled so the wire is a little bit juiced up.
  7. Galtha58

    Galtha58 Lurker

    I found that the charging connection on my Touchpad is not real good at times. Need to watch the charging icon to make sure the Touchpad is charging. If I don't do that, then sometimes the tablet will go to zero charge and then it becomes a real challenge to get it going again. Also, found that switching to WebOS when charging or when shutting down if the tablet charge is 20% or less seems to be a good idea. Less chance of the tablet having loss of charge or not able to charge issues when I do this. Bit of an issue to switch back and forth between operating systems but not too bad. Recently, while on vacation, I did not notice that the charging connection was not working and the tablet would not do anything the next day. Took quite a while to get it going again.
  8. Nevertells

    Nevertells Well-Known Member

    There is no such thing as juicing up a piece of wire with electricity. What that guy wrote in that thread is totally bogus. What happened to him was totally coincidence and had nothing to do with switching two usb cables between two different chargers.
  9. Nevertells

    Nevertells Well-Known Member

    Have you tried a different usb cable to make sure it is not your cable. HP usb cables are notoriously flimsy.
  10. colchiro

    colchiro Extreme Android User

    This app (by the same guy who is developing our CM roms) will tell you if you're charging or not: Goo.im Downloads - Downloading TPChargeTest-v1.0.apk

    I use my TP usb cable and charger all the time, for multiple devices, and have never had an issue with it, however, if you bend it a lot, like tucking the cable under the tablet, making a 180
  11. kmpatel

    kmpatel Lurker

    my hp touchpad tab is always showing use reliable charger and doesn't charge so what is the way to charge it again ....?
  12. colchiro

    colchiro Extreme Android User

    Are you using the stock, round-barrel charger?
    Are you using the stock cable with the round silver disk on the charger end?

    If no, there you go.
    If yes, then maybe you've ruined your USB cable and need to try other ones.
    Plugging it into your computer won't charge it reliably.
    Install this TP app to see what you are getting for charging: Goo.im Downloads - Downloading TPChargeTest-v1.0.apk
  13. stef7

    stef7 Android Expert

    The most convenient, and the method which avoids cycling the connector is the TouchStone Inductive Charging Station. You know you are charging when the battery indicator in the status area shows animation.
  14. faeq00

    faeq00 Newbie

    Yes you are right, but, if the Touchpad won't boot up from the dead battery or it's stuck on the red charging logo, let the tablet rest for 15-20 min, or until the backside is cool again. For some reason it won't charge when dead and hot... weird. :p
  15. Nevertells

    Nevertells Well-Known Member

    Just be very careful when using a TouchStone. I have seen way too many folks say they verified their TouchPad was charging when they went to bed and woke up in the morning and it was dead and in many cases, bricked. Some got lucky and were able to use J.C. Sullin's Debricking scripts to bring them back to life, some were not so lucky. Lithium battery do not like to be drained to zero. It damages them every time one does that. And if you are the lucky owner of a TouchPad that bricks when the battery is allowed to drain to zero, you get the double whammy!!! Personally, I would not trust charging for long periods of time using a TouchStone and to be doubly safe, boot to WebOS if you do.
  16. Rabid1

    Rabid1 Android Enthusiast

    The same thing is said about using the wall charger. It's the system not the type of charger. It has never happened to me with the Touchstone, but has happened on several occasions with the wall unit on different Touchpads.

    The latter part of you post is the best advice as it seems to only/mostly happen when booted to Android. Although with 10.1 I have not had it happen yet, so possibly it has been fixed.
  17. Nevertells

    Nevertells Well-Known Member

    The only issue I have had with the wall charger in two years using two TouchPads is the removable end cap went bad and I got a replacement cap from HP. I've lost count on the number of folks who have posted about the TouchStone "fooling" them into believing their TP was charging, when in fact it was not or at some point during a charge it stopped. Sorry:(, I don't trust them! It could very well could be something in the Android code, I don't remember anyone posting they had that problem using WebOS.
  18. stef7

    stef7 Android Expert

    The geometry and case designs are such that it's possible the TP slips out of position after you've placed it on the Touchstone. Initially it's charging, and then it isn't.

    But I just don't want to cycle that power connector unless it's necessary.

    So nice to just lie it on the Stone and go.
  19. colchiro

    colchiro Extreme Android User

    Get a shutdown app and leave a shortcut on the desktop. Then you can shutdown without using the button.
  20. meggiedude

    meggiedude Member

    @colchiro and whomever can help :)

    OK, got a completely dead CM10 Touchpad. Tried all the various options to get it going again, i.e every combination of button pressing for 30 sec, tried different USB/charging cables, tried using the USB from PC to trickle charge (which previously worked btw), tried reverting to the touchstone, tried leaving it for 3 weeks and trying again. Nothing. Still dead.

    So is this a case of a totally trashed battery, or will the TPDebrick option linked above likely work.
    On the subject of the TPDebrick utility, obviously it comes with the standard 'you may brick your device' caviat warnings, but in reality, is it likely to be my best option here? What would you do??


  21. colchiro

    colchiro Extreme Android User

    If power + home for 40 seconds didn't cut it, then debrick is your only option. I've done it before when I picked up a TP on fleeBay that wouldn't boot. Fixed it on first try.
    meggiedude likes this.
  22. meggiedude

    meggiedude Member

    Thanks for this.
    What state does the TPDebrick leave your Touchpad in?? CM10? or back to WebOS.
    I'm CM10/WebOS dual boot at the moment (or rather was).


  23. faeq00

    faeq00 Newbie

    Don't worry, it keeps your CM version, and in automatically boot into it once you are finished.
  24. Nevertells

    Nevertells Well-Known Member

    There is a good change that your battery charge state if very low. Once Debricking finishes, your TouchPad may need to sit on the wall charger for a while, but one the battery reaches a safe state, they TP will boot up and like MD said, it will boot to CM10. So be patient and let things take their course.
  25. colchiro

    colchiro Extreme Android User

    It boots into the same rom it always did when you turned it on. For 99% of us, it would be CM, but some people change it to be webOS to prevent bricking from a low battery.

    You will want to use your stock charger (the cylindrically-shaped one) and the stock cable with the silver disk on the tablet end when it's done (assuming both are in good condition).

Share This Page