1. Check out our app, Forums for Android! Download and leave feedback here!

Support HSPA signal but no Internet access.

Discussion in 'Android Devices' started by dirtydozenuk, Sep 2, 2010.

  1. dirtydozenuk

    dirtydozenuk Active Member
    Thread Starter
    16

    Sep 2, 2010
    28
    4
    16
    Afternoon all,

    I have a HTC Desire on o2 pay as you go.

    At home I have a E signal, sometimes 3G and everything works fine. In certain areas I get a H signal which works great.

    Here's were my problem lies - At my workplace I get a H signal but can't gain access to the android market, browse the Internet or use Facebook etc.

    Has anyone else experienced the same problem or have any ideas on how to fix this?

    Thanks

    :cool:
     

    Advertisement

  2. SUroot

    SUroot Well-Known Member
    1,123

    May 25, 2010
    23,925
    5,304
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    I find with O2, sometimes it reports that it is H, when the connection isn't present. A bit like a black spot... and I can't connect/ Theres one on my bus route to work, but once out of it, it starts to operate fine.

    You could always try turning on (and then off) airplane mode to see if that helps.
     
  3. dirtydozenuk

    dirtydozenuk Active Member
    Thread Starter
    16

    Sep 2, 2010
    28
    4
    16
    Thanks for your reply Dan. I have tried this but still no luck. I think you are right maybe it is a black spot. Though my old phone (with a different sim, still o2) did work in this same area.

    Not sure if it means anything but under the H the left arrow (pointing up) seems to be the only one that lights up while @ work.
     
  4. SUroot

    SUroot Well-Known Member
    1,123

    May 25, 2010
    23,925
    5,304
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Yeah this means your phone is trying to connect to the netwrok but its not getting a response. This is what I get too.
     
  5. dirtydozenuk

    dirtydozenuk Active Member
    Thread Starter
    16

    Sep 2, 2010
    28
    4
    16
    I have found a solution for anyone having the same problem.

    I have changed the network mode to GSM only which seems to have done the trick. E signal only, but hey it's better than nothing.
     
    SUroot likes this.
  6. nx1977

    nx1977 Well-Known Member
    163

    Feb 8, 2010
    2,421
    174
    163
    UK
    Check your APN settings are correct, and that your SIM card has '3G' on it.
     
Tags:

Share This Page

Loading...