1. Download our Official Android App: Forums for Android!

Root htc desire bravo stuck in bootloop- can anybody assist me in cracking this with adb

Discussion in 'Android Devices' started by battymatty007, Dec 19, 2013.

  1. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    Hello, i am stuck and hoping someone can assist me.
    Im a beginner with this stuff so my understanding is basic and instructions need to be idiot proof!
    I have purchased an htc desire (G7) bravo on ebay as faulty: crashes regularly and only restarts after an hour or so, hangs on white startup screen with green htc logo.
    Phone details:
    Bravo PVT4
    Samsung amoled by looking at the LCD
    Ship S-on
    Hboot 0.93.0001

    Since purchase i have tested it and the above is true. I am wondering if this could be a solvable software issue rather than hardware at fault.
    I have noticed that there are a screen full of unusual control widgets that i cannot get rid of by factory resetting, and that i cannot locate on downloaded apps menu- i wonder if someone has pushed these into the phone and caused this problem.
    So far i have rooted using unrevoked 3 and recovery RA 2.0.1 (as PVT4 and uncertain if 40,000 or 20,000).
    It took me sometime to get success because the phone would freeze but eventually with a bit of luck i got a success message from unrevoked and the phone entered recovery mode (black with green text).
    I powered down the phone hoping to complete later on but on restarting it now just hangs up and i cant get it to boot or enter recovery. Is this a bootloop?
    In addition sometimes it just vibrates 7 times before freezing on startup- what does this mean?
    I can access hboot and fast boot with power+vol down and these are stable.
    I have since set up adb on my computer and in command the phone responds to fastboot by providing its serial no.
    I am unsure exactly where to go from here.
    Is it possible to flash the operating system from fastboot?
    Or even the kernel? (i am uncertain how to aquire and use a boot.img file? and have had no luck so far tring to install one)
    I have tried downloading and flashing cm7.zip from the adb folder. i have tried the same with superuser, but i get the error message: failed registery (or something similar as i remember).
    So as you can tell i am well out of my depth but finding this very interesting and am eager to crack it (with some help).
    I am hoping to be able to use adb to rectify the problems or wipe the lot and start again.
    Any such help greatly appreciated,
    Regards,
    Mat.
     

    Advertisement

  2. iowabowtech

    iowabowtech root@android:/ #
    Rank:
    None
    Points:
    1,493
    Posts:
    12,182
    Joined:
    May 2, 2010

    May 2, 2010
    12,182
    8,680
    1,493
    Making the Establishment nervous
    Iowa|USA
    Is that G7 a Chinese clone? Anyway, I moved your thread to our HTC Desire root forum in the hope that other owners of this device can be of assistance.
     
  3. Hadron

    Hadron Smoke me a kipper...
    VIP Member
    Rank:
     #9
    Points:
    2,468
    Posts:
    24,805
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    24,805
    19,268
    2,468
    Spacecorp Test Pilot
    Dimension Jumping
    Hi battymatty007, and welcome to AF :)

    I wish I had good news for you, but 7 vibrates when you start to boot is really not a good sign. That usually means a fault with the motherboard, so it's a little surprising it boots at all, and it might be that there's nothing we can do using software.

    From hboot can you not get into recovery? What happens if you select "recovery" from the hboot menu?

    That's how you install a ROM: copy the ROM .zip onto the sd card, go into a custom recovery (Amon Ra in your case), do a factory reset, then select "install from zip", select the zip and install it. Don't worry about boot.img: on the Desire you install the kernel as part of the ROM, so if you can install a ROM that's job done.

    If you can't get into recovery, your best bet software-wise might be a ROM Update Utility (RUU), which will wipe the phone and install a fresh set of official (unrooted) software. You can find a selection of RUUs here. These are specific to the phone's region and provider. If there's no obvious branding on the phone (like an operator's splash screen when you power on) then RUU_Bravo_Froyo_HTC_WWE_2.29.405.5_Radio_32.49.00.32U_5.11.05.27_release_159811_signed.exe
    would be worth trying. Or the 2.3 update (near the bottom of the list, as a .zip - unzip to find the RUU .exe), which works on many network's phones. To run an RUU you copy it to a Windows PC, boot the phone into fastboot, connect to the PC via USB and run the .exe on the PC.

    I'm a bit worried about the instability and vibration though. Just a thought, but try leaving the battery out for a bit before doing any of this - let the phone get good and cool. It may run better (though PVT4 devices didn't usually suffer from overheating - it was mostly PVT1 that had that).

    Oh, and although it's not important (because the screen isn't your issue, if it's PVT4 that's an LCD screen, not an AMOLED. Only the PVT1 devices had Samsung AMOLED displays.

    Good luck!
     
  4. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    i love techi forums, always so much assistance out there. thanks!
    ive been worried about the 7 vibrations too and also the fact that sometimes it boots, sometimes it dont.. seems a bit unstable to be just software issue.
    but worth a go a fixing i reckon.
    from hboot i can access fastboot fine and both will usb plug fine.
    from hboot to recovery generally does the same as trying to start the phone, i.e it freezes on white screen with green htc logo. sometimes with 7 vibrations, sometimes with 3, sometimes with none.
    and very occassionally it does start, or enter recovery but there seems to be little pattern as to when this is.
    i managed to get back into recovery after my last post and i flashed cm7 which worked fine. however the problem is the same its just that im running cm7 rather than 'sense' or whatever the stock system is called.
    ive just tried running the ruu you suggested (funny enough i worked on another broken desire i have so thanks for that!) but on this i get this error message: error [131] customer id error - cannot update android phone- please get correct ruu and try again.
    i will try another ruu but am unsure what build i have and which i should go for as i cannot boot the phone to check- any ideas.
    if all else fails at least i have myself a complete set of spares minus the mother board!
    regarding the screen i am confused- theer seem to be 2 distinct types that are incompatible, i thought 1 wassony and the other samsung, i know i have tried swapping bits from G7's around and have run into trouble when trying to mix and match from the varients with different screen circuitry.
    many thanks for your help,
    mat
     
    scary alien and scotty85 like this.
  5. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    aah, i have used fastboot and comand to find out that my existing rom is 2.17.61.3
    ive not found a suitable ubdate yet and it seems as though a few people are in the same boat with this one.
    cheers,
    mat
     
    scary alien and scotty85 like this.
  6. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    tried ruu 2.33.161.2 as was recomemded by somebody out there who was having trouble updating from 2.17.61.3
    it failed unfortunately.
    i know have a black screen with whits htc logo and 4 corner triangles.
    the ruu software still recognises the phone though and tries to restore.
    however i have no hboot, fastboot etc.
    if an ruu exists to suit then it should be ok..
    any ideas anybody?..
    thanks again.
     
  7. Hadron

    Hadron Smoke me a kipper...
    VIP Member
    Rank:
     #9
    Points:
    2,468
    Posts:
    24,805
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    24,805
    19,268
    2,468
    Spacecorp Test Pilot
    Dimension Jumping
    Sorry, was offline & now going to bed. With the phone in that state the only thing you can do is run an RUU. If the 2.33 RUU started (i.e. didn't stop with a cid error - which means wrong region/branding) it may be worth trying that again. If the phone is unstable it may be just that it glitched part way through.
     
  8. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    i havent had a chance to read this very closely yet,but to get out of ruu mode you can try:

    fastboot reboot-bootloader

    if that doesnt work,you may have a command to reset the ruu flag,so enter:

    fastboot oem ?

    and give us that list.

    failing that,you just need to falsh something. since youre s on,it will have to be an htc signed file. :(

    an ruu is worth a shot,but as hadron mentioned,7 vibes is a bad sign. in all my searching for folks with that issue,ive never come across a 7 vibe sitiuation that was fixed with software :(

    im off to dinner,but when i get back ill give it a closer look and see if anything pops into my mind :)
     
    scary alien and iowabowtech like this.
  9. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    fastboot reboot
    reboots into bootloader on comand screen and resets phone but only to same black screen with corner triangles

    fastboot oem ?
    info keytest
    infoheap
    infoboot
    inforeset
    infopowerdown
    inforebootruu
    infoheap_test
    infosmi_test
    infortask
    infoenableqxdm
    infogencheckpt
    okay

    means nothing to me, wheres the info?

    okay, many thanks again.
    please let me know if anybody thinks up a plausable ruu for my build or of any other ideas
    appreciate all the help and enjoying the challenge..
    mat
    x
     
    scary alien likes this.
  10. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    in addition i thought id mention that the hboot screen now just displays
    bravo, hboot, microchip, touch and radio verions along with the date and highlighted in orange 'RUU'
    x
     
  11. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    i was hoping to see a command something along the lines of "reset RUU flag" but unflrtunately nothing there looks particularly useful. if youre feeling froggy try:

    fastboot oem reset and see what happens. ive no idea what this will do,so use your own judgement. so we prolly now will just need to find an ruu that will flash. the .exe files can be finicky. you might try extracting rom.zip from it,and then flashing it via fastboot if it started to run without a cid/mid/main version error.

    extract rom.zip in this manner:
    the .exe utilities can be finicky,so if you have trouble getting it to run, you can extract "rom.zip" in the following manner:
    -start the utility
    -check the "i understand" box to move on to the next screen
    -hide the utility temporarily out of site
    -search your C drive for "rom.zip". you will find it in a temporary location(it will be in a different spot each time you run the utility)
    -open the folder location,and transfer rom.zip to a safe location on your PC.
    -unhide and cancel the utility,youre done with it.
    -rom.zip can be renamed to PxxxIMG and flashed in hboot,from a FAT32 sd card

    since youre stuck in ruu mode anyway:)eek:) id flash it in this manner:
    if youre working with a booted,operational phone,you can flsh the file in the following manner:

    -open a cmd window

    -change to adb/fastboot directory
    cd c:\foldername
    (cd c:\mini-adb if youve used any of my guides :))

    -place the zip file you want to flash into adb/fastboot directory

    -enable usb debug,disable fastboot,plug in phone

    -check for connectivity
    adb devices (should return serial number)

    -boot to fastboot
    adb reboot bootloader

    -check for connectivity again
    fastboot devices

    -flash the file
    fastboot erase cache

    fastboto oem rebootRUU (will put you in ruu mode,black screen silver htc letters)

    fastboot flash zip zipfilename.zip (will send and flash the file. dont interupt it while the cmd window shows its writinging,and the green status bar is moving on the phone screen)

    *sometimes a file will fail with a pre-update error. this is normal,just enter again:
    fastboot flash zip zipfilename.zip
    and this time it will finish

    -when you get "finished" and "OK"
    fastboot reboot-bootloader (takes you back to fastboot)

    -reboot back to the OS
    fastbooot reboot

    you can use this if you dont have an operational phone as well. you just need to manually put the phone in fastboot(select from hboot menu) then skip the "adb" commands and start with fastboot devices

    if it runs,doing so in this manner will also let us see exactly where it fails.

    if you cant get past a main version/cid/mid error,then the only option left will be to try to lower the main version,and then either find an ruu that meets the cid/mid criteria,or if you have another device you can create a gold card,wich will bypass the cid/mid check.

    if you have done a fastboot getvar all,it may help us to see that(with exception of your esn,meid)

    hadron,is there an eng hboot for his device? if so,think we could DD it into place using adb in recovery? also,this is a mtd device,correct?
     
  12. iowabowtech

    iowabowtech root@android:/ #
    Rank:
    None
    Points:
    1,493
    Posts:
    12,182
    Joined:
    May 2, 2010

    May 2, 2010
    12,182
    8,680
    1,493
    Making the Establishment nervous
    Iowa|USA
    If u think u know the right RUU and have trouble extracting the rom.zip give me a download link the the RUU and I'll extract the rom and host it for you. Great effort here guys.
     
  13. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    hi, extracted the rom.zip from ruu 2.33 and tried to flash from fastboot with adb
    heres a copy of the results

    c:\SDK\platform-tools>adb reboot bootloader
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    error: device not found

    c:\SDK\platform-tools>fastboot devices
    HT04LPL11550 fastboot

    c:\SDK\platform-tools>fastboot erase cache
    erasing 'cache'... OKAY


    c:\SDK\platform-tools>fastboot oem rebootRUU
    ... OKAY

    c:\SDK\platform-tools>fastboot flash zip rom.zip
    sending 'zip' (157061 KB)... OKAY
    writing 'zip'... INFOadopting the signature contained in this image...
    INFOsignature checking...
    INFOzip header checking...
    INFOzip info parsing...
    INFOchecking model ID...
    INFOchecking custom ID...
    FAILED (remote: 42 custom id check fail)

    getvar all gives me:


    c:\SDK\platform-tools>fastboot getvar all
    INFOversion: 0.5
    INFOversion-bootloader: 1.02.0001
    INFOversion-baseband: 5.10.05.30
    INFOversion-cpld: None
    INFOversion-microp: 051d
    INFOversion-main: 2.17.61.3
    INFOserialno: HT04LPL11550
    INFOimei: 357710048245545
    INFOproduct: bravo
    INFOplatform: HBOOT-8x50
    INFOmodelid: PB9920000
    INFOcidnum: ORANG001
    INFObattery-status: good
    INFObattery-voltage: 3947mV
    INFOpartition-layout: Generic
    INFOsecurity: on
    INFObuild-mode: SHIP
    INFOboot-mode: RUU
    INFOcommitno-bootloader: a7cdbe26
    INFOhbootpreupdate: 11
    all: Done!

    any ideas?.
     
    scotty85 likes this.
  14. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    still trying to sus this but pretty ignorant of the language.
    im assuming custom id failure relates to Cid?
    what exactly is this?
    is this still a question of locating the correct rom?
    i know that others have had trouble updating from 2.17.61.3
    is there a way to root from fastboot with adb or another method to get the phone to accept a custom rom?
    I should give up really but am stubborn and hungry to understand this infernal little machine!
     
    scotty85 likes this.
  15. Hadron

    Hadron Smoke me a kipper...
    VIP Member
    Rank:
     #9
    Points:
    2,468
    Posts:
    24,805
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    24,805
    19,268
    2,468
    Spacecorp Test Pilot
    Dimension Jumping
    CID is customer id, i.e. the check on region/branding. I think 2.17.61.3 is an Orange software version (at least the first dozen results when I googled it were all Orange phones). And I realise there's a possible confusion: when I referred to the 2.33 RUU I was thinking of the offical update to 2.3.3, but the software version you quoted (2.33.161.2) is actually a Vodafone build. So yeah, a cid error is likely.

    Actually this does make things simple: no Orange RUUs I know of ever leaked, so if that's what you have then your best bet is the official Android 2.3 upgrade. You can download that from shipped-ROMs, where it's at the bottom of the page. The package is a zip, which you need to unzip to get the RUU (which is a .exe). That one should not suffer a cid error.

    @Scotty: yes, this is an mtd device. And I think alpharev's hboots would do anything an official eng hboot would (the one they call bravo_stock would work with a standard HTC ROM - the others are for modifying the mtd). I've never tried modifying hboot via adb though (unfortunately the two normal tools for installing this, revolutionary and the original alpharev tool, both require the phone to be running android to work).
     
    scotty85 likes this.
  16. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    hadron,i assume you mean this file? Shipped ROMs

    if that one will run,that would be the easiest route to take.

    thanks hadron. i was thinking there are little enuff security checks on this phone that we could use "flash_image" to write the bootloader in recovery,where a root shell will exist. i have no idea if it would work or not. seems like it should,we just need to know where hboot lives. my experience with mtd devices is limited to the eris,and the OG droid incredible,where flash_image was used to write a new misc image with a modified main version.

    basically,wed do it something like this:

    adb push flash_image /data/local/
    adb push mtdx.img /sdcard/

    cd /data/local
    chmod 0755 /data/local/flash_image

    cd /data/local
    ./flash_image misc /sdcard/mtdx.img

    where mtdx is the alpharev hboot,and the x is where hboot goes(mtd0,mtd1,etc)

    if this would work it would give us an huge amount of freedom,since the alpharev hboot:
    -is patched for eng commands
    -ignores the radio secure flag
    -ignores the mid/cid check(so no gold card is needed to flash different regional roms)
    -protects itself from being overwritten by other hboots.

    those last 3 mean we could run literally any ruu that there is,without regard to main version,cid,or mid,and the s off hboot would remain.

    it seems to easy,lol,so there may well be reasons or write protections keeping it from working that way. what are your thots?

    if that doesnt work,we could always rewrite the misc image with flash_image,and if a gold card could be made,we could still trick the phone into flashing a different signed ruu. for this to work,we just need an altered misc image,or a stock misc image we can modify.
     
  17. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    your info:

    after a bunch of digging,i got to rom.zip,and heres whats on the android info:

    Code (Text):
    1.  
    2. cidnum:YOIGO***
    3. cidnum:VODAP***
    4. cidnum:VIRGI***
    5. cidnum:T-MOB***
    6. cidnum:TELUS***
    7. cidnum:TELST***
    8. cidnum:SBM__***
    9. cidnum:SKT__***
    10. [COLOR="Red"]cidnum:ORANG***[/COLOR]
    11. cidnum:O2___***
    12. cidnum:BSTAR***
    13. cidnum:H3G__***
    14. cidnum:FASTW***
    15. cidnum:HTCCN***
    16. cidnum:HTC__***
    17. [COLOR="red"]modelid: PB9920000[/COLOR]
    18. modelid: PB9921000
    19. modelid: PB9922000
    20. cidnum: 11111111
    21. [COLOR="red"]mainver: 3.14.405.1[/COLOR]
    22. hbootpreupdate:12
    23. DelCache: 1
    24.  
    from the getvar above,this one does look perfectly compatible.

    hadron,how hard is it to root this build if it boots and runs?
     
  18. Hadron

    Hadron Smoke me a kipper...
    VIP Member
    Rank:
     #9
    Points:
    2,468
    Posts:
    24,805
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    24,805
    19,268
    2,468
    Spacecorp Test Pilot
    Dimension Jumping
    Yes, that's the RUU I meant. :)

    If that RUU loads and runs you can then use Revolutionary to flash an Alpharev hboot to it. One that's done you can do pretty much anything.

    Ironically the RUU you should try to avoid is the one that installs the officially unlockable bootloader. That will block all other rooting methods and leave you stuck S-On. The only place I know to get that one if from htcdev.com, if you follow the bootloader unlocking instructions. However, it does have the merit of being compatible with a wide range of cids, but I treat it as a last resort.
     
    scotty85 likes this.
  19. battymatty007

    battymatty007 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    18
    7
    16
    Good afternoon,
    All very interesting.
    I have just extracted the rom.zip file from the official android 2.3 update and tried flashing with adb in fastboot. It failed at:


    Remote 12 signature verify fail


    Strangely it didn
     
  20. nicka3200

    nicka3200 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,047
    Joined:
    Dec 28, 2011

    Dec 28, 2011
    1,047
    357
    163
    Male
    UK
    For the official 2.3.3 RUU you don't need to flash the ROM as such. You need to open the .zip file. Inside you will find an .exe file, copy that to your PC. Now boot the phone into fastboot mode (from fully de powered hold down the back arrow key & press the power key, or from the bootloader scroll down with the volume key to fastboot & press power to select). Connect the phone to the PC using the USB cable & launch the .exe file.

    Sorry if the above is teaching you to suck eggs. Your post read as though you are trying to extract the ROM from the .exe & flash from recovery, which is not what is intended.
     
    scotty85 likes this.
  21. nicka3200

    nicka3200 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,047
    Joined:
    Dec 28, 2011

    Dec 28, 2011
    1,047
    357
    163
    Male
    UK

    A gold card is a file placed on your sd card that an RUU will use to confirm that you are using the correct RUU for your carrier. The 2.3.3 official upgrade RUU is universal so does not require a gold card.

     
    scotty85 likes this.
  22. Hadron

    Hadron Smoke me a kipper...
    VIP Member
    Rank:
     #9
    Points:
    2,468
    Posts:
    24,805
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    24,805
    19,268
    2,468
    Spacecorp Test Pilot
    Dimension Jumping
    Signature verification fail means that the digital signature of the file is invalid. If you still have the original zip file, check the md5 code and make sure it matches the one on the site. If not you have a bad download.
     
    scotty85 likes this.
  23. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    The .exe is in a zip file in a zip file... It's pretty deep inside there
     
    nicka3200 likes this.
  24. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    to elaborate a little more... when you extract the downloaded file,you have an unzipped folder. inside that,you have another unzipped folder. inside that, you have a couple .apk files,a wallpaper zip file,and another HTC_Desire_Android_2.3_Upgrade.zip :)eek:) extract this zip file,and you have a PDF file,and the actual signed 2.3 upgrade RUU. this .exe file you can run directly,or extract rom.zip from that. as i said,its in there pretty deep.

    my hope is that you just attempted to flash the first zip file that you came to,wich would definately result in the verification error.

    as hadron said,check the md5sum of the downloaded zip,before doing any extractions. it should be:
    HTC_Desire_Android_2.3_Upgrade.zip 1b1bf0eba081f9ba2a0aaa2089f3868b
     
  25. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    not a prollem. we are here to help. holler if you have further questions :)
     
Tags:

Share This Page

Loading...