1. Download our Official Android App: Forums for Android!

General HTC Desire C Bricked on Software Update

Discussion in 'Android Devices' started by BrkHll, Dec 25, 2013.

  1. BrkHll

    BrkHll Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 25, 2013

    Dec 25, 2013
    4
    0
    5
    Hi all.

    I was offered a system update on my HTC Desire C and I accepted it. While it was downloading/ installing I was moving in and out of cell coverage. It got stuck on the "HTC Quietly Brilliant" screen for 2 hours.

    I turned it off and it won't get past that point now. It will just get to that screen and stay there for hours. I tried hard factory reset. No help.

    I don't know how to fix it. Can anyone help?

    HBOOT says:
    *** LOCKED ***
    GOLFU PVT SHIP S-ON RL
    HBOOT-1.31.0000
    RADIO-1.19.98.02
    eMMC-boot
    Jul 12 2013, 15:44:30
    I'm not experienced with this kind of thing so all help really appreciated.
     

    Advertisement

  2. argedion

    argedion The TechnoFrog
    Rank:
    None
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,294
    953
    The Infernal Swamp
    Is the phone under warranty?
     
  3. BrkHll

    BrkHll Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 25, 2013

    Dec 25, 2013
    4
    0
    5
    No, don't think so. Bought it second hand unlocked from another network in August. I don't have original box or receipts or anything.

    How would I find out for sure though?
     
  4. argedion

    argedion The TechnoFrog
    Rank:
    None
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,294
    953
    The Infernal Swamp
    I would call my provider see if they can help. If a factory reset wont work then the /system partition is probably corrupt. Not sure if you can root it under the condition it is in and try to flash a different ROM.

    Start Here
    HTC Desire C All Things Root

    I will move this thread over to the HTC Desire C Forums. Hopefully someone over there can offer a lot more help than I can.
     
  5. iowabowtech

    iowabowtech root@android:/ #
    Rank:
    None
    Points:
    1,493
    Posts:
    12,182
    Joined:
    May 2, 2010

    May 2, 2010
    12,182
    8,680
    1,493
    Making the Establishment nervous
    Iowa|USA
    Well if we can locate the most recent RUU, you can use that to flash stock from your PC. May be hard to come across if there's a very new update hitting the phone now.

    Anybody know where one might find it?
     
  6. iowabowtech

    iowabowtech root@android:/ #
    Rank:
    None
    Points:
    1,493
    Posts:
    12,182
    Joined:
    May 2, 2010

    May 2, 2010
    12,182
    8,680
    1,493
    Making the Establishment nervous
    Iowa|USA
    BrkHll,
    Do you remember which network this phone was originally running on when you bought it? And if possible, what Country it came from?

    edit:
    leaving this here for my own reference/possible future use:
    http://www.androidruu.com/?developer=Golf
     
  7. BrkHll

    BrkHll Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 25, 2013

    Dec 25, 2013
    4
    0
    5
    Thanks for your response iowabowtech.

    Ya, as far as I know it was originally locked to the O2 network in the Republic of Ireland. When it was last working it was unlocked and I was using it on the 48 Months network in the same country.
     
  8. iowabowtech

    iowabowtech root@android:/ #
    Rank:
    None
    Points:
    1,493
    Posts:
    12,182
    Joined:
    May 2, 2010

    May 2, 2010
    12,182
    8,680
    1,493
    Making the Establishment nervous
    Iowa|USA
    Hmm, I'm afraid that UK RUU might predate what you have now which means it wouldn't load. I'm going to check with our resident Desire expert Hadron and see if he can take a look at this one and maybe offer up some thoughts. Stay tuned.
     
    argedion likes this.
  9. Hadron

    Hadron Smoke me a kipper...
    VIP Member
    Rank:
     #9
    Points:
    2,468
    Posts:
    24,775
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    24,775
    19,223
    2,468
    Spacecorp Test Pilot
    Dimension Jumping
    Sorry, not been on here over Christmas. Unfortunately I know the original Desire better than the C (my wife has a C, but she doesn't let me fiddle with it ;)).

    Bill, did you try running any of the RUUs on the page that IBT linked? To run them if you can't boot the phone into android, select "fastboot" from the hboot menu, connect to a PC via USB, then run the RUU .exe on the PC. If it fails, note down the error message and code, as that may help us identify the problem.

    One problem might be that the phone was originally O2 Eire. RUUs check the original region and network branding, and won't run if these don't match. There's no O2 Eire RUU in that archive, nor have I found one, so my best guess would be to try the 2.00 HTC_Europe one and see whether that will run. If it fails with a "cid" or "customer id" error then that means it needs the original branding.

    As for warranties, the Desire C is less than 2 years old, and 48 month warranties are standard throughout the EU for phones, so it should still be covered. Lack of original paperwork may be a problem, but there's no harm in contacting HTC and seeing whether they will accept it anyway.
     
    olbriar and iowabowtech like this.
  10. BrkHll

    BrkHll Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 25, 2013

    Dec 25, 2013
    4
    0
    5
    Thanks Hadron. Just tried that. No luck unfortunately.

    Attached are the Image Versions used in tmp2.jpg and the resulting error in tmp.jpg.

    Any other ideas folks?

    Thanks.
     

    Attached Files:

    • tmp2.jpg
      File size:
      32.3 KB
      Views:
      94
    • tmp.jpg
      File size:
      32.9 KB
      Views:
      88
  11. Hadron

    Hadron Smoke me a kipper...
    VIP Member
    Rank:
     #9
    Points:
    2,468
    Posts:
    24,775
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    24,775
    19,223
    2,468
    Spacecorp Test Pilot
    Dimension Jumping
    Damn - looks like IBT's fears were correct :(
     
  12. iowabowtech

    iowabowtech root@android:/ #
    Rank:
    None
    Points:
    1,493
    Posts:
    12,182
    Joined:
    May 2, 2010

    May 2, 2010
    12,182
    8,680
    1,493
    Making the Establishment nervous
    Iowa|USA
    It's simply not available yet. I'm checking some contacts to see about digging it up. Otherwise it's a waiting game. Will post back if I hear anything.
     
  13. jnilsso1

    jnilsso1 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 2, 2014

    Jan 2, 2014
    1
    0
    5
    Hi,

    I've run into the exact same problem with a HTC Desire C with the same specs as yours but mine is bought in Sweden. I don't succeed with the HTC_Europe ones :(

    Hopefully there will be a new ROM shortly!

    Thanks guys for awesome help so far!
     
Tags:

Share This Page

Loading...