1. Check out our companion app, Forums for Android! Download from Google Play

HTC Desire HD GPS transformed from unusable to perfect

Discussion in 'Application Requests' started by dcheech, Apr 2, 2011.

  1. dcheech

    dcheech Member
    Thread Starter
    6

    Mar 27, 2011
    5
    1
    6
    Retired
    Newcastle Upon Tyne
    Gone to GPS fix in a few seconds then spot on accuracy from not working at all

    I've surfed for months & found bits of what works for me to fix this, but never found all of this together:

    I get GPS fix in 5 to 10 seconds outdoors & often indoors by doing the following (I suggest you write down your original settings so you can reset things when not using Sat Nav or other GPS dependent apps):

    - menu - Settings - Location (switch GPS on & Wireless networks off)

    - menu - Settings - Wireless & networks (switch Wi-fi & Mobile network off)

    - menu - Settings - Wireless & networks - Mobile networks - Access Point Names (make sure there is an entry with your network provider name & default,supl underneath it. Create a new entry if this doesn't exist. Highlight this entry)

    - Start GPS Status (it's free from the Market) you should get a very quick GPS fix.

    - In my case Locations & Premium Navigation work smoothly & with spot on accuracy now.

    If this proves useful to others it would be great if a developer with the right skills could write a widget to do this!

    Hope it helps some of you,

    David
     

    Advertisement

    JediMeerkat likes this.
  2. JediMeerkat

    JediMeerkat New Member
    5

    Apr 9, 2011
    4
    0
    5
    Design Engineer
    England
    Hello David,

    Just got a new HTCDHD and I cannot get the GPS to work either. I'm waiting for a new sim from my my new supplier and when I get transferred over I will try your suggestions. Do I run GPS status before or after I run locations? Do I need to run GPS status every time I use GPS on locations, premium nav or google maps?

    I've just looked at - menu - Settings - Wireless & networks - Mobile networks - Access Point Names and my entry is o2 postpay and in small text underneath it says wap.o2.co.uk. I can't see any reference to default,supl ???? It's the only entry in Access Point Names.


    Thanks Ray :)
     

Share This Page

Loading...