1. Are you ready for the Galaxy S20? Here is everything we know so far!

HTC Desire HD - Soft Bricket on Updating to Jelly bean 4.2.2

Discussion in 'Android Devices' started by iquadri, Jul 8, 2013.

  1. iquadri

    iquadri Lurker
    Thread Starter

    Hi all,

    First of all, I would really appreciate if any body could help me out regarding my HTC Desire HD dilemma.

    I had my old HTC desire HD, that I wanted to updated to a custom ROM (Jelly bean 4.2.2, as using the instructions found at this link:

    Update HTC Desire HD to Android 4.2.2 JellyTime Jelly Bean Custom ROM [How To] - Tutorial / Guide

    (Just for info, the version on HTC desire HD was Gingerbreak 2.3.5) with French SFR ROM (Corresponding RUU = HTC Europe 3.12.405.1 as indicated in the HECDev.com).

    So 0) I followed the instructions to root my HTC Desire HD:
    as indicated at this link at androidforums,
    http://androidforums.com/desire-hd-...-how-unlock-install-recovery-root-htcdev.html

    1) I first installed HTC Sync on my machine, and did a sync between PC and HTC to transfer some photos.

    2) Went to the HTC Dev website, followed the procedure, to get the oem token, got the unlock code.bin file, unlocked the boot loader, the phone got reset, everything was dandy till then.

    3) Used the temporary flash recovery option, adb and fastbook were working fine. I was able to boot the ext4 image via fastboot and made a backup (present in the clockmode recovery folder in the sd card)

    4) Flash the superuser root files, without any issue

    Thus my HTC Desire HD got rooted and everything was fine till then.

    5) Then tried to install the custom Jelly bean 4.2.2 ROM, via the teamandroid page. Downloaded the ROM, and the google apps (Gapps CyanogenMod 10.1 - gapps-jb-20130301-signed.zip
     



    1. Download the Forums for Android™ app!


      Download

       
  2. iquadri

    iquadri Lurker
    Thread Starter

    Hi again, I also found that on recovery, after the red exclamation point, I can press up and power button to access a new set of menus (Clock mood recovery) , I tried rebooting the system, didn't worked. Didn't wanted to try other options, until i get some feedback.

    Thanks.
     
  3. iquadri

    iquadri Lurker
    Thread Starter

    So, i did the following,
    I extracted the boot.img from the RUU, and put it in the adb/fastboot folder in my PC.

    I used the fastboot boot boot.img command,

    The HTC booted back to life and then was at the config screen.
    Everything looked fine.
    Except, i restarted the phone and was back at the rest green/red screens.

    :(
     
  4. iquadri

    iquadri Lurker
    Thread Starter

    Issue solved after doing some digging, now on 4.2.2 :) !
     
    scotty85 and scary alien like this.
  5. scary alien

    scary alien not really so scary
    VIP Member

    A little late, iquadri, but congrats on solving this (by yourself!) and welcome to our AndroidForums! :)

    I've also moved your thread to our all-things-root sub-forums since it best fits in there.

    Cheers!
     
    scotty85 likes this.
  6. scotty85

    scotty85 Extreme Android User

    hi iquadri! glad you figured out your prollems,sorry for the late replys :eek: sounds like there was issue installing the boot image,but you might post your steps for fixing your issue so it can benefit other folks seeing this thread with similar prollems.

    id also consider to be come s off and superCID,as it will make rom flashing and recovery from soft bricks considerably easier since the phone wont be doing any security checks(meaning the ruus you tried to run would have worked)

    http://androidforums.com/desire-hd-...-s-off-simunlock-supercid-inspire-4g-dhd.html
     
    scary alien likes this.
  7. dennismil

    dennismil Lurker

    Hey

    I second what scotty85 suggested, if you could tell us how you got it working in the end?

    I'm in the process of doing the same upgrade, i've unlocked the bootloader, but that's as much as i've done so far, and it's already taken me half a day going through all the million different pages with info regarding this :), and still quite unsure how to proceed from here due to conflicting info on different threads and sites..

    Please, maybe, yes?

    Thanks,
    D
     
    D-U-R-X and scary alien like this.
  8. scotty85

    scotty85 Extreme Android User

    is your phone booting and working? if so follow this guide: http://androidforums.com/desire-hd-...-s-off-simunlock-supercid-inspire-4g-dhd.html

    if not describe for us the state its in,and how it got that way. im sure we can get you sorted :)
     
    D-U-R-X and scary alien like this.
  9. dennismil

    dennismil Lurker

    Hey Scotty

    Much appreciated!

    Phone unlocked through htcdev, otherwise working fine.

    I started going through your instructions. I'm currently struggling with unlisted device after booting to bootloader. The problem seems to be a missing "Android 1.0" device driver. It doesn't seem to be in the HTCDriver3.0.0.007.exe package. Also tried installing Google Android USB driver from the SDK i downloaded yesterday, tried that on a laptop and it didn't help. Now on desktop (both W7), but same problem.

    Commencing search operation id=Android 1.0 driver :), although if you have a clue, i dont mind it.

    -D
     
    scary alien likes this.
  10. dennismil

    dennismil Lurker

    I found info on how to get the Android 1.0 driver installed, for example here:
    http://forum.xda-developers.com/showthread.php?t=737728
    Had to edit the Google USB driver (in the adt sdk under sdk\extras\google\usb_driver\android_winusb.inf) to include my device id (USB\VID_0BB4&PID_0C94) and then update the Android 1.0 driver (after which is shows as "Android ADB Interface").

    But now i realised, from your instructions to someone else that maybe the device isn't supposed to be found by adb while device is in the bootloader? Cause i noticed "fastboot devices" finds the device, but not "adb devices", regarless if i'm in HBOOT USB PLUG -mode or FASTBOOT USB -mode.

    So in other words - as funny as it sounds - i'm still unaware whether i have a problem or not?

    -D
     
  11. dennismil

    dennismil Lurker

    Hahah, i feel like i'm talking to myself (guess it's useful documentation though), but i found out that adb should not work while device is in the bootloader. So guess i'm good to go. Still it seems a bit weird that a device missing a driver appears in Windows? Only when selecting BOOTLOADER from the bootloader screen though (= HBOOT USB PLUG -mode).
     
    scary alien likes this.
  12. dennismil

    dennismil Lurker

    Alright! Got it rooted. Thanks for that part at this point! (Thanked you in the thread as well of course).

    Only thing i'm wondering now after further reading the instructions is that do i need to make a gold sd card - how do i know if i do? It seems to be optional in your instructions?
     
    D-U-R-X and scary alien like this.
  13. scotty85

    scotty85 Extreme Android User

    sorry for the delayed reply,ive been crawling around under/on a 37 foot trailer with a paint roller for most of the day :eek:

    correct,adb will not work in fastboot,only in the booted OS,or some custom recoveries. in fastboot,one uses fastboot commands.

    so im asuming youve just completed the htcdev unlock,installed recovery and superuser,and are still s on?

    if you wish to s-off,you will need in install an older expliotable radio via the "firmware.zip" file downloaded in the s off thread. if your dhd happens to have a CID that is compatible with this firmware.zip,then you can skip the goldcard step. otherwise you will have to make one as there is no way to change CID while s on,and you have to flash that firmware package for the s off exploit to work

    unfortunately,you wont really know for sure the goldcard worked until you try and flash the downgrade firmware.zip. when youre going thru the guide,follow along in my codebox and make sure that you get the same responses. if you do,more than likely the goldcard creation will be successful and the downgrade will work without issue.

    if you have further questions,just holler in that thread :)
     
    D-U-R-X, scary alien and dennismil like this.
  14. dennismil

    dennismil Lurker

    No problemo at all. Guess what, all went well! Did the goldcard also. So huge thank you again!

    Now, this might seem like a stupid question at this point, but i'm really not sure after all that's been done what's the process to install a new rom? Do i just go for example:
    1) boot manager -> recovery
    2) wipe cache + dalvik cache
    3) install any rom zip from sdcard?
     
    scary alien likes this.
  15. scotty85

    scotty85 Extreme Android User

    just to make sure i understand correctly,the process was successful and you are s off,correct?

    if so,then one small addition to your list:
    also,always make sure you make a nandroid backup of any good working rom. so i guesss actually it should look more like this:

     
    D-U-R-X, scary alien and dennismil like this.
  16. dennismil

    dennismil Lurker

    Ha! I'm very happy currently! Seems to work like a charm. Many many thanks to you! Your instructions and support were invaluable, I'm very grateful. Thank you!
     
    D-U-R-X, scotty85 and scary alien like this.
  17. scotty85

    scotty85 Extreme Android User

    your welcome. glad to help. :)
     
    D-U-R-X and scary alien like this.

HTC Desire HD Forum

The HTC Desire HD release date was October 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 768GB RAM, Snapdragon S2 processor, and 1230mAh battery.

October 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...