1. Download our Official Android App: Forums for Android!

Root HTC desire not booting ( only bootloader available) version-main: 3.14.405.1

Discussion in 'Android Devices' started by shab1h, Sep 11, 2011.

  1. shab1h

    shab1h Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    6
    Joined:
    Sep 11, 2011

    Sep 11, 2011
    6
    0
    25
    Phone in discussion
    BRAVO PVT1 SHIP S-ON
    HBOOT-1.02.0001
    MICROP-031d
    TOUCH PANEL-SYNT0101
    RADIO-5.17.05.23
    Jul 22 2011, 16:19:16


    I have read several forum but without any luck. Maybe you guys can help me out here

    Basically this phone keeps on rebooting when you start it up and screen also keeps flickering only displaying htc logo


    This phone is NOT Rooted and doesnot have any recovery image.

    Once you go in to bootloader I do get access to fastboot commands and here are a few stats

    C:\android-sdk-windows\tools>fastboot getvar al
    (bootloader) version: 0.5
    (bootloader) version-bootloader: 1.02.0001
    (bootloader) version-baseband: 5.17.05.23
    (bootloader) version-cpld: None
    (bootloader) version-microp: 031d
    (bootloader) version-main: 3.14.405.1
    (bootloader) serialno: HT04APL01991
    (bootloader) imei: 357841032175024
    (bootloader) product: bravo
    (bootloader) platform: HBOOT-8x50
    (bootloader) modelid: PB9920000
    (bootloader) cidnum: HTC__001
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 4162mV
    (bootloader) partition-layout: Generic
    (bootloader) security: on
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    (bootloader) commitno-bootloader: a7cdbe26
    (bootloader) hbootpreupdate: 11
    all: Done!
    finished. total time: 0.024s

    ..........

    C:\android-sdk-windows\tools>fastboot oem boot
    ...
    (bootloader) setup_tag addr=0xA0000100 cmdline add=0x8E0800C4
    (bootloader) TAG:Ramdisk OK
    (bootloader) TAG:smi ok, size = 0
    (bootloader) TAG:hwid 0x0
    (bootloader) TAG:skuid 0x21F04
    (bootloader) TAG:hero panel = 0x0
    (bootloader) TAG:engineerid = 0x0
    (bootloader) MCP dual-die
    (bootloader) MCP dual-die
    (bootloader) TAG:mono-die = 0x0
    (bootloader) Device CID is not super CID
    (bootloader) CID is HTC__001
    (bootloader) setting->cid::HTC__001
    (bootloader) serial number: HT04APL01991
    (bootloader) commandline from head: no_console_suspend=1
    (bootloader) command line length =453
    (bootloader) active commandline: board_bravo.disable_uart3=0 board_bravo.
    (bootloader) usb_h2w_sw=0 board_bravo.disable_sdcard=0 diag.enabled=0 boa
    (bootloader) rd_bravo.debug_uart=0 smisize=0 userdata_sel=0 androidboot.e
    (bootloader) mmc=false androidboot.baseband=5.17.05.23 androidboot.cid=H
    (bootloader) TC__001 androidboot.carrier=HTC-WWE androidboot.mid=PB992000
    (bootloader) 0 androidboot.keycaps=qwerty androidboot.mode=normal android
    (bootloader) boot.serialno=HT04APL01991 androidboot.bootloader=1.02.0001
    (bootloader) zygote_oneshot=off kmemleak=off no_console_suspend=1
    (bootloader) aARM_Partion[0].name=misc
    (bootloader) aARM_Partion[1].name=recovery
    (bootloader) aARM_Partion[2].name=boot
    (bootloader) aARM_Partion[3].name=system
    (bootloader) aARM_Partion[4].name=cache
    (bootloader) aARM_Partion[5].name=userdata
    (bootloader) partition number=6
    (bootloader) Valid partition num=6
    (bootloader) jump_to_kernel: machine_id(2457), tags_addr(0x20000100), ker
    (bootloader) nel_addr(0x20008000)
    (bootloader) -------------------hboot boot time:13451 msec
    FAILED (status read failed (Too many links))
    finished. total time: 20.474s

    I have tried to load different stock rom with no success all giving error 144 bootloader version not being correct. I've even tried goldcard and loading stock images from sdcard but with no success. Even in bootloader the screen keeps flickering

    I'd be really thankful if someone could help me out here

    Thanks
     

    Advertisement

  2. Rastaman-FB

    Rastaman-FB Extreme Android User
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    you cannot use other ruu's as this is the highest one and it will not let you downgrade

    what did you do to cause this. you have to manually flash this sw version as its a dev build?
    was it working on this build before or did this occur after a flash?
     
  3. shab1h

    shab1h Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    6
    Joined:
    Sep 11, 2011

    Sep 11, 2011
    6
    0
    25
    Please let me know how can I manually flash this sw version, I am unaware of the history of the phone as I got it in a joblot from someone so I can fix it

    Thanks
     
  4. Rastaman-FB

    Rastaman-FB Extreme Android User
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    download the 3.13.x.x firmware from the htcdev website
    HTCdev - HTC Kernel Source Code and Binaries
    top link.
    in that file there is the ruu and the files needed after flash is complete

    be warned that this might be bootlooping due to hardware issues
     
  5. shab1h

    shab1h Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    6
    Joined:
    Sep 11, 2011

    Sep 11, 2011
    6
    0
    25
    Can you please share with me the full instructions and steps required to perform this as I cant seem to find 3.13.x.x firmware from the link above

    Thanks
     
  6. Rastaman-FB

    Rastaman-FB Extreme Android User
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    its the top link
    HTC Desire Android 2.3 Upgrade
    click it, download it, boot device to hboot run the ruu, connect device
     
  7. shab1h

    shab1h Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    6
    Joined:
    Sep 11, 2011

    Sep 11, 2011
    6
    0
    25
    I have tried it but its giving image error and a black screen with exclamation marks on all four corners. Is there anyway to downgrade or root this kind of phone

    Thanks
     
  8. Rastaman-FB

    Rastaman-FB Extreme Android User
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    no, thats a radio brick
    you bought it damaged, its not repairable unless you have advanced equipment from htc.

    you could send it to htc but theyll probably charge you

    the risk you take buying a joblot mate, sorry
     
  9. shab1h

    shab1h Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    6
    Joined:
    Sep 11, 2011

    Sep 11, 2011
    6
    0
    25
    Ok thanks anyway, I'm not really sure if you know anything about hardware but would a motherboard change or a particular part replacement fix this issue?? thanks
     
  10. Rastaman-FB

    Rastaman-FB Extreme Android User
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    I dont know too much about hardware but i would imagine a motherbord change would fix this as it would be new nand and radio stack as afaik thats built into the mobo of the desire.
     
Tags:

Share This Page

Loading...