1. Download our Official Android App: Forums for Android!

Support HTC Desire S - Calls straight to voicemail

Discussion in 'Android Devices' started by Libellule, Jul 22, 2011.

  1. Libellule

    Libellule Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 22, 2011

    Jul 22, 2011
    13
    1
    16
    Suffolk, UK
    Hi

    I have recently got a new HTC Desire S on O2.

    Several friends commented that when they tried to call me, they were diverted directly to voicemail - these were at times I knew my phone was on and had signal.

    I would like to point out at this stage I am by no means some technical phone wizard, but just wanted to share my experience for others who may be seeking an answer to the same issue...

    After trawling through forums to see why this could be, I thought I would share what I have found out following a massive internet search, some self-testing of the phone and subsequent calls to HTC customer service.

    It appears when you are connected to a 2G network (2G network/GPRS will be shown by a G and arrows next to the signal icon in the top right hand corner) and have your mobile internet connection turned on, and it is in use (or apps are using it in the background), you WILL NOT be able to receive incoming calls.

    I have tested this by switching off the mobile internet connection, and then calling my mobile. No problems - rings straight away. :)

    Then I have switched on the mobile internet connection (it was showing G i.e 2g connection as I live in a non 3G coverage area), and then started using the internet, and redialled my mobile - the call went directly to voicemail.:mad:

    I tried these tests several times, ensuring the phone had adequate signal each time, with the same results.

    I called HTC and they went through all the usual - changing settings, saying I needed a new SIM card (I am using a new SIM card already). I asked to speak to someone technical, who could explain the problem, as it was clearly a phone issue. Eventually I spoke to someone who admitted that you can not get voicecalls when using the Desire S internet on a 2G connection, the voicecall is apparently unable to interrupt the internet connection, hence why the call goes directly to voicemail.

    I have tested this with 3G and HDPSA connections (shown by 3G and arrows, and H and arrows, respectively, and there appears to be no issue - calls come through even if you were using the internet at the time. I can not comment for EDGE connections (E and arrows) though - as I rarely get this type of connection.

    Hoping this helps !
     

    Advertisement

    notebook likes this.
  2. notebook

    notebook Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    732
    Joined:
    Jun 10, 2011

    Jun 10, 2011
    732
    169
    93
    Much appreciated. This issue has cropped up here before and your investigation, along with the response from HTC, would appear to be definitive.

    It does seem stupid that HTC have sacrificed the primary purpose of a phone for the sake of an internet connection!
     
  3. rodrigt

    rodrigt Newbie
    Rank:
    None
    Points:
    16
    Posts:
    27
    Joined:
    Apr 17, 2011

    Apr 17, 2011
    27
    2
    16
    Thanks for your insights, I have the same problem of all my calls going directly into voice mail. Could you please say more about the necessary settings to make sure my LG GT540 phone is set to G2? In the US I use AT&T's pre-paid service (calls only, no data plan) and the phone is "open" (not an ATT phone).

    What I have tried so far is turning off Wi-Fi and invoked Airplane Mode but the calls still go directly to voice mail. Any suggestions?
     
  4. notebook

    notebook Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    732
    Joined:
    Jun 10, 2011

    Jun 10, 2011
    732
    169
    93
    @rodrigt

    Menu > Settings > Wireless & networks > Mobile network settings > Network Mode > 'GSM only' to set it to 2G. WCDMA is 3G only.
     
    rodrigt likes this.
  5. rodrigt

    rodrigt Newbie
    Rank:
    None
    Points:
    16
    Posts:
    27
    Joined:
    Apr 17, 2011

    Apr 17, 2011
    27
    2
    16
    Thanks! When I get to "Mobile network settings" it won't let me enter (that line lights up acknowledging my selection but nothing happens). Right above "Mobile network" states it is disabled but it also won't let me enter.

    Could there be any other setting that is precluding mobile networks? Might I need a replacement SIM card from ATT? (My current card is probably 5 or 6 years old.)

    (PS- Otherwise the phone works fine for calling, WiFi, Apps, GPS, etc.)
     
  6. notebook

    notebook Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    732
    Joined:
    Jun 10, 2011

    Jun 10, 2011
    732
    169
    93
    5-6 years old is pretty old for a SIM card - it'd be a good idea to request a new one anyway.

    Even if you don't have a data plan, theoretically, you should still be able to use 3G to make calls on, but this depends on what your network provider allows you to do.

    'Network mode' should be all that you need to change between 2-3G for voice calls.

    The original poster suggested the problem happens when a call is received at the same time mobile data is being used. As your phone isn't set-up to do this (use mobile data), your problem may have a different cause.

    Have you checked your voicemail settings? Menu > Settings > Call > Voicemail service should be set to 'My Carrier'. Voicemail settings should be the default number of your carrier. Call forwarding settings are usually all disabled by default.

    When you ask for a new SIM I'd flag up the issue with them as it might be something which they can fix their end.
     
    rodrigt likes this.
  7. rodrigt

    rodrigt Newbie
    Rank:
    None
    Points:
    16
    Posts:
    27
    Joined:
    Apr 17, 2011

    Apr 17, 2011
    27
    2
    16
    Thank you! Being entirely new to smart phones I need to revamp the symptoms I've described above because they were caused by my having turned off WiFi and set to Airplane mode.

    Menu > Settings > Wireless & networks > Mobile network settings > Network mode provides only 3 options: Enable, Disable and Always Ask but NOT the option to set for GSM only.

    Menu > Settings > Call > Voicemail was already set to 'My Carrier'.

    Thanks to your insights my next step is to get a new card from AT&T. (PS- This will take me a few days because I am currently travelling and I look forward to reporting on results.)
     
  8. notebook

    notebook Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    732
    Joined:
    Jun 10, 2011

    Jun 10, 2011
    732
    169
    93
    Turning off your wifi shouldn't affect your call connections unless you're able to utilise the Desire S UMA technology which boosts your phone's signal when using wifi. Menu > Settings > Call > Use Internet calling.

    The difference in your Network mode options and mine is probably due to the software version on your phone being unique to your carrier/country. It may be worth checking to see if you have the latest version - Menu > Settings > About phone > Software updates > Check now - for the manual check. (By default, Scheduled check should be checked.)
     
    rodrigt likes this.
  9. rodrigt

    rodrigt Newbie
    Rank:
    None
    Points:
    16
    Posts:
    27
    Joined:
    Apr 17, 2011

    Apr 17, 2011
    27
    2
    16
    Thanks for mentioning the possibility that differences in carrier/country software may be causing what options appear in the various menu paths, indeed that seems to be the case. The very recent time I hooked up the phone to my PC nothing came up when I invoked updates. What my phone shows at Menu>Settings>About is:
    -- Firmware version 2.1-update 1
    -- Kernel version 2.6.29
    --Software version GT540-V20c-DEC-15-2010

    Regarding Menu > Settings > Call > Use Internet calling, beyond >Call my phone does not offer the Internet calling as an option. The mention of UMA technology went right over my head and probably best we leave it that way :) - Thanks again!
     
  10. David4902

    David4902 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Nov 23, 2016

    Nov 23, 2016
    1
    0
    15
    Male
    I had the same problem . going through Settings I noticed that Do Not Disturb was On. I turned it off and could receive calls again .
     
Tags:

Share This Page

Loading...