1. Are you ready for the Galaxy S20? Here is everything we know so far!

HTC email client not sending on WIFI

Discussion in 'Android Devices' started by john7760, May 23, 2010.

  1. john7760

    john7760 Lurker
    Thread Starter

    Anyone else having an issue where when connected to wifi and trying to reply to an email it gives a message failed error using the HTC mail client? Once I disable wifi it sends with no problem.

    1. Download the Forums for Android™ app!


  2. nightfishing

    nightfishing Android Enthusiast

    There are various things that do not seem to work with wifi enabled. sending mail from certain email providers is one.
  3. justinandroid

    justinandroid Newbie

    Is there a fix for this? Not the end of the world to turn off wifi and send, but seems like it should work either way??
  4. Bundy

    Bundy Android Enthusiast

    I would think it depends on the network you are connected to and what SMTP server you're using. A lot of ISPs don't allow relaying, so you will get failure errors when trying to send from their ntework through another SMTP server.
  5. Kevin_C

    Kevin_C Lurker

    I had this problem at my house where I am still on AT&T DSL. My default EMAIL server is not AT&T and they will NOT let you send unsecured SMTP (port 110) on their network. My workaround is using Google as my SMTP host.

  6. gobluejd

    gobluejd GOBLUE!

    I could not receive email via Google or Exchange. I had my lT company look into and they resolved it. I asked him to email me what he did. Here is his response:

    "Because you were in a domain setting I had to create an internal dns entry that corresponded with your external mail ip address. This way when you were inside the network you would stay inside the network to send an receive mail."

    Don't ask what all that means, but it works now.

    Now if only HTC can fix the FWD'ing as attachment issue!
  7. tgi007

    tgi007 Lurker

    Just for completeness, in case future visitors to this thread get confused, the SMTP port number is 25 (Email message sending).

    Port 110 is POP3 (Email message retrieval).

  8. Jakaro

    Jakaro Android Enthusiast

    Seems to be a lot of issues with Wi-Fi. Can't stream pandora, last.fm or slacker for more than one song, when the phone goes to sleep it shuts down the music stream. Ive also had problems connecting to the market on Wi-Fi. Seems to be an issue and i have Wi-Fi to never sleep when on.
  9. tgi007

    tgi007 Lurker

    For what it's worth, I've seen none of the symptoms described here. I use WiFi at home with a Linksys WRT160N Wireless Router behind a Netopia/Cayman 3346 DSL Modem/Router/Firewall (I subscribe to BellSouth/AT&T DSL 6 Mb/s). I've experimented with trying various things with the WiFi off, seeing how it performs with EVDO (so-called "3G" mode; no "4G"/WiMAX in my area (Ft. Lauderdale, FL, US)), then turning on WiFi to compare performance. Other than speed differences, I've experienced NO differences in functionality. Things work (or don't) the same using either connectivity (other than access to nodes on my LAN that are inaccessible from outside the firewall).

    The port-blocking for SMTP (port 25) by BellSouth (now AT&T) has been going on for several years, so I use SSL authentication/encryption which uses port 995 by default. This port is *not* blocked, so it's all happy.

    I'm on a Sprint/HTC EVO with the OTA update applied to 1.47.651.1

    BTW: I strongly recommend setting this up on a mobile client, because, by default, all SMTP (port 25) traffic is "in the clear". Anyone packet-sniffing can read your (supposedly) private Email you're sending.

    Similarly, if you're using POP3 (port 110) for Email retrieval, then (most likely) all of your retrieved Email is also open to be read by anyone snooping on the same network as your mobile device (WiFi or office LAN).
  10. l.a.rossmann

    l.a.rossmann Newbie

    I still can't send email over wifi with the Incredible without using maildroid or K-9, each of which have severe defeciencies when it comes to selecting/copying material out from the body of an email.
  11. gobluejd

    gobluejd GOBLUE!

    I had same problem but only on my office WiFi. It had to do with exchange and how our internal address and DNS outside worked. Our IS company that I work with fixed it. Not sure that helps but I could not receive but could send. Opposite of your issue but it may be related. I am on vacation until Tuesday so I can not be any more specific. If neededi can find more out then.
  12. red wun

    red wun Lurker

    I have the same issues .when using htc inspire email client I have to either check or unchecked require authentication password .im ising time warner t wcny.rr.com email I like to use wi-fi because it uses up plus my data plan .I can receive emails either way wi-fi or to the network no problem .it's when I go on wifi I cannot send my email unless i change settings in email seup check or unchecj require authentication when I go back off wifi I'll have to change it back to the other settings so I can send em ails again .it's a real pain in the a**. Htc/droid needs to updat email interface so I can have a setting for each wifi and network both . until htc android ficx this in software update . we will have a problem that's the bottom line. They need to fix software on the phone .

HTC Droid Incredible Forum

The HTC Droid Incredible release date was April 2010. Features and Specs include a 3.7" inch screen, 8MP camera, Snapdragon S1 processor, and 1300mAh battery.

April 2010
Release Date

Share This Page