1. Check out our companion app, Forums for Android! Download from Google Play

Support HTC EVO 4G SD Card Error

Discussion in 'Android Devices' started by hagendas, Aug 25, 2012.

  1. hagendas

    hagendas New Member
    Thread Starter

    Jun 6, 2010
    I own an HTC EVO 4G that's telling me the SD card isn't mounted. Attempts to mount it give me a recommendation to reformat the card.

    Model: HTC EVO 4G
    Carrier: Sprint
    Android version: 2.3.5
    Rooted?: No
    Power: battery approximately 75%, and on AC power
    Networking status at time of issue: wi-fi on, 3G off, bluetooth off
    Background data: Enabled
    Activity: Browsing Google play, installing apps, trying them, and uninstalling them.
    Free space on phone: Approximately 150MB
    SD card size: 8GB
    SD card brand: Samsung
    SD card class: 2
    Free space on SD card: Approximately 4GB

    Troubleshooting Notes

    • I've browsed to running applications and Force Stopped HTC Sense and hit Home with no change in symptoms.
    • I've rebooted the phone with no change in symptoms.
    • I've removed and reinserted the SD card with no change in symptoms.
    • I've installed the SD card into another phone and the SD card was recognized with no mounting messages.
    • I've installed the SD card into a memory card adapter and installed it into my laptop (Windows XP, SP-3) and the SD card was recognized with no errors. I ran Properties > Tools > Error Checking and no errors were found.
    Years ago I had the same problem that was solved with no 3rd party software and no SD card reformatting. I'm sorry to say I don't remember what the solution was. I seem to recall it had something to do with deleting or modifying one of the files on the SD Card.

    Does anyone have any recommendations that haven't been mentioned here already?

    I'm confident the SD card doesn't require reformatting. Despite the popularity of suggesting spontaneous failure, "sometimes they just go bad" isn't troubleshooting, it's half-ass guessing. Besides, it's been tested in another phone/laptop so we can rule that out.

    I've read several similar threads on this and other forums, however the one thing they all have in common is "shot-in-the-dark" troubleshooting, no genuine recommendations based on listed symptoms. If you've got some genuine help to give, fire away!


  2. Mikestony

    Mikestony ~30% Carbon Black ±

    Sep 10, 2010
    N/W Indiana
    Very nice info and troubleshooting!
    Do you have another card you could try in your Evo to see if it will read it?
    I'm no expert on sd card issues, but what if you took card out, copied contents to computer, formatted it with this, and transfer contents back and reinsert into phone.

    Edit: or, a simple, yet sometimes effective solution...take some "air in a can" and blow out sd card port.

    Edit again: or see this
    tube517 likes this.
  3. hagendas

    hagendas New Member
    Thread Starter

    Jun 6, 2010
    I do have another SD card from a second phone, but I didn't want to risk potentially damaging a second SD card.

    I did copy the contents of the allegedly damaged SD card to my laptop in order to back up all the data. I didn't try blowing out the SD card port. I examined the port (under the internal battery) and there was no foreign particulate/dust.

    I did get the error to go away. I don't know the rationale for why this worked, but it did:

    • I backed up my SD card to my laptop
    • I erased everything except for the secure android folder (I've read somewhere that that particular directory is somehow important)
    • I reinserted the SD card and it worked fine
    • I then copied the original contents back onto the SD card
    • I reinserted the SD card and it continued to work fine.
    Since I don't know why it stopped giving me the error, I can't say with any degree of certainty that it won't come back again.
    Mikestony likes this.

Share This Page