1. Download our Official Android App: Forums for Android!

Support HTC Evo not charging. Nothing.

Discussion in 'Android Devices' started by dudeitstrey, Apr 16, 2011.

  1. dudeitstrey

    dudeitstrey Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 16, 2011

    Apr 16, 2011
    3
    0
    5
    Lafayette, LA
    Okay, I know there are a bunch of threads about this, but I have found that none of them are exactly what's wrong with mine.

    Last week I had a lot of trouble getting my phone to charge. While it was plugged in the battery was still draining and would give the message "Current is too weak for power consumption of the phone" or something along those lines.

    I left it on the charger all night and when I woke up it was dead. Dead, dead. Plugged in no LED light would come on, not even flashing. Couldn't turn the phone on. I searched forums for answers to my problem and found that maybe the battery had drained too much.

    So I went to Sprint and they ordered me a new battery. Got it yesterday and only got to charge it a little before work. By the time I got home it was nearly dead. So I plugged it in and I'm still having the same problem. It said the same current is too weak message and didn't charge at all.

    So I went back to Sprint and they are replacing my Evo for free, but I would still like to know what the hell is wrong with it. I left it on the charger while I was at work today. When I left it had the flashing LED light. I get home, and nothing.

    It's plugged in right now and there's no LED light, can't turn it on, nada.

    Anyone else ever come across this problem or know what's causing it?
    I figure it's the charging port, but when the battery was still alive the phone said it was charging, but the "Current is too weak" message said otherwise.

    What gives?:thinking:
     

    Advertisement

  2. Evo 5oh

    Evo 5oh Android Enthusiast
    Rank:
    None
    Points:
    88
    Posts:
    530
    Joined:
    Dec 1, 2010

    Dec 1, 2010
    530
    39
    88
    I think its the port loose or something ....I never had the problem though
     
  3. tube517

    tube517 Android Expert
    Rank:
     #35
    Points:
    693
    Posts:
    3,963
    Joined:
    Jun 7, 2010

    Jun 7, 2010
    3,963
    1,994
    693
    Male
    USA
    One of the common issues with the EVO is a defective USB port, which it sounds like is what happened to yours. At least you got it replaced.
     
  4. dudeitstrey

    dudeitstrey Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 16, 2011

    Apr 16, 2011
    3
    0
    5
    Lafayette, LA
    Well, even though it's been nearly 3 months, just for anyone who stumbles across this with the same problem, the actual problem was my charger that came with the phone. For some reason it had stopped charging it at all, yet it still allowed data transfer to my SD card. When plugged into the wall, it would indicate that it is charging but infact would not, and I'm guessing that somehow fried the battery.

    If you have this same problem, for me when I plug it into my computer via USB it gives me a pop-up stating "This device will preform faster in a USB 2.0 port" or something like that. If you get this warning, try getting a new charger or try someone else's before going through the same trouble I went through.
     
Tags:

Share This Page

Loading...