1. Check out our app, Forums for Android! Download and leave feedback here!

Support HTC Legend fails to connect to Wi-Fi

Discussion in 'Android Devices' started by plugandplay, Apr 9, 2010.

  1. plugandplay

    plugandplay New Member
    Thread Starter
    5

    Apr 9, 2010
    1
    0
    5
    I have a Wi-Fi router D-Link Dir-615.
    My HTC Legend recognize the router but after enterring the key to unlock the connection, it fails to connect. 2 PC are connected and the HTC touch of my wife too, and all three work fine. Somebody can help me, Thank you in advance
     

    Advertisement

  2. matthewprince

    matthewprince Member
    5

    Apr 8, 2010
    8
    0
    5
    the wifi signal on the legend is applaing it might just be the strength is crap
     
  3. benner

    benner Well-Known Member
    16

    Oct 22, 2009
    93
    2
    16
    same for me. i just ditched my galaxy for the legend and the wifi is not nearly as strong. in any case, both drop out for no reason from time to time. probably an android thing. sucks.
     
  4. GeoffBot

    GeoffBot Well-Known Member
    63

    Apr 19, 2010
    100
    37
    63
    Male
    ISP Sales Account Manager
    Brighton, UK
    Mine works just fine
     
  5. Bootsock

    Bootsock Guest

    fine here using netgear kit...

    Sent from my HTC Legend using Tapatalk
     
  6. Bootsock

    Bootsock Guest

    Also, for reference I've found WiFi analyzer from http://a.farproc.com/wifi-analyzer to be quite a handy little free app for finding a better channel if you are having connection issues as its quite common to find loads of local routers competing for the same channels.

    Sent from my HTC Legend using Tapatalk
     
  7. tigerdriver

    tigerdriver New Member
    5

    Apr 16, 2010
    4
    0
    5
    Pie sales
    Norwich Uk
    mine works on wifi round the house at least as well as my ipod touch, probably better
     
  8. Scaramaus

    Scaramaus New Member
    5

    Mar 12, 2010
    2
    0
    5
    Hi all,
    I'm having the same problem. It was fine before, but I haven't been able to connect all day. I used to use We-Fi and Locale, but both have been de-installed. I also use Juicedefender, but that one is disabled atm.
    I can see my wifi-router, with varying strength. Within settings I can see what is happening as follows: "Obtaining IP address from..." followed by "Unsuccesful"
    Anyone have an idea? Is it the phone or the router? My wife's Tattoo works fine, as do the connected laptops.

    Thanks
    Scaramaus
     
  9. Frostation

    Frostation Active Member
    16

    Apr 1, 2010
    41
    3
    16
    Student
    Brentwood, UK
    Easy solution that works for me everytime is to restart your router, not your phone because that does not work. This is just an idea that works for me so dont complain!
     
  10. Scaramaus

    Scaramaus New Member
    5

    Mar 12, 2010
    2
    0
    5
    Thanks for the tip, Frostation. Unfortunatly I tried that a few times. :(
     
  11. wdmalik

    wdmalik Active Member
    16

    May 2, 2010
    35
    1
    16
    Maintenance Engineer
    I will agree, my laptop connects fine with the router by 'legend' has always problems, anyone working on any fix
     
  12. erk

    erk Member
    5

    May 3, 2010
    7
    0
    5
    I'm experiencing problems as well. I only have 2g coverage here so wifi needs to work, and it just doesn't. My previous Nokia N95, N900, 5800, and E51 all worked. It can't be that hard to make it connect can it?
     
  13. cleverbeat

    cleverbeat New Member
    5

    May 15, 2010
    1
    0
    5
    it has weak wifi receiver
     
  14. rayhoo

    rayhoo New Member
    5

    Aug 18, 2010
    2
    0
    5
    Guys, can you indicate the following info? I'm have no this issue.
    1. WiFi AP brand and model names?
    2. Legend Rom code version?
    3. Any more detail info such as reproduce steps?
     
  15. 3t3rnity

    3t3rnity New Member
    5

    Aug 26, 2010
    1
    0
    5
    Man was I hyped to buy this phone, until I heard about these wifi and bad signal problems. I heard different things about how some of the devices are faulty, or that the receiver is just bad by default, or that maybe it's a software problem etc...

    So after so much time could anyone explain what exactly is the problem, if it's fixable, if it is, when it's gonna be fixed.

    thanks
     
  16. myphonedrivesmenuts

    5

    Oct 27, 2010
    7
    0
    5
    This is not going to help anybody, my legend has never picked up wifi apart from 2-3 times even when sat next to the router. I have tested it against other machines. Have a sneaky feeling my phones a dud.
     
  17. Dr T.

    Dr T. New Member
    5

    Feb 5, 2011
    1
    0
    5
    My Legends wifi have seemed patchy since i got i a week ago too.

    What I have noticed is that it depends on how you hold the phone. Leaving the upper part of the phone free from my hand gives me way better reception than when I hold a finger or even my whole hand over the top of the phone.

    I would be great if some of you could try this out and see if you get the same result.
     
  18. mspayne

    mspayne Member
    5

    Jan 27, 2011
    5
    0
    5
    Australia
    I had a similar problem to OP but found that the Legend connected better after the router had been reset. However after a few hours it would not connect and I had to reset the router again. Laptops and other phones worked fine.

    There are many networks in my area so I thought maybe better security would help. I already had WPA2 but I added MAC filtering and disabled SSID broadcast. This helped a lot! Now my Legend connects without any problems. It also has quite good signal around the house, though signal strength was not really the problem.

    Details:
    -Billion 7404VGPX router
    -standard Android 2.1-update1 Build 2.10.178
    -also same experience with my gf's Legend running 2.2
     
Tags:

Share This Page

Loading...