1. Download our Official Android App: Forums for Android!

Support HTC One M8 stuck in recovery mode

Discussion in 'Android Devices' started by Montejuli, Jan 22, 2016.

  1. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    Hi everyone. Im new here, i created an account to see if you guys could help me solving a problem. The thing is that today i finished downloading the new android marshmallow update, but when it was 83% the download failed and now its stuck in recovery mode (the one with black screen right?). I have an unlocked stock htc one m8 non rooted. I bought it in the US like 5 months ago and brought it here to Argentina where i live. Every time i turn on the device and after all the android screens show up, a red question mark appears for less than a second and then it goes in recovery mode. I don't know what is going on so i'll need your help. Let me know if theres something you guys can do. Sorry for my bad english and thank you in advice! Cheers.
     

    Advertisement

    varr m likes this.
  2. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    Here's what the Android Recovery screen shows:

    Supported API: 3
    handle_cota_install: install cwpkg to /cache/data/cwtemp/cwpkg.zip
    handle_cota_install: install cwprop to /cache/data/cwtemp/cw.prop
    Write host_mode success
    handle_cota_install: No CW files. Skip cw installation
     
  3. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
  4. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    please?????
     
  5. today

    today Android Expert
    Rank:
     #101
    Points:
    123
    Posts:
    948
    Joined:
    Mar 30, 2010

    Mar 30, 2010
    948
    383
    123
    Male
    spanaway washington
    Not an expert at all but have you tried long pressing the power button?
     
  6. Mamafrog

    Mamafrog Lurker
    Rank:
    None
    Points:
    15
    Posts:
    2
    Joined:
    Jan 24, 2016

    Jan 24, 2016
    2
    0
    15
    Female
    My husbands phone is doing the same thing after Marshmallow. He got his phone from Hong Kong. If you get any slution let me know please:)
     
  7. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    Hi, i managed to install Marshmallow to my phone downloading the Ruu through this page http://www.htc.com/us/support/rom-downloads.html . It's from Htc's official page, so don't be scared to download the Ruu. Is your husband's phone unlocked? If so, scroll down till' you find the Unlocked/Developer list and click on the Htc one m8 link. Installing the ruu is very simple, im not an expert at all and i managed to do it. Justo follow the instalation steps and Marshmallow will install on the phone. As simple as that. If you need more help, there is a guide that can help you through the installation next to the ruu download link. Let me know if you need a hand. Good Luck!
     
    varr m likes this.
  8. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    Yes i did but it was more complicated lol. I downloaded and installed the Ruu from htc's official page. Thanks for answering!
     
    varr m likes this.
  9. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    Yeah but these RUUs will only install successfully if the phone mamafrog is talking about is from one of the US carriers. Doubtful if it was purchased in HK.
     
  10. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    Oh i didn't know. You are right! Is there any way to download HK's Ruus? HK's Htc oficial page maybe?
     
  11. varr m

    varr m Lurker
    Rank:
    None
    Points:
    15
    Posts:
    3
    Joined:
    Jan 28, 2016

    Jan 28, 2016
    3
    0
    15
    Male
    hi... i tried to follow the step on the htc site but my computer is not recognizing my device....
    can anyone help??
     
  12. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    Hi varr m! My pc didn't recognize it either. So you just select "reboot to bootloader" (i think it says something like that) then, during the bootloader select fastboot and then plug your htc to your pc. It should say "usb fastboot" and now your pc should recgnoize it. Here's a guide in case you didn't understand me. Im not from the Usa. Here's the link: http://www.htc1guru.com/wp-content/uploads/2013/files/RUU_Install_ReadMe.doc
     
    varr m likes this.
  13. varr m

    varr m Lurker
    Rank:
    None
    Points:
    15
    Posts:
    3
    Joined:
    Jan 28, 2016

    Jan 28, 2016
    3
    0
    15
    Male
    ok thanks... will installing it wipe my phone?
     
  14. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    unfortunately yes, but your phone will work! But if you did make a back up previously you will recover all your apps, preferences, etc. So its not that bad...
     
  15. varr m

    varr m Lurker
    Rank:
    None
    Points:
    15
    Posts:
    3
    Joined:
    Jan 28, 2016

    Jan 28, 2016
    3
    0
    15
    Male
    thanks again.... but i will lose all my pics n vidz :(
     
  16. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    not if you have a sd card
     
    varr m likes this.
  17. BrowncoatMel

    BrowncoatMel Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Feb 6, 2016

    Feb 6, 2016
    7
    2
    6
    Hi, I have the same problem as Montejuli, and am attempting to follow the instructions given, but I can't get the computer to recognize my phone, and I've read the ReadMe file thoroughly but didn't find any instructions that worked. Any help would be awesome! Thanks!
     
  18. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    Hi there mate! That happened to me too, so read my reply on varr m's question about this problem. Here it is.
     
  19. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    @BrowncoatMel there are a few important things you need to check first before trying a RUU anyway - Montejuli has a US carrier and was therefore able to download the correct RUU for his phone and firmware version. If you are also on a US carrier you will probably be able to get the correct RUU, but you will also need to know what firmware version you phone has on it. That means checking how far the OTA update process got with installing new firmware - if indeed it was a Marshmallow OTA you were installing. Do you know what version of Android you had before trying the update install?
     
  20. Montejuli

    Montejuli Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jan 22, 2016

    Jan 22, 2016
    12
    5
    16
    Male
    @saltire oh yeah, i didn't mentioned all those things because i assumed BrowncoatMel read all previous comments. Thanks!
     
  21. BrowncoatMel

    BrowncoatMel Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Feb 6, 2016

    Feb 6, 2016
    7
    2
    6
    Hi there @Montejuli and @saltire, thanks for helping me out! I had read all comments in this thread, and wasn't getting anywhere, but I just tried a different USB cable and now it says fastboot usb, thankfully!
    Saltire, as to your questions, I live in the US and I just bought this phone brand new for Straight Talk service. It quit the upload at 1%, and I think it had Lollipop before. My hboot page says the OS is 6.12.401.4, so it was indeed installing Marshmallow when it quit.
    Do you see any problems with me attempting to upload Marshmallow now?
     
  22. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    @BrowncoatMel Ok, that's good that you have x.x.401.x firmware as that's a WWE version and tends to make certain files easier to get if we need them. Is Straight Talk your carrier (I'm in UK so don't recognise it)? If you do have 401 firmware though, there isn't a specific RUU available to you from the HTC US site. What we be useful is to get a screenshot of your bootloader screen, or boot your phone to the bootloader and post what's on the screen - specifically whether the bootloader is "Locked" or "Unlocked" and whether the phone is S-ON or S-OFF. Do you have a Win PC/laptop with the adb/fastboot tools installed? You can get it here if not:

    ADB Guide (updated 2014/11/11)

    along with instructions to install.

    Reboot phone to bootloader and plug in to PC (so you see FASTBOOT USB on bootloader screen). Open a command prompt window in the adb/fastboot folder on your PC - if in Explorer hold shift + right click, and pick "Open command window here" from context menu.

    Then type:

    fastboot devices (this is to check fastboot connects to phone ok, it should also return the phone serial number - write this down carefully as we might need it)

    If it does, then type:

    fastboot getvar all

    and post the info the command returns but scrub out your IMEI number and serial number. Need to know what the CID number is and that Version-main matches the firmware number 6.12.401.4.

    Note that if your bootloader shows "Locked", unfortunately we may end up in the situation where to get phone working again the process involved wipes your phone including the internal SD card. I'm going to do some digging as well, but just letting you know so you're aware of this.
     
  23. Armada_07

    Armada_07 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Feb 10, 2016

    Feb 10, 2016
    4
    1
    16
    Male
    Hi, I have the same problem. I have HTC M8 which was Unlocked (now I use carrier from my country). Here is the message I see on bootloader screen:

    *** Software Status: Official ***
    *** Locked ***

    @saltire , I followed your instructions and this is what the command returned. I`ll be very grateful if you could help me.

    (bootloader) version: 0.5
    (bootloader) version-bootloader: 3.19.0.0000
    (bootloader) version-baseband: 1.29.214500021.12G
    (bootloader) version-cpld: None
    (bootloader) version-microp: None
    (bootloader) version-main: 6.12.401.4
    (bootloader) version-misc: PVT SHIP S-OFF
    (bootloader) serialno:
    (bootloader) imei:
    (bootloader) imei2: Not Support
    (bootloader) meid: 00000000000000
    (bootloader) product: m8_ul_ca
    (bootloader) platform: hTCBmsm8974
    (bootloader) modelid: 0P6B10000
    (bootloader) cidnum: 11111111
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 0mV
    (bootloader) partition-layout: Generic
    (bootloader) security: off
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    (bootloader) commitno-bootloader: 76df2b54
    (bootloader) hbootpreupdate: 11
    (bootloader) gencheckpt: 0
     
  24. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    @Armada_07 When you say you have the same problem do you mean you accepted an OTA update but it didn't complete successfully, and will only boot to the stock recovery? What else have you tried to get the phone to reboot? Is there anything saved on the internal sd card storage that you want to keep?

    From the bootloader info I can see the phone was originally from AT&T, but the modelid is gsm plus you are s-off with SuperCID set - which are all good.

    Unfortunately your bootloader is locked though. There are a couple of ways to get back to a working phone but with bootloader locked they both involve wiping your device clean including the internal storage. Just want you to be aware of this and understand it means losing anything saved here including photos, documents, music etc.
     
  25. Armada_07

    Armada_07 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Feb 10, 2016

    Feb 10, 2016
    4
    1
    16
    Male
    @saltire Thank you for your quick response. Yes, I accepted OTA update and it didn`t complete successfully so the phone is only booting to the stock recovery.

    I tried wipe cache partition and wipe data/factory reset. I also tried "Reboot, HBoot, Fastboot, Recovery" options. The phone is still going into Android Recovery Mode.

    There is nothing saved on the internal sd card what I want to keep so wiping everything is not a problem.
     

HTC One M8

The HTC One M8 is the Taiwanese company's flagship phone for the first half of 2014. It built on its predecessor with an upgraded 5-inch 1080p display, Snapdragon 801 processor, 2GB of RAM, 32GB of internal storage, and an UltraPixel rear Duo Camera.
Tags:

Share This Page

Loading...