1. Download our Official Android App: Forums for Android!

Support HTC ONE M8 Stuck on "Update HTC Sense Home"

Discussion in 'Android Help' started by Mr Ali G, Mar 6, 2016.

  1. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    I tried to factory reset my phone after having some network issues. After I reset my phone, it got stuck on the update HTC sense home screen.

    I can swipe down into the notification tray and go into setting from there however the update screen will never go.



    my firmware is:

    **LOCKED**
    M8_UL PVT SHIP S-ON
    HBOOT-3.19.0.0000
    Radio-1.29.214500021.12g
    opendsp-v51.2.2-00593-m8974_FO.1015
    OS-6.12.401.4
    emmc-boot 2048MB


    Can someone please help thanks!!!

     

    Advertisement

  2. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    someone help?
     
  3. KJohns

    KJohns ROM/Application Developer
    Rank:
    None
    Points:
    113
    Posts:
    841
    Joined:
    Dec 1, 2011

    Dec 1, 2011
    841
    266
    113
    Male
    student/intern
    Illinois - U.S.
    Just to cut through potential troubleshooting issues - just find a download for a RUU and reflash the stock firmware - this should get you up and running again. What carrier and android versions were you on so i can direct you to downloads.
     
  4. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    Hello KJohns,
    Thanks for your reply.

    I'm on android 6.0 marshmallow and I'm on a UK carrier Three.

    Can you also link how to flash ruu because I don't know how all this works.

    Thanks again
     
  5. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    Do you have files/photos/stuff saved to internal storage that you want to try and keep? A RUU will completely wipe your phone so is really a last resort if nothing else will work first. Assuming you do have a WWE CID I can point you to a signed RUU if it comes to that. I'm not 100% sure what you mean when you say "it got stuck on the update HTC sense home screen." either? It sounds like the phone rebooted successfully, so do you mean an update of Blinkfeed got stuck?

    I would try a cache wipe from stock recovery first.
     
    Mr Ali G likes this.
  6. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    This is the screen I'm stuck on. I did a factory reset it was going all good until I finished the setup, this screen pops up. I cleared the cache already but still the same, I did a wipe/reset still no help.

    And all my photos and Stuff are saved on my SD card which I removed just in case I lose any data In it.
     

    Attached Files:

  7. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    Is that not just the HTC Launcher that gets updated via Play store? I can't remember as I switched to Nova straight-away. You could try and clear the app cache, and uninstall the update from Settings > Apps and then see if it will auto update again.
     
    Mr Ali G likes this.
  8. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    There is no HTC sense home app in the settings >apps.
    I tried to uninstall other apps but it won't let me

    Don't you think a ruu work?
     
  9. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    The RUU will work fine. We need to double check you have a WWE CID first. Do you have a PC and adb/fastboot tools setup?
     
    Mr Ali G likes this.
  10. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    I have a pc, but I don't know what abd/fastboot setup is. I am a noon with all this can you help me work it out?
     
  11. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    Edit: @scary alien @El Presidente <or any other friendly Mod> : if you happen to pass-by could you move this to the specific M8 sub-forum, as it's easier for me to keep track thanks :)


    @Mr Ali G ok, first get the mini sdktools download from this post:

    ADB Guide (updated 2014/11/11)

    which also has instructions for set up - you can ignore the parts about drivers.

    Next reboot phone to bootloader and plug in to PC (so you see FASTBOOT USB on bootloader screen). Open a command prompt window in the adb/fastboot folder on your PC - if in Explorer hold shift + right click, and pick "Open command window here" from context menu.

    Then type:

    fastboot devices (to check fastboot connects to phone ok, it should return your phone serial number)

    If it does, then type:

    fastboot getvar all

    and post the output here, but scrub out your IMEI number and serial number first before posting.
     
    #11 saltire, Mar 8, 2016
    Last edited: Mar 8, 2016
    Mr Ali G likes this.
  12. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    Hello Saltire,
    this is the output i got.

    C:\sdk-tools>fastboot getvar all
    (bootloader) version: 0.5
    (bootloader) version-bootloader: 3.19.0.0000
    (bootloader) version-baseband: 1.29.214500021.12G
    (bootloader) version-cpld: None
    (bootloader) version-microp: None
    (bootloader) version-main: 6.12.401.4
    (bootloader) version-misc: PVT SHIP S-ON


    (bootloader) imei2: Not Support
    (bootloader) meid: 00000000000000
    (bootloader) product: m8_ul
    (bootloader) platform: hTCBmsm8974
    (bootloader) modelid: 0P6B10000
    (bootloader) cidnum: HTC__001
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 0mV
    (bootloader) partition-layout: Generic
    (bootloader) security: on
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    (bootloader) commitno-bootloader: 76df2b54
    (bootloader) hbootpreupdate: 11
    (bootloader) gencheckpt: 0
    all: Done!
    finished. total time: 0.094s

    C:\sdk-tools>
     
  13. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    Ok, sorry not had time to get back to you. This is a relatively easy fix - just be warned though process will wipe you phone. Will get back to you.
     
    Mr Ali G likes this.
  14. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    Ok, thank you
     
  15. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    Mr Ali G likes this.
  16. Mr Ali G

    Mr Ali G Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 6, 2016

    Mar 6, 2016
    10
    1
    26
    Male
    Thank you very much saltire. It worked. You are a beast :D
     
    saltire likes this.
  17. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    No problem ;)
     

Share This Page

Loading...