1. Download our Official Android App: Forums for Android!

General huawei ascend p1 water damage

Discussion in 'Android Devices' started by vafa24, Jul 31, 2013.

  1. vafa24

    vafa24 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Oct 8, 2012

    Oct 8, 2012
    5
    0
    5
    hi,
    today i went fishing and the tide came in and my phone got wet.
    every thing is fine except for one thing.
    the touch screen doesn't work.
    i now put in rice. not the best method i know, but what else can i do.
    what now?
    thanks
     

    Advertisement

  2. scary alien

    scary alien not really so scary
    Moderator
    Rank:
     #9
    Points:
    2,138
    Posts:
    22,319
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    22,319
    23,814
    2,138
    Male
    space alien ;)
    Indy
    Wow, sorry to hear that, vafa24 :(.

    Usually, the first thing to do is remove the battery which I hope you did. Then, as you mentioned, find a good desiccant like dry rice and leave it in there for a good while (at least a day--longer = better).

    I've also heard that it's not just the water that ends-up zapping a device like this but the impurities in the water that get deposited on the electronics (like the touch screen components) causing shorts and such.

    Not sure what else to tell you, though, other than best of luck!

    Hopefully some others will chime-in with some helpful advice.
     
  3. vafa24

    vafa24 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Oct 8, 2012

    Oct 8, 2012
    5
    0
    5
    i left a few details out, that i thought i typed in.
    it was saltwater.
    at first it didn't turn on, just vibrated.
    then i went home and had to plug it in, then the touch screen didn't work.
    then i put in rice. (after turning off, taking out the sim card, sd card... etc)
    i took it out now, and everything seems to be fine.
    THANKS TO RICE
     
  4. vafa24

    vafa24 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Oct 8, 2012

    Oct 8, 2012
    5
    0
    5
    OK i have some problems.
    when i turned it on there was no sim card in it.
    it said no service, i was expecting insert sim.
    i then put my sim card in and it still said no service.
    i thought maybe if i turn airplane mode on and off it will work.
    i turned it on and then it immediately turned it off automatically.
    but the notfication bar indicates it is in airplane mode. but the setting bar says its off.
    help!!!!!!! please urgent help.
    it still says no service. even when i take the card out the notification bar says it is in airplane mode. i even turned it on and off.... helppppppp
     

Share This Page

Loading...