1. Check out our companion app, Forums for Android! Download from Google Play

Support Huawei Mercury Screen Not Responding?? No Water Damage!!

Discussion in 'Android Devices' started by gomezalexis3, Aug 4, 2012.

  1. gomezalexis3

    gomezalexis3 Member
    Thread Starter
    5

    Aug 4, 2012
    9
    0
    5
    I was texting fine then screen timed out pressed button tried to slide and no response. Removed Bsttery hard reset already and still wont respond. phone was fine no water damage ever and hasnt been dropped! Any ideas pls?? Thanks :)
     

    Advertisement

  2. rodawg71

    rodawg71 Well-Known Member
    36

    Dec 29, 2009
    78
    8
    36
    G14 Classified
    IL. Side
    Are you rooted? Running ATK? Have you ran an OTA?
     
  3. gomezalexis3

    gomezalexis3 Member
    Thread Starter
    5

    Aug 4, 2012
    9
    0
    5
    not rooted or anything no updates no changes everything was fine -.- have no idea what couldve caused it
     
  4. gomezalexis3

    gomezalexis3 Member
    Thread Starter
    5

    Aug 4, 2012
    9
    0
    5
    i know there was an issue with the evo if u got moisture on the screenn the touch response would fail till u reset it but dont know if it couldve been something like that
     
  5. Gmash

    Gmash Well-Known Member
    613

    Feb 3, 2011
    6,910
    3,191
    613
    Male
    neither Here nor There
    If you've already tried a hard reset I don't know what else to suggest. Take it to a corporate store and try to get a warranty replacement. Good luck!
     
  6. gomezalexis3

    gomezalexis3 Member
    Thread Starter
    5

    Aug 4, 2012
    9
    0
    5
    thanks i got one already just wondered what couldve happened to a brand new phone ;/
     
  7. Gmash

    Gmash Well-Known Member
    613

    Feb 3, 2011
    6,910
    3,191
    613
    Male
    neither Here nor There
    Just chalk it up to the electronics gods lol. Sometimes they like to smite perfectly innocent devices. :banghead:
     
  8. gomezalexis3

    gomezalexis3 Member
    Thread Starter
    5

    Aug 4, 2012
    9
    0
    5
  9. gixxer_751

    gixxer_751 Well-Known Member
    16

    Mar 11, 2011
    50
    4
    16
    i had this happen to me just yesterday .. it seems that the terminals on the battery werent pressing up against the terminals on the phone right.. insert the battery & kinda push the batter up into so that u know for sure that the leads are contacting each other.. i did this & it began working.. put the cover back on & no problems since.. & it actually have after doing a cold restart of my phone.. (pulling battery off while phone is powered)..
     

Share This Page

Loading...