1. Are you ready for the Galaxy S20? Here is everything we know so far!

Huawei P9 Lite, Mass Storage/MTP Option Disappeared

Discussion in 'Android Devices' started by auntyethel, Jul 6, 2017.

  1. auntyethel

    auntyethel Lurker
    Thread Starter

    Hi everyone

    I've had a P9 Lite for about 7 months. For file transferring, I've never bothered with any of the included software, have rather used the method of plugging it in, swiping down the notification area and selecting files, so it works like a flashdrive.

    However, yesterday I had it plugged in, used it, unplugged it. A little while later, plugged it back in... and nothing. It charges (takes a few seconds to register now) but doesn't appear connected to my PC at all (Windows 10). The option to select 'files' no longer appears, and it doesn't register in My Computer. As far as I know, I didn't do anything at all in my phone to change any USB options.

    I've tried using the *#*#2846579#*#* code and fiddling with the USB options, have tried multiple cables which work with a friend's P9 Lite, different PCs, but nothing.

    Is there anything I'm potentially missing? I've heard the other option would be to do a Factory Reset... If that is the last option I'll try it. However, as I'm a bit of an Android noob, would I have to back my phone up before doing this? I can't backup via USB now, so any recommendations for a backup program that would restore my phone exactly as it is after a reset?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. auntyethel

    auntyethel Lurker
    Thread Starter

    Lols... so tried it this morning, still didn't work. Now, all of a sudden, it does. I am confused. I'm glad it works again, but I'm not sure how consistent this will be.

    If this has happened to anyone else, please let me know!
     

Huawei P9 lite Forum

The Huawei P9 lite release date was April 2016. Features and Specs include a 5.2" inch screen, 13MP camera, 2/3GB RAM, HiSilicon Kirin 650 processor, and 3000mAh battery.

April 2016
Release Date
0
Reviews
Loading...

Share This Page

Loading...