1. Are you ready for the Galaxy S20? Here is everything we know so far!

I bricked my acer liquid E!

Discussion in 'Android Devices' started by mrubuto, Feb 8, 2011.

  1. mrubuto

    mrubuto Lurker
    Thread Starter


    I just got the acer liquid E yesterday and I was reading about romming. I followed the unclockr.com tutorial to a T and everything was going fine, once I finished the phone was supposed to reboot. except it never did.

    It loads the 2 first acer screens then just a black screen....

    I've tried the clean boot; pull batter. put battery back in. push volume up and down at the same time. choose clean boot.

    that did not help me.

    I've read of another method of taking out the battery then plugging in the USB cord, when you see the battery logo put battery back in and push volume up and the power button at the same time and then choose factory reset. I cant seem to get that method right.

    any advice would be great. I feel like such a idiot, i've only had this thing 24 hours

    1. Download the Forums for Android™ app!


  2. HustlinDaily

    HustlinDaily Android Expert

    Yeah TheUnlockr guide really is crap. That Superboot image can only be flashed on certain Eclair bins.

    So you can get into recovery? (the menu in which you choose a factory reset).

    Get back into recovery. Flash a .bin (make sure all Acer drivers are installed). Once the .bin is flashed, then root it using Malez Recovery.

    Here is a list of .bins: Acer Liquid, Liquid E, Liquid Metal ALL ROMs bin extract collection - Android @ MoDaCo (newer ones on the bottom, find one for Liquid E 512MB. Keep in mind, EMEA=Europe/Middle East/Africa and has many languages while AAP=Asia/Asia Pacific and only has English and Chinese Traditional/Han).

    Read the instructions here- [TUTORIAL] How to flash .bin files on Acer Liquid/E - Android @ MoDaCo

    If anything goes wrong, refer to this-

    [TIP] Dont try to restart phone during flash if it looses connection, or u will have a bricked liquid! [MOD PLEASE STICKY!] - Android @ MoDaCo

    Then install MalezRecovery- acer-liquid-malez-recovery - Project Hosting on Google Code

    The Google Code page for MalezRecovery has an Easy Root Kit. Install Recovery first (using the easy installer), then root the phone using that.
    mrubuto and thor124 like this.
  3. mrubuto

    mrubuto Lurker
    Thread Starter

    my cpu cant seem to see my android at all tho even when I'm in recovery mode = (


    on android.modaco.com I found this.

    I was able to flash it using a variation of these instructionc from user MALEZ

    Try this :

    1. Pull battery in and usb cable to phone and pc
    Press in order and without releasing
    1. < (back button)
    2. Camera
    3. (power) not always necessary
    Bootloader should appear. If that doesn't work unplug usb and unplugg battery and retry.

    If this still does not work you can also try this
    1. turn off your phone (and unplug usb if plugged)
    2. press camera + volume up and then without releasing this two buttons hit power and the phone will vibrate two times. Release all buttons.
    3. take the battery out and put it back (don't touch any button on the phone)
    4. connect the usb to your computer and you will the acer logo and then bootloader will pop up.

    Here you can reflash a correct boot.img and system.img. If you don't have one, I can give you.

    Keep us in touch
  4. HustlinDaily

    HustlinDaily Android Expert

    Hey Buto,

    Did either of those methods help?
  5. HustlinDaily

    HustlinDaily Android Expert

  6. AdroidAcer

    AdroidAcer Lurker

    how will i factory reset my acer liquid A1(an android)??

    please can anyone help??
  7. HustlinDaily

    HustlinDaily Android Expert

    What is wrong exactly?

    If your phone can boot and you want to do a factory reset, go to Settings-->Privicy-->Factory Data Reset

    If your phone cannot boot, then I would just try booting into recovery (remove/replace battery, hold down Volume Down+Camera+Power, phone vibrates 2-4 times, then hold down Camera+Power and phone boots into recovery) and do a factory reset it from there (in recovery, you will see a little Android robot with a ! in the middle, just press I believe Volume Up button to get a menu and you will find a factory reset option). If that doesn't work, boot into recovery (same method above) and flash a .bin (instructions above in this thread, preferably one for your region for warranty purposes).

    Let me know.
    jenny.devost likes this.
  8. rockstead

    rockstead Lurker

    Guys, I really need your help, I had a stock phone that had never been modifiedt and I think I totally messed up my wife's phone and I'm in trouble, I really need some help here.

    I have a Acer Liquid E, it was previously on Fido and it had 2.1 on it and my friend gave it to me and it worked fine on Roger's just by placing in a Roger's Sim Card.

    I went to Acer.Ca and I followed the instructions to apply the Froyo 2.2 update, I placed the update.zip and the image folder on the root of my SD card and followed the procdedures for rebooting, but instead of putting on a Fido 2.2 version, I put on the Roger's version.

    After 40 minutes, the phone never restarted, I pushed the power button and now when it starts, it just shows some red colors and does not start.

    I even followed the procedures for a clean boot (hard reset) and it still doesn't restart without those funny colours and then nothing.

    Help please.
Similar Threads - bricked acer liquid
  1. Troubleshooter03
  2. GeneralGhest
  3. ablix
  4. chrisabcabc
  5. krakengz
  6. Melvin Stark1
  7. Akshaj Chauriha
  8. itsmedude
  9. Charan Sai Pedireddi
  10. iamashrafulbd

Share This Page